Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Qt Creator Discussion :

Point d'arrêt et crash de l'application


Sujet :

Qt Creator

  1. #1
    Membre du Club
    Point d'arrêt et crash de l'application
    Bonjour à tous !

    Je me heurte à un petit problème pour le moins handicapant avec mon IDE.

    Le mode debug de QtCreator est devenu inutilisable sur mon projet C++/Qt.
    Cela fait, je crois, suite à un merge de master dans ma branche feature. Je suis la seule de mon groupe de projet à avoir ce problème, et le code mergé ne présente rien de particulier, pas même d'ajout de fichiers.

    L'application C++ s'exécute correctement en release et en debug.
    Sauf qu'en debug, avoir le moindre breakpoint chamboule tout :
    1) le debugger s'arrête correctement sur le break point pendant une seconde environ
    2) puis l'appli ferme
    3) laissant dans la fenêtre sortie de l'application, la simple ligne 11:37:32: Debugging has finished
    4) Et dans la fenêtre debugger log il y a, à gauche Debugger finished. et à droite ceci :
    dLLDB PROCESS ERROR: 1
    dNOTE: ENGINE SHUTDOWN FINISHED
    dState changed from InferiorStopOk(11) to EngineShutdownFinished(16)
    Debugger finished.
    dState changed from EngineShutdownFinished(16) to DebuggerFinished(17)
    Peu importe où se situe le breakpoint, dans le main ou bien plus tard dans l'appli, c'est au moment où l'exécution arrive dessus que ça crash.
    Je ne peux donc pas débugger mon appli pas à pas, ou encore observer la valeur de mes variables.

    J'ai essayé de supprimer les dossiers de build, et de nettoyer/recompiler la solution sans succès.
    J'ai tenté le reboot de l'IDE, et de la machine, sans succès également.
    J'ai également mis à jour XCode, sans succès.
    Je commence à être à court d'idée

    Je ne suis pas du tout compétente avec le debugger log, et donc je ne sais pas si le message posté plus haut peut éclairer.
    Pour les infos :
    - Qt Creator 4.9.1
    - Qt 5.12.3 (x86_64-little_endian-lp64 shared (dynamic) release build; by Clang 10.0.0 (clang-1000.11.45.5) (Apple)) on "cocoa"
    - sous macOS Mojave (10.14) [darwin version 18.7.0]
    - avec XCode version 11.0 (11A420a)

    Je vous remercie d'avance pour votre aide toute bienvenue
    À vaincre sans péril, on triomphe sans gloire.

  2. #2
    Responsable Qt & Livres



    Ça ressemble à un problème côté Qt Creator (dans la même veine que https://bugreports.qt.io/browse/QTCREATORBUG-13077).

    Tente une mise à jour de Qt (on en est à la 5.12.5/5.13.1) et de Qt Creator (4.10), ça résoudra peut-être le problème.
    Vous souhaitez participer aux rubriques Qt ou PyQt (tutoriels, FAQ, traductions), HPC ? Contactez-moi par MP.

    Créer des applications graphiques en Python avec PyQt5
    Créer des applications avec Qt 5.

    Pas de question d'ordre technique par MP !

  3. #3
    Membre du Club
    Bonjour dourouc05 merci pour ta réponse

    J'ai fais une mise à jour vers Qt 5.13.1 et Qt Creator 4.10.0 comme tu l'as conseillé, et tu sais quoi ? Ça remarche !
    Merci pour ton aide, je vais pouvoir reprendre le débug de mon appli en toute sérénité maintenant.

    Résolu !
    À vaincre sans péril, on triomphe sans gloire.