Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Raspberry Pi Discussion :

Grafana : connection "localhost:3000/login"


Sujet :

Raspberry Pi

  1. #1
    Nouveau Candidat au Club
    Homme Profil pro
    sans emplois
    Inscrit en
    octobre 2019
    Messages
    3
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 34
    Localisation : France, Haute Savoie (Rhône Alpes)

    Informations professionnelles :
    Activité : sans emplois

    Informations forums :
    Inscription : octobre 2019
    Messages : 3
    Points : 1
    Points
    1
    Par défaut Grafana : connection "localhost:3000/login"
    bonjour a tous,
    alors voila, j'essaye de me replonger dans les arduino, raspberry et compagnie afin de me faire une petite supervision (de courbe de temperature principalement);
    c'est donc avec attention que je commence a lire les tutoriaux ici présent et d'essayer en parrallele sur ce que je possede;
    j'ai donc reccuperé mon vieux raspberry, un B+
    j'ai reinstalle rasbian sur une nouvelle carte SD (car l'autre n'avais plus l'air de vouloir demmarer et j'arrive pas a la formater...)
    j'ai suivit le tuto pour installer influxdb sans soucis (enfin je crois!...)
    j'ai pas encore essayé de créer une base de donnée mais j'ai suivit le tuto sans probleme...
    =>https://projetsdiy.fr/tutoriel-influ...uration-macos/
    j'ai suivit le tuto suivant pour installer grafana;
    =>https://projetsdiy.fr/grafana-graphi...luxdb-partie1/
    sans probleme non plus,
    jusqu'a ce que l'on me demande de saisir "http://localhost:3000/login" dans le navigateur web
    et la, chromium m'indique que le site est innacessible, localhost n'autorise pas la connection,
    me demande de verifier la connection, le proxy et le parfeu;
    on me renvoit aussi le code erreur: "ERR_CONNECTION_REFUSED"
    je jardine un peu en vain, merci de m'aider pour la marche a suivre...
    cordialement
    fabien

  2. #2
    Expert éminent
    Avatar de transgohan
    Homme Profil pro
    Développeur Temps réel Embarqué
    Inscrit en
    janvier 2011
    Messages
    2 852
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Maine et Loire (Pays de la Loire)

    Informations professionnelles :
    Activité : Développeur Temps réel Embarqué

    Informations forums :
    Inscription : janvier 2011
    Messages : 2 852
    Points : 8 262
    Points
    8 262
    Par défaut
    Je ne connais pas ces utilitaires.
    Mais peut être une piste, dans le tutoriel il est fait mention d'un fichier graphana.ini qui indique le port.
    Et de base il est à 3000 et non 8080.

    Si cela ne résous pas le problème alors il faudra bien vérifier que les services installés tournent et ne sont pas en erreur.

    « Toujours se souvenir que la majorité des ennuis viennent de l'espace occupé entre la chaise et l'écran de l'ordinateur. »
    « Le watchdog aboie, les tests passent »

  3. #3
    Nouveau Candidat au Club
    Homme Profil pro
    sans emplois
    Inscrit en
    octobre 2019
    Messages
    3
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 34
    Localisation : France, Haute Savoie (Rhône Alpes)

    Informations professionnelles :
    Activité : sans emplois

    Informations forums :
    Inscription : octobre 2019
    Messages : 3
    Points : 1
    Points
    1
    Par défaut
    je dois t'avouer que je reste dubitatif!!
    j'ai pas tout compris!...
    d'ouest ce qu'il sort ce port 8080 ??

    si je veux verifier l'état des services installé, comment dois j'm'y prendre??

  4. #4
    Expert éminent
    Avatar de transgohan
    Homme Profil pro
    Développeur Temps réel Embarqué
    Inscrit en
    janvier 2011
    Messages
    2 852
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Maine et Loire (Pays de la Loire)

    Informations professionnelles :
    Activité : Développeur Temps réel Embarqué

    Informations forums :
    Inscription : janvier 2011
    Messages : 2 852
    Points : 8 262
    Points
    8 262
    Par défaut
    Je viens de relire mon message, et les tiens... Et j'en viens à la même conclusion.
    Ne tenir compte que de la seconde partie de mon message.

    (pour ma défense je couve un rhume depuis une semaine qui me rend patraque, vivement mon rendez-vous chez le médecin pour avoir des antibiotiques pour m'en débarrasser...)

    Tu devrais pouvoir obtenir la liste des services qui tournent avec :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    sudo service --status-all
    Et individuellement :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    sudo service <NOM_DU_SERVICE> status

    « Toujours se souvenir que la majorité des ennuis viennent de l'espace occupé entre la chaise et l'écran de l'ordinateur. »
    « Le watchdog aboie, les tests passent »

  5. #5
    Nouveau Candidat au Club
    Homme Profil pro
    sans emplois
    Inscrit en
    octobre 2019
    Messages
    3
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 34
    Localisation : France, Haute Savoie (Rhône Alpes)

    Informations professionnelles :
    Activité : sans emplois

    Informations forums :
    Inscription : octobre 2019
    Messages : 3
    Points : 1
    Points
    1
    Par défaut
    pas de soucis;
    tant qu'on avance...
    j'viens d'essayer tes deux commandes;
    la premieres m'affiche toute une liste de services ou je retrouve bien entre influxdb et grafana
    avec une petite difference qd meme un symbole + entre crochet devant influx mais un symbole - devant grafana...

    J'ai donc essayer la deuxieme commande juste pour grafana
    et j'obtiens:
    Loaded : loaded (/usr/lib/systemd/system/grafana-server.service; disabled; vendor preset: enabled
    Active : inactive (dead)
    Docs https://docs.grafana.org

    (dead) !?! c'est grave docteur??

  6. #6
    Expert éminent
    Avatar de transgohan
    Homme Profil pro
    Développeur Temps réel Embarqué
    Inscrit en
    janvier 2011
    Messages
    2 852
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Maine et Loire (Pays de la Loire)

    Informations professionnelles :
    Activité : Développeur Temps réel Embarqué

    Informations forums :
    Inscription : janvier 2011
    Messages : 2 852
    Points : 8 262
    Points
    8 262
    Par défaut
    C'est donc de là que vient le souci. Le service n'a pas réussi à se lancer.

    Il faudrait potasser leur documentation pour trouver s'ils enregistrent des logs qui pourraient expliquer la cause.
    Ou bien la commande permettant de lancer manuellement Grafana pour avoir les logs en temps réel dans un terminal.

    « Toujours se souvenir que la majorité des ennuis viennent de l'espace occupé entre la chaise et l'écran de l'ordinateur. »
    « Le watchdog aboie, les tests passent »

Discussions similaires

  1. [2014] Se connecter avec un login password
    Par Invité dans le forum Administration
    Réponses: 3
    Dernier message: 09/03/2017, 17h02
  2. Problème de se connecter à localhost
    Par mannouchka87 dans le forum Débuter
    Réponses: 3
    Dernier message: 09/09/2011, 16h46
  3. Connection Proxy - Sauvegard Login & Password
    Par JmL40 dans le forum Firefox
    Réponses: 0
    Dernier message: 29/01/2010, 15h59
  4. [LDAP]Se connecter via le login
    Par partyboy dans le forum APIs
    Réponses: 3
    Dernier message: 05/10/2005, 19h52
  5. ERROR 2003: Can't connect to MySQL server on 'localhost'...
    Par tonton54 dans le forum Installation
    Réponses: 8
    Dernier message: 25/04/2004, 16h51

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo