Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

SAS Base Discussion :

Import d'une base access sous SAS


Sujet :

SAS Base

  1. #1
    Futur Membre du Club
    Import d'une base access sous SAS
    Bonjour,

    Je viens vers vous par rapport à un problème qui me pénalise fortement: Je ne parviens pas à importer une base access sous sas!

    Mon code est le suivant:

    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    3
    PROC IMPORT TABLE=Ma_table OUT=out_table DBMS=ACCESS REPLACE;
    DATABASE=chemin\table_access.accdb;
    RUN;


    Après exécution je vois le message d'erreur suivant:
    ERROR: Le fichier _IMEX_.nom_table_access.DATA n'existe pas.
    ERROR: Import unsuccessful. See SAS Log for details.

    J'ai essayé de remplacer dans le code l'option ACCESS par ACCESCS mais j'ai un autre message d'erreur qui s'affiche:
    ERROR: Failed to connect to the Server: .
    Je travaille avec la version 9.4 de sas et sur la version de 2010 d'access.

    Pouvez-vous m'aider svp? Là je ne vois vraiment pas ce que je dois tenter....

    Bien cordialement,
    lilbiostat

  2. #2
    Membre à l'essai
    Précision sur configuration
    Bonjour,

    C'est SAS base en local que tu utilises ?
    Tu n'as pas de Enterprise Guide ?

    Si SAS local, où est ta base ACCESS ? En local aussi ? Ou sur un autre serveur ?

    Je n'ai pas SAS base en local avec moi, mais de mémoire tu peux aussi faire une importation avec "FICHIER/IMPORTER DES DONNEES".

    Il y a aussi la possibilité LIBNAME avec le moteur ACCESS.

  3. #3
    Futur Membre du Club
    Bonjour,
    Oui les deux logiciels sont en local. On a trouvé le problème en fait il s'agissait d'un problème de compatibilité de version.
    Sas était en 64bits et ACCESS en 32bits. Après avoir installé la bonne version d'ACCESS j'ai pu importé normalement.
    Merci beaucoup pour ta réponse c'est vrai qu'on ne pense pas toujours à l'import automatique!