Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Macros et VBA Excel Discussion :

Eviter le #REF!


Sujet :

Macros et VBA Excel

  1. #1
    Membre du Club
    Homme Profil pro
    Inscrit en
    novembre 2011
    Messages
    144
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : novembre 2011
    Messages : 144
    Points : 61
    Points
    61
    Par défaut Eviter le #REF!
    Bonjour à tous,

    j'ai une cellule A1 qui additionne des cellules avec la formule =SOMME(O1:O100)
    J'ai une macro qui efface la ligne si la cellule O(x)=0
    Si il n'y a rien à ajouter la cellule A1 provoque l'erreur #REF!


    J'aimerais faire apparaitre un 0 à la place de #REF!

    Est-ce possible?

    Merci de votre aide.

  2. #2
    Expert éminent sénior

    Profil pro
    Conseil, Formation, Développement - Indépendant
    Inscrit en
    février 2010
    Messages
    6 263
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Activité : Conseil, Formation, Développement - Indépendant

    Informations forums :
    Inscription : février 2010
    Messages : 6 263
    Points : 11 645
    Points
    11 645
    Par défaut
    Bonjour

    Ta description ne semble pas correspondre au fonctionnement d'Excel

    Peux-tu préciser ce que contiennent les lignes de la colonnes et le code d'effacement de ligne
    Chris

    Quand un homme a faim, mieux vaut lui apprendre à pêcher que de lui donner un poisson.
    Confucius

    ----------------------------------------------------------------------------------------------
    En cas de résolution, n'hésitez pas cliquer sur c'est toujours apprécié...

  3. #3
    Membre du Club
    Homme Profil pro
    Inscrit en
    novembre 2011
    Messages
    144
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : novembre 2011
    Messages : 144
    Points : 61
    Points
    61
    Par défaut
    Je me reponds à moi même
    j'ai trouvé une solution :
    Dans la formule de la case A1
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    =SI(ESTERREUR(SOMME(O1:O100));"0";SOMME(O1:O100))
    résolu,

    Merci à tous quand même

  4. #4
    Expert éminent sénior

    Profil pro
    Conseil, Formation, Développement - Indépendant
    Inscrit en
    février 2010
    Messages
    6 263
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Activité : Conseil, Formation, Développement - Indépendant

    Informations forums :
    Inscription : février 2010
    Messages : 6 263
    Points : 11 645
    Points
    11 645
    Par défaut
    RE

    Aujourd'hui on utilise plus simplement
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    =SIERREUR(SOMME(O1:O100);0)
    Utiliser 0 et non "0"
    Chris

    Quand un homme a faim, mieux vaut lui apprendre à pêcher que de lui donner un poisson.
    Confucius

    ----------------------------------------------------------------------------------------------
    En cas de résolution, n'hésitez pas cliquer sur c'est toujours apprécié...

  5. #5
    Membre averti
    Homme Profil pro
    Développeur .NET
    Inscrit en
    juin 2019
    Messages
    207
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Développeur .NET

    Informations forums :
    Inscription : juin 2019
    Messages : 207
    Points : 328
    Points
    328
    Par défaut
    Bonjour,
    en Ligne 1 tu colles un titre de colonne, O1="titre"
    comme ta plage fait 100 ligne elle va en O101.

    voilà la formule qui te permet de supprimer tes ligne =0
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    =SOMME(DECALER(O1;1;0):DECALER(O102;-1;0))
    bien évidement l’adresse de ta formule va s'adapté il faudra insérer une ligne avant d'ajouter une valeur!

  6. #6
    Membre du Club
    Homme Profil pro
    Inscrit en
    novembre 2011
    Messages
    144
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : novembre 2011
    Messages : 144
    Points : 61
    Points
    61
    Par défaut
    Merci à tous de votre aide et de vos conseils

    Sam

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Réponses: 10
    Dernier message: 18/07/2007, 17h36
  2. Réponses: 2
    Dernier message: 27/04/2004, 11h17
  3. Pb affichage avec un PaintBox (pour eviter scintillement)
    Par juan64 dans le forum C++Builder
    Réponses: 7
    Dernier message: 08/04/2004, 09h21
  4. [opengl] Comment eviter l'ordre de faces ?
    Par :GREG: dans le forum OpenGL
    Réponses: 3
    Dernier message: 02/03/2004, 19h14
  5. Eviter deux nombres identiques dans un tirage aléatoire
    Par moon tiger dans le forum Pascal
    Réponses: 5
    Dernier message: 25/11/2002, 09h57

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo