Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Membre à l'essai
    Homme Profil pro
    utilisateur office
    Inscrit en
    août 2016
    Messages
    25
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 56
    Localisation : Belgique

    Informations professionnelles :
    Activité : utilisateur office
    Secteur : Service public

    Informations forums :
    Inscription : août 2016
    Messages : 25
    Points : 24
    Points
    24

    Par défaut Rapport TextBox ou étiquette = valeur d'une requête

    bonjour,

    je cherche a afficher dans l’entête d'un rapport la valeur d'une requête dans le genre
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    [ZonTextParcour2].Value = request_ReqNumeroLigne.Expr1

    partir de la requête suivante

    Nom : capture1.JPG
Affichages : 49
Taille : 31,8 Ko

    Nom : Capture2.JPG
Affichages : 46
Taille : 17,1 Ko


    ou dois je passer par un autre chemin

    en faite cette donnée se trouve dans ma table d'origine mais sous la forme X1234 et je ne veux afficher que 1234
    la j'arrive a afficher X1234 je veux donc supprimer a l'affichage dans mon textbox de mon entête le premier caractère ou garder les 4 dernier selon le point de vue.

    j'y suis arriver dans mon formulaire avec les paramètre suivant

    Nom : 3.JPG
Affichages : 48
Taille : 33,2 Ko

    mais je ne retrouve pas cela dans un text box d'un rapport

    j'ai mème essayer de la récupérer a partir du formulaire

    mais pour que le rapport en tienne compte je dois au préalable cliquer dans le textbox du formulaire avant d'ouvrir le rapport. ce que je ne veux pas bien sur puisque se text box est automatique. et dépend de la sélection d'une liste déroulante a cote .

    Nom : 4.JPG
Affichages : 48
Taille : 18,0 Ko

    voila j’espère que je suis parvenu a me faire comprendre

    merci d'avance

  2. #2
    Modérateur

    Homme Profil pro
    Inscrit en
    octobre 2005
    Messages
    13 246
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Canada

    Informations forums :
    Inscription : octobre 2005
    Messages : 13 246
    Points : 20 089
    Points
    20 089

    Par défaut

    Bonjour.

    C'est un peu compliqué pour rien.

    Je te suggère de mettre dans ta source :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    =Mid([Forms]![TonForm]![TonChamp];2)
    Ça va lire directement la valeur du formulaire.

    Access va traduire de l'anglais au français pour toi.

    A+
    Vous voulez une réponse rapide et efficace à vos questions téchniques ?
    Ne les posez pas en message privé mais dans le forum, vous bénéficiez ainsi de la compétence et de la disponibilité de tous les contributeurs.
    Et aussi regardez dans la FAQ Access et les Tutoriaux Access. C'est plein de bonnes choses.

  3. #3
    Membre à l'essai
    Homme Profil pro
    utilisateur office
    Inscrit en
    août 2016
    Messages
    25
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 56
    Localisation : Belgique

    Informations professionnelles :
    Activité : utilisateur office
    Secteur : Service public

    Informations forums :
    Inscription : août 2016
    Messages : 25
    Points : 24
    Points
    24

    Par défaut helas ca fonctionne pas

    Désolé mais cela ne fonctionne pas ma textbox reste vide

  4. #4
    Modérateur

    Homme Profil pro
    Inscrit en
    octobre 2005
    Messages
    13 246
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Canada

    Informations forums :
    Inscription : octobre 2005
    Messages : 13 246
    Points : 20 089
    Points
    20 089

    Par défaut

    Ton formulaire est bien ouvert ?

    A+
    Vous voulez une réponse rapide et efficace à vos questions téchniques ?
    Ne les posez pas en message privé mais dans le forum, vous bénéficiez ainsi de la compétence et de la disponibilité de tous les contributeurs.
    Et aussi regardez dans la FAQ Access et les Tutoriaux Access. C'est plein de bonnes choses.

  5. #5
    Membre à l'essai
    Homme Profil pro
    utilisateur office
    Inscrit en
    août 2016
    Messages
    25
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 56
    Localisation : Belgique

    Informations professionnelles :
    Activité : utilisateur office
    Secteur : Service public

    Informations forums :
    Inscription : août 2016
    Messages : 25
    Points : 24
    Points
    24

    Par défaut

    oui puisque je lance le rapport a partir du formulaire, mais comme la donnée que je dois récupérer est affichée automatiquement sur le formulaire, et varie en fonction de la donnée sélectionnée dans la liste déroulante, il y a plusieurs liste déroulantes en cascade lorsque elles ont toutes etes validées un bouton rapport apparait . ce qui lance le rapport, j'arrive a récupérer toutes les donnée des liste déroulantes mais pas celle du text box, sauf si j'ai au préalable cliquer dans le text box, j'ai essaie avec la fonction "request" et également la fonction "setfocus" mais rien y fait la donnée n'est validée que si je place au préalable mon curseur dans le text box.
    merci d'avance

  6. #6
    Modérateur

    Homme Profil pro
    Inscrit en
    octobre 2005
    Messages
    13 246
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Canada

    Informations forums :
    Inscription : octobre 2005
    Messages : 13 246
    Points : 20 089
    Points
    20 089

    Par défaut

    Bonjour.

    Le textbox affiche bien une valeur ?

    A+
    Vous voulez une réponse rapide et efficace à vos questions téchniques ?
    Ne les posez pas en message privé mais dans le forum, vous bénéficiez ainsi de la compétence et de la disponibilité de tous les contributeurs.
    Et aussi regardez dans la FAQ Access et les Tutoriaux Access. C'est plein de bonnes choses.

  7. #7
    Membre à l'essai
    Homme Profil pro
    utilisateur office
    Inscrit en
    août 2016
    Messages
    25
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 56
    Localisation : Belgique

    Informations professionnelles :
    Activité : utilisateur office
    Secteur : Service public

    Informations forums :
    Inscription : août 2016
    Messages : 25
    Points : 24
    Points
    24

    Par défaut

    Citation Envoyé par marot_r Voir le message
    Bonjour.

    Le textbox affiche bien une valeur ?

    A+
    oui le text box affiche bien une valeur, mais lorsque je lance le rapport la valeur ne s'affiche pas sauf si j'ai au préalable sur le textbox et qu'il se met en surbrillance
    encore merci de votre aide

  8. #8
    Membre à l'essai
    Homme Profil pro
    utilisateur office
    Inscrit en
    août 2016
    Messages
    25
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 56
    Localisation : Belgique

    Informations professionnelles :
    Activité : utilisateur office
    Secteur : Service public

    Informations forums :
    Inscription : août 2016
    Messages : 25
    Points : 24
    Points
    24

    Par défaut

    Citation Envoyé par wappymil Voir le message
    oui le text box affiche bien une valeur, mais lorsque je lance le rapport la valeur ne s'affiche pas sauf si j'ai au préalable sur le textbox et qu'il se met en surbrillance
    encore merci de votre aide
    re bonjour, j'ai trouvé une solution en contournant ce problème, j'ai créé une requête avec toutes les valeur addocc, et j'ai créé le rapport sur base de cette requête.

    mais j'aimerai tout de même trouver la solution a cette configuration.

    raison pour laquelle je laisse cette discutions ouverte
    merci

  9. #9
    Modérateur

    Homme Profil pro
    Inscrit en
    octobre 2005
    Messages
    13 246
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Canada

    Informations forums :
    Inscription : octobre 2005
    Messages : 13 246
    Points : 20 089
    Points
    20 089

    Par défaut

    Citation Envoyé par wappymil Voir le message
    oui le text box affiche bien une valeur, mais lorsque je lance le rapport la valeur ne s'affiche pas sauf si j'ai au préalable sur le textbox et qu'il se met en surbrillance
    encore merci de votre aide
    C'est vraiment étrange, je n'ai jamais vu Access se comporter de cette façon.

    Peux-tu faire le test suivant ?

    Dans le code qui lance le rapport, mettre un point d'arrêt dans la marge (cliquer à l'extrême gauche de la ligne, ça va afficher un gros point rond).
    Accepter de passer en mode débogage quand Access te l'offre.
    Aller dans la fenêtre d'exécution immédiate ([ctrl][g] pour l'afficher si elle n'est pas visible).
    Taper :

    ? [Forms]![TonForm]![TonChamp] [Enter]

    puis

    ? [Forms]![TonForm]![TonChamp].Text [Enter]

    Est-ce que l'une ou l'autre des instructions affiche quelque chose ?

    A+
    Vous voulez une réponse rapide et efficace à vos questions téchniques ?
    Ne les posez pas en message privé mais dans le forum, vous bénéficiez ainsi de la compétence et de la disponibilité de tous les contributeurs.
    Et aussi regardez dans la FAQ Access et les Tutoriaux Access. C'est plein de bonnes choses.

  10. #10
    Membre à l'essai
    Homme Profil pro
    utilisateur office
    Inscrit en
    août 2016
    Messages
    25
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 56
    Localisation : Belgique

    Informations professionnelles :
    Activité : utilisateur office
    Secteur : Service public

    Informations forums :
    Inscription : août 2016
    Messages : 25
    Points : 24
    Points
    24

    Par défaut

    bonjour désolé pour le petit retard
    je vais laisser cette question en suspend car j'ai prix un autre chemin qui fonctionne
    je vais mettre cette discutions en résolu et je ferais ce test plus tard si tu veux bien.
    j'y reviendrai car j'aime pas rester dans l'ignorance loll.
    encore merci de ton aide.
    a plus
    charles

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. [Débutant] comment récupérer la valeur d'une requête?
    Par Athorus dans le forum Servlets/JSP
    Réponses: 1
    Dernier message: 27/02/2007, 17h59
  2. [SQL] Affichage d'une valeur depuis une requête
    Par kitty2006 dans le forum PHP & Base de données
    Réponses: 7
    Dernier message: 19/09/2006, 16h38
  3. Récupération valeurs d'une requête
    Par bobic dans le forum JDBC
    Réponses: 3
    Dernier message: 19/09/2006, 14h51
  4. Valeur d'une requête dans 1 formulaire
    Par liop49 dans le forum Requêtes et SQL.
    Réponses: 11
    Dernier message: 07/07/2006, 10h02
  5. passer une valeur d'une requête a une table
    Par LesLemmings dans le forum Requêtes et SQL.
    Réponses: 1
    Dernier message: 09/06/2006, 14h13

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo