Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Nouveau membre du Club
    Probleme de configuration des accès de mkframework à mysql pour un user avec password
    Bonjour chère membre

    je travail habituellement avec le framework sur wamp local avec le root sans mot de passe. et tout fonctionne très bien.

    mon ministère à acquit un serveur pour le développement. et j'ai configurer wamp pour accès distant. j'ai défini un mot de passe pour le root et j'ai aussi créer un utilisateur avec mot de passe. tout fonctionne correctement. je me connecte à distance à mon serveur web ainsi que phpmyadmin pour créer ma base de données sans problème

    Pb: j'ai déployer la toute dernier version du MKframework sur mon serveur web, et j’essaie de me connecter à la base de donnée avec les paramètres pour générer mon modèle mais erreur d'accès.
    si quelqu'un à une solution de comment de connecter avec un utilisateur MySQL avec mot de passe. qu'il me passe un coup de main. Merci d'avance


    //-----------------------------voici ma config (connexion.ini.php)---------------------------------------------------//

    000002 [db]
    [EDITER] 000003 pdoPostgresqlExple.dsn = "pgsql:dbname=postgres;host=localhost"
    [EDITER] 000004 pdoPostgresqlExple.sgbd = pdo_pgsql
    [EDITER] 000005 pdoPostgresqlExple.username = postgres
    [EDITER] 000006 pdoPostgresqlExple.password = root
    [EDITER] 000007
    [EDITER] 000008 pdoMysqlExple.dsn = "mysql:dbname=gestmaintenance;host=192.168.105.21"
    [EDITER] 000009 pdoMysqlExple.sgbd = pdo_mysql
    [EDITER] 000010 pdoMysqlExple.username = MyDbAdmin
    [EDITER] 000011 pdoMysqlExple.password = Admin123$

    [EDITER] 000012
    [EDITER] 000013 pdoSqliteExple.dsn = "sqlite:/var/www/test4.sqlite"
    [EDITER] 000014 pdoSqliteExple.sgbd = pdo_sqlite
    [EDITER] 000015 pdoSqliteExple.username = root
    [EDITER] 000016 pdoSqliteExple.password = root
    [EDITER] 000017
    [EDITER] 000018 firebirdExple.dsn = "firebird:host=localhost;dbname=/var/www/firebirdDb"
    [EDITER] 000019 firebirdExple.sgbd = pdo_firebird
    [EDITER] 000020 firebirdExple.username = root
    [EDITER] 000021 firebirdExple.password = root
    [EDITER] 000022
    [EDITER] 000023 sqlserverExple.dsn = "dblib:dbname=blog;host=localhost"
    [EDITER] 000024 sqlserverExple.sgbd = pdo_mssql
    [EDITER] 000025 sqlserverExple.username = root
    [EDITER] 000026 sqlserverExple.password = root
    [EDITER] 000027
    [EDITER] 000028 oracleExple.dsn =
    [EDITER] 000029 oracleExple.sgbd = oracle
    [EDITER] 000030 oracleExple.username = username
    [EDITER] 000031 oracleExple.password = pass
    [EDITER] 000032 oracleExple.database = myOracleDb
    [EDITER] 000033 oracleExple.hostname = myOracleHostname
    [EDITER] 000034
    [EDITER] 000035
    [EDITER] 000036 xmlExple.dsn =
    [EDITER] 000037 xmlExple.sgbd = xml
    [EDITER] 000038 xmlExple.database = ../data/xml/base/
    [EDITER] 000039
    [EDITER] 000040 csvExple.dsn =
    [EDITER] 000041 csvExple.sgbd = csv
    [EDITER] 000042 csvExple.database = ../data/csv/base/
    [EDITER] 000043
    [EDITER] 000044 jsonExple.dsn =
    [EDITER] 000045 jsonExple.sgbd = json
    [EDITER] 000046 jsonExple.database = ../data/json/base/
    [EDITER] 000047
    [EDITER] 000048 mongodb.dsn = "mongodb://monuser:pass@localhost:27017/mabase"
    [EDITER] 000049 mongodb.sgbd = mongodb
    [EDITER] 000050 mongodb.database = mabase


    ///-----------------------------------------Erreur généré------------------------------------------------------//
    SQLSTATE[HY000] [1045] Acc�s refus� pour l'utilisateur: 'MyDbAdmin'@'@MAE-TEST-WEBSRV' (mot de passe: OUI)
    #0 C:\wamp\www\mkframeworkPackage-1.2.0\Lib\mkframeworkLib\sgbd\pdo\sgbd_pdo_mysql.php(80): PDO->__construct('mysql:dbname=ge...', 'MyDbAdmin', 'Admin123$\n')
    #1 C:\wamp\www\mkframeworkPackage-1.2.0\Lib\mkframeworkLib\abstract\abstract_sgbd_pdo.php(237): sgbd_pdo_mysql->connect()
    #2 C:\wamp\www\mkframeworkPackage-1.2.0\Lib\mkframeworkLib\sgbd\pdo\sgbd_pdo_mysql.php(38): abstract_sgbd_pdo->query('SHOW TABLES')
    #3 C:\wamp\www\mkframeworkPackage-1.2.0\Lib\mkframeworkLib\abstract\abstract_model.php(216): sgbd_pdo_mysql->getListTable()
    #4 C:\wamp\www\mkframeworkPackage-1.2.0\Builder\module\builderTools\main.php(38): abstract_model->getListTable()
    #5 C:\wamp\www\mkframeworkPackage-1.2.0\Builder\module\mods\all\model\main.php(22): module_builderTools->getListTablesFromConfig('pdoMysqlExple')
    #6 C:\wamp\www\mkframeworkPackage-1.2.0\Lib\mkframeworkLib\class_layout.php(107): module_mods_all_model->_index()
    #7 C:\wamp\www\mkframeworkPackage-1.2.0\Builder\module\builder\main.php(292): _layout->addModule('main', 'mods_all_model:...')
    #8 C:\wamp\www\mkframeworkPackage-1.2.0\Lib\mkframeworkLib\class_root.php(250): module_builder->_editembedded()
    #9 C:\wamp\www\mkframeworkPackage-1.2.0\Builder\public\index.php(49): _root->run()


    Nb: j'ai testé la config avec tous les utilisateurs et leur mot de passe. c'est le même problème


    cordialement !

  2. #2
    Rédacteur

    Bonjour,
    Cela vient du fait que dans votre cas vous n avez plus le serveur Web et mysql sur le même serveur.
    Il vous faut créer /modifier votre user mysql pour qu il soit autorisé à partir d une ip externe

    En SQL:
    GRANT ALL PRIVILEGES ON database_name.* TO 'username'@'%' IDENTIFIED BY 'password'

    Ce qui est important ici c est le @'%' qui signifie de n importe quel ip, une fois le problème réglé, je vous invite à remplacer le % par l IP de votre serveur Web
    Framework php sécurisé et simple à prendre en main avec générateur web http://mkframework.com/ (hebergé sur developpez.com)
    Mes cours/tutoriaux

  3. #3
    Nouveau membre du Club
    toujpours problème
    Boinjour imikado.

    j'ai fais ce que tu m'a suggérer et même plus. mais ça fonctionne pas.
    j'ai créer un utilisateur sans mot de passe et ça marche.

    donc question: Comment est ce que je pourrai héberger mes applications quand je constate que ça ne marche pas avec les utilisateur avec mot de passe.

  4. #4
    Rédacteur

    Le problème vient peut etre d'un caractère dans le mot de passe, vous pouvez essayer avec un mot de passe très simple genre pass ?
    l'erreur c'est encore un "accès refusé" ? mais il affiche bien un utilisateur @'%' ?

    vous avec un accs au serveur mysql ? vous pouvez essayer de vous y connecter avec mysql workbench par exemple ?
    Framework php sécurisé et simple à prendre en main avec générateur web http://mkframework.com/ (hebergé sur developpez.com)
    Mes cours/tutoriaux

###raw>template_hook.ano_emploi###