Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Candidat au Club
    utilisation d'un contenu de cellule pour faire reference à un tablau nommé
    bonjour,
    je sèche sur quelque chose qui me semblait simple, je souhaite utiliser le contenu d'une cellule pour faire appel à une reference de tableau nommé exemple avec la recherchev : (ref de recherche;tableau1;n°index col;faux) et bien à la place de tableau1 je souhaite utiliser le contenu d'une cellule.
    est ce possible ?
    par avance merci

  2. #2
    Rédacteur

    Bonjour,
    à la place de tableau1 je souhaite utiliser le contenu d'une cellule.
    Est-ce que cela signifie que le contenu de la cellule contient le nom d'un tableau ?
    Dans l'affirmative, il faut utiliser la fonction INDIRECT faisant référence à cette cellule
    Soit
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    =RECHERCHEV(A2;INDIRECT(B2);2;FAUX)

    B2 contient le nom du tableau
    Philippe Tulliez
    Ce que l'on conçoit bien s'énonce clairement, et les mots pour le dire arrivent aisément. (Nicolas Boileau)
    Lorsque vous avez la réponse à votre question, n'oubliez pas de cliquer sur et si celle-ci est pertinente pensez à voter
    Mes tutoriels : Utilisation de l'assistant « Insertion de fonction », Les filtres avancés ou élaborés dans Excel
    Quelques contributions : USERFORM - Créer, Consulter, Modifier et Supprimer des enregistrements à l'aide d'un formulaire - Géolocalisation d'une adresse avec Excel et Google sans VBA

  3. #3
    Membre du Club
    Bonjour,

    Je rebondis sur cette discussion. J'ai la même difficulté à mettre en paramètre le nom de mon tableau dans INDIRECT.
    Je voudrais dans ma SOMME.SI entrer une plage comme MONTABLEAU[MACOLONNE] et je n'y parviens pas.

    Avec MONTABLEAU étant une valeur dans une colonne à gauche de ma formule.

    Merci beaucoup pour votre aide.

  4. #4
    Rédacteur

    Bonjour,
    Cela fonctionne exactement comme avec RECHERCHEV. La cellule référencée dans INDIRECT doit contenir la bonne chaîne de caractères

    Exemple sans INDIRECT
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    =SOMME.SI(T_Test[Ca];">1000")


    Exemple avec INDIRECTC30 contient la chaîne T_Test[CA]
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    =SOMME.SI(INDIRECT(C30);">1000")
    Philippe Tulliez
    Ce que l'on conçoit bien s'énonce clairement, et les mots pour le dire arrivent aisément. (Nicolas Boileau)
    Lorsque vous avez la réponse à votre question, n'oubliez pas de cliquer sur et si celle-ci est pertinente pensez à voter
    Mes tutoriels : Utilisation de l'assistant « Insertion de fonction », Les filtres avancés ou élaborés dans Excel
    Quelques contributions : USERFORM - Créer, Consulter, Modifier et Supprimer des enregistrements à l'aide d'un formulaire - Géolocalisation d'une adresse avec Excel et Google sans VBA

###raw>template_hook.ano_emploi###