Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

EDI Delphi Discussion :

Plus d'accès à Delphi (10.3)


Sujet :

EDI Delphi

  1. #1
    Membre expérimenté
    Plus d'accès à Delphi (10.3)
    Bonjour
    J'ai une licence Delphi 10.3 (Delphi 10.2 Tokyo Professional Named User Upgrade from XE7 or later, Date d'expiration de la licence: Illimité
    ) achetée il y près d'un an. Et aujourd'hui à chaque lancement il me propose un écran d''enregistrement et je ne peux plus utiliser Dephi !
    Si je remplis l'écran d'enregistrement il me donne un message 'vous n'êtes pas autorisé à utiliser RAD Studio pour windows'.
    Bon je bloque là .. une idée ?

  2. #2
    Membre émérite
    Bonjour,

    Le plus simple est de contacter le support Embarcadero :

    https://supportforms.embarcadero.com/

  3. #3
    Rédacteur/Modérateur


  4. #4
    Rédacteur/Modérateur

    Bonjour,

    tu as de la chance d'avoir un écran, mon EDI clignotait et je n'avais accès à rien https://www.developpez.net/forums/d1958270/environnements-developpement/delphi/edi/hyper-mesaventure-lancement-rio-renouvellement-licence/
    Je confirme que modifier le registre fonctionne
    La seule chose absolue dans un monde comme le nôtre, c'est l'humour. » Albert Einstein

    Delphi installés : D3,D7,D2010,XE4,XE7,D10 (Tokyo, Rio, Sidney) et peut être quelques autres
    SGBD : Firebird 2.5, 3, SQLite
    générateurs Etats : FastReport, Rave, QuickReport
    OS : Window Vista, Windows 10, Ubuntu, Androïd

  5. #5
    Membre expérimenté
    Bonjour,

    Pouvez vous essayer ceci?

    > > 1) shut the IDE down.
    > > 2) run regedit
    > > 3) go to
    > > HKEY_CURRENT_USER\Software\Embarcadero\BDS\20.0\Globals
    > > 4) change the value of "LicenseNotificationEnabled" to "0" (NOTE: it is a
    > > string).
    > > 5) start the IDE and see if that affects the issue.

  6. #6
    Membre expérimenté
    suite...
    Bonjour à tous
    Merci pour vos réponses mais le pb rencontré n'est pas celui de "l'écran qui clignote" en effet je suis en 10.3 (pas en 10.3.1). En fait le comportement est celui que j'aurais si ma licence n'était pas enregistrée (ce qui n'est pas le cas, le gestionnaire de licence me l'indique).
    Bon j'ai contacté le support Barnsten (réponse rapide...) mais en parallèle j'ai installé la 10.3.1 sur laquelle j'avais fait l'impasse (bug de l'écran qui clignote, pas bcp de valeur ajoutée et surtout tous les logiciels tiers à réinstaller !!).
    Bon à priori ça semble avoir résolu mon problème (mais pkoi ????) Je vous tiens au courant.

  7. #7
    Membre expérimenté
    Citation Envoyé par Maxime Capellot Voir le message
    Bonjour,

    Pouvez vous essayer ceci?

    > > 1) shut the IDE down.
    > > 2) run regedit
    > > 3) go to
    > > HKEY_CURRENT_USER\Software\Embarcadero\BDS\20.0\Globals
    > > 4) change the value of "LicenseNotificationEnabled" to "0" (NOTE: it is a
    > > string).
    > > 5) start the IDE and see if that affects the issue.
    Merci Maxime, j'avais vu ce post mais en 10.3 cette clef n'existe pas (et résout un autre bug).

  8. #8
    Membre expérimenté
    Citation Envoyé par SergioMaster Voir le message
    Bonjour,

    tu as de la chance d'avoir un écran, mon EDI clignotait et je n'avais accès à rien https://www.developpez.net/forums/d1...ement-licence/
    Je confirme que modifier le registre fonctionne
    En fait non car l'écran que l'on me fournit est l'écran d'enregistrement de la licence.. qui ne fonctionne pas et du coup je n'ai pas du tout accès à l'EDI.

  9. #9
    Membre expérimenté
    Tout est OK..
    Bon je confirme la réinstallation en 10.3.1 a résolu le problème...

###raw>template_hook.ano_emploi###