Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

EDI Delphi Discussion :

Transfert de composants entre versions


Sujet :

EDI Delphi

  1. #1
    Membre émérite
    Transfert de composants entre versions
    Bonjour

    Je viens d'installer RIO en plus de Tokyo.
    Maintenant, je vais devoir installer dans RIO tous les composants que j'avais dans Tokyo.
    Ça va me prendre du temps :-(

    à moins qu'une astuce que je ne connais pas existe pour aller vite ??

  2. #2
    Membre émérite
    Bonjour,

    je ne sais plus si l'outil de migration (migrationtool.exe) qui se trouve dans le répertoire Bin :

    C:\Program Files (x86)\Embarcadero\Studio\20.0\bin

    prend en compte la partie composants.

  3. #3
    Membre émérite
    OOOhhh ... Salut Thierry

    Comment ça va ?

    J'ai testé migrationtool.exe mais même en cochant toutes les options, il n'y pas les composants dans le fichier de sortie.
    Je me suis débrouillé en refaisant tout à la main.
    Il ne me reste plus que le problème avec IP*Works et je ne trouve aucune indication sur leur site.
    Je crois que je vais devoir désinstaller la version Tokyo mais ça ne m'arrange pas du tout :-(

  4. #4
    Rédacteur/Modérateur

    Citation Envoyé par Papy214 Voir le message

    Il ne me reste plus que le problème avec IP*Works et je ne trouve aucune indication sur leur site.
    Je crois que je vais devoir désinstaller la version Tokyo mais ça ne m'arrange pas du tout :-(
    Elle s'est installée sur mes deux versions quand j'ai fait mon installation "vierge"
    La seule chose absolue dans un monde comme le nôtre, c'est l'humour. » Albert Einstein

    Delphi installés : D3,D7,D2010,XE4,XE7,D10 (Tokyo, Rio, Sidney) et peut être quelques autres
    SGBD : Firebird 2.5, 3, SQLite
    générateurs Etats : FastReport, Rave, QuickReport
    OS : Window Vista, Windows 10, Ubuntu, Androïd

  5. #5
    Membre émérite
    Citation Envoyé par Papy214 Voir le message
    OOOhhh ... Salut Thierry

    Comment ça va ?

    J'ai testé migrationtool.exe mais même en cochant toutes les options, il n'y pas les composants dans le fichier de sortie.
    Je me suis débrouillé en refaisant tout à la main.
    Il ne me reste plus que le problème avec IP*Works et je ne trouve aucune indication sur leur site.
    Je crois que je vais devoir désinstaller la version Tokyo mais ça ne m'arrange pas du tout :-(
    Je vais bien merci. Bon pas de chance pour l'outil de migration. Pour IPWorks en ce qui me concerne, ne les ayant jamais installé su plusieurs versions je n'ai pas été confronté au problème.

  6. #6
    Membre émérite
    Je l'utilisais juste pour le composant ftp.
    C'est pas grave, je vais remplacer par le composant Indy pur ne pas perdre de temps.

  7. #7
    Membre expérimenté
    A ma connaissance l'outil de migration (que je n'utilise jamais) ne prend en compte que les options de Delphi.
    Rien pour le moment ne permet d'installer automatiquement des composants tiers d'une version à l'autre ni de parcourir ce qui est installé depuis GetIt sur une version pour le remettre sur la seconde (mais ça, ça peut évoluer dans les mois qui viennent si une demande de nouvelle fonctionnalité est saisie sur quality.embarcadero.com )

  8. #8
    Membre actif
    J'arrive un peu tard, mais tu aurais pu essayer remplir la base de registre avec un petit script.

    Avec Berlin, tous les paquets connus de l'ide se trouvent dans
    "Ordinateur\HKEY_CURRENT_USER\Software\Embarcadero\BDS\18.0\Known Packages"

    On travaille avec plusieurs projets qui utilisent les mêmes composants, mais par forcément de la même version. Du coup on a un script qui permet de renseigner les entrées dans la base de registre.

  9. #9
    Membre émérite
    Il n'est jamais trop tard pour bien faire.

    C'est vrai que je pouvais passer par cette méthode, d'ailleurs en faisant une copie "aménagée" de l'arborescence de la 19.0 mais je me disais qu'il y avait peut-être un outil déjà écrit pour ça.
    D'ailleurs, il faudrait que l'éditeur pense à inclure cette possibilité quand on installe une nouvelle version.
    Ou tout au moins, l'inclure dans l'outil de migration. Ça permettrait de gagner du temps.

    Merci tout de même d'avoir proposé cette solution.

    Comme quoi, ce qu'on dit sur les "blondes" ......

  10. #10
    Membre émérite
    Et sinon, pour les IP*Works, j'ai posté un message au support nsoftware qui m'a rapidement répondu en m'envoyant le setup, ce qui a réglé le problème.
    LE problème vient en fait de GetIt.
    Ces gens sont très efficaces ...

  11. #11
    Rédacteur/Modérateur

    Citation Envoyé par Papy214 Voir le message

    LE problème vient en fait de GetIt.
    Ce n'est pas le seul paquet Getit qui pose problème hélas, pratique mais pas toujours ...
    La seule chose absolue dans un monde comme le nôtre, c'est l'humour. » Albert Einstein

    Delphi installés : D3,D7,D2010,XE4,XE7,D10 (Tokyo, Rio, Sidney) et peut être quelques autres
    SGBD : Firebird 2.5, 3, SQLite
    générateurs Etats : FastReport, Rave, QuickReport
    OS : Window Vista, Windows 10, Ubuntu, Androïd

  12. #12
    Membre émérite
    Citation Envoyé par Papy214 Voir le message
    C'est vrai que je pouvais passer par cette méthode, d'ailleurs en faisant une copie "aménagée" de l'arborescence de la 19.0 mais je me disais qu'il y avait peut-être un outil déjà écrit pour ça.
    D'ailleurs, il faudrait que l'éditeur pense à inclure cette possibilité quand on installe une nouvelle version.

    En fait ce n'est pas si simple que ça à faire comme outil. Il n'y a pas de garanties par exemples selon les editeurs de composants que les packages aient le même nom selon les versions (Certains mettent dans le nom du package la version de Delphi pour pouvoir avoir les différents packages selon les versions), ou même que les composants soient disponibles dans la nouvelle version....etc. Donc il ne suffit pas juste d'avoir un outil qui migre les clés de la base de registre

###raw>template_hook.ano_emploi###