Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Qt Creator Discussion :

Spécifier une version d'OS cible


Sujet :

Qt Creator

  1. #1
    Nouveau membre du Club
    Spécifier une version d'OS cible
    Bonjour à tous,

    plutôt nouveau dans le domaine, je ne suis pas un pur développeur mais plutôt bidouilleur qui développe quelques outils simple en Qt ou openFrameworks.

    ma question est plus orientée configuration de compilation que de code à proprement parler.

    J'ai une application ultra simple (player vidéo) que j'ai développé sur ma machine mais qui au final tournera sur une autre machine : ma machine de développement est un macbook pro sous macOS Mojave (10.14) sous l'IDE QtCreator 4.8.1. Ma machine cible sera un vieux macbook sous OSX Snow Leopard (10.6)

    J'essaie de trouver un moyen de compiler mon code pour qu'il soit compatible 10.6 mais je ne sais pas comment déclarer cela dans mon projet.

    Merci pour votre aide

  2. #2
    Nouveau membre du Club
    je viens d'insérer cette ligne dans l'étape de compilation

    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    QMAKE_CXXFLAGS += -mmacosx-version-min=10.6


    Mais je vois un warning me disant

    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    avertissement : overriding '-mmacosx-version-min=10.6' option with '--target=x86_64-apple-macosx10.9-macho' [-Woverriding-t-option]


    Cela veut il dire que je ne peut pas compiler pour autre chose que minimum 10.9 ?