Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Membre habitué
    Interbase 2017 - Connection rejected by remote interface
    Salut à tous.
    Je viens d'installer la version 2017 d'Interbase (32Bits) sur une machine où tourne également Firebird 2.5 32Bits.
    Interbase Manager m'indique que le serveur "is currently Running" mais en utilisant IBConsole, quand je tente de connecter le serveur (Local Server gds_db), j'ai cette put*** d'erreur :



    Je précise que j'ai fait l'essai en désactivant le pare-feu et l'anti-virus.
    Cette même erreur apparaît bien sûr chaque fois que tente d'ouvrir une base à partir d'une application Delphi (via, par exemple, le composant FDConnection).
    Cette erreur est encore présente en tentant une connexion via l'explorateur de données de l'EDI.
    Autre précision qui épaissit le mystère : en utilisant IBExpert, je parviens sans problème à créer/connecter/consulter n'importe quelle base Interbase (employee.gdb par exemple) pourvu que le serveur soit lancé.

    Ké passa ?

  2. #2
    Rédacteur/Modérateur

    Bonjour,
    Ké passa ?
    en soit rien de bien nouveau encore que c'est généralement l'inverse (Interbase puis Installation de Firebird) qui est le plus fréquent.
    Plusieurs possibilités :
    - La bibliothèque gds32.dll est écrasée par celle de Firebird (c'est dans les options d'installation de Firebird)
    - Le port d'écoute est le même 3050 pour firebird comme interbase (il est facile de tester en arrêtant le service Firebird)
    Autre précision qui épaissit le mystère : en utilisant IBExpert,

    ce n'en est pas un car IBExpert se connecte aux Dll des SGBD (répertoires d'installation) et non comme IBConsole qui fait "confiance" aux dll de System32 ou Syswow64
    La seule chose absolue dans un monde comme le nôtre, c'est l'humour. » Albert Einstein

    Delphi installés : D3,D7,D2010,XE4,XE7,D10 (Tokyo, Rio, Sidney) et peut être quelques autres
    SGBD : Firebird 2.5, 3, SQLite
    générateurs Etats : FastReport, Rave, QuickReport
    OS : Window Vista, Windows 10, Ubuntu, Androïd

  3. #3
    Membre habitué
    Bien joué SergioMaster !

    Sur une autre machine, j'ai carrément désinstallé FireBird et là ... bingo ! ca marche !
    Je vais "bidouiller" pour faire cohabiter les deux sur ma machine de développement car j'ai besoin de ces deux serveurs.

    Merci.

  4. #4
    Rédacteur/Modérateur

    Pour Interbase je ne sais plus, mais changer le port par défaut de Firebird est assez simple trouver le fichier firebird.conf et modifier en fonction
    (en mode administrateur car ce fichier se trouve certainement dans program files/firebird) c'est ici que ça se passe
    # ----------------------------
    # TCP Protocol Settings
    #
    # The TCP Service name/Port number to be used for client database
    # connections.
    #
    # It is only necessary to change one of the entries, not both. The
    # order of precendence is the 'RemoteServiceName' (if an entry is
    # found in the 'services.' file) then the 'RemoteServicePort'.
    #
    # Per-connection configurable.
    #
    # Type: string, integer
    #
    #RemoteServiceName = gds_db
    #RemoteServicePort = 3050
    J'ai souvent changer le RemoteServicePort (avec succès), jamais le RemoteServiceName .
    Ne pas oublier de redémarrer les services firebird après

    Pour Interbase, après quelques recherches,SOUS RESERVE il faudrait modifier le fichier services (c:/windows/system32/drivers/etc/services)
    et changer la ligne gds_db 3050/tcp, (toujours en ayant arrêté les services avant bien sûr)
    La seule chose absolue dans un monde comme le nôtre, c'est l'humour. » Albert Einstein

    Delphi installés : D3,D7,D2010,XE4,XE7,D10 (Tokyo, Rio, Sidney) et peut être quelques autres
    SGBD : Firebird 2.5, 3, SQLite
    générateurs Etats : FastReport, Rave, QuickReport
    OS : Window Vista, Windows 10, Ubuntu, Androïd

###raw>template_hook.ano_emploi###