Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Candidat au Club
    Profil pro
    Inscrit en
    septembre 2012
    Messages
    7
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : septembre 2012
    Messages : 7
    Points : 4
    Points
    4

    Par défaut Webpack - L'actualisation ne fonctionne pas

    Bonjour,

    Depuis que j'ai formaté mon ordinateur, webpack ne fonctione plus.
    Je lance la commande "npm run watch" pour pouvoir voir mes modifications faites dans VueJS.

    Ici aucune erreur dans la console. Par contre dans la console de mon navigateur j'ai ce message d'erreur :
    J'utilise pour Node la version v11.9.0 et pour npm v6.5.0

    app.js:80992 [Vue warn]: Failed to mount component: template or render function not defined.

    found in

    ---> <ItemListeMain>
    <Root>
    Je pense que du coup ce problème viens évidemment pas du formatage mais plutôt de la version que j'utilise, mais je n'arrive pas à trouver comment avec la nouvelle version monter mes components...

    J'importe mes components de cette manière :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    Vue.component('item-liste-main', require('./components/main/item/ItemListe.vue'));
    Je me suis aperçu qu'apparement j'ai ce message sur tous les components issus des routes.
    J'ai essayé plein de méthode trouvé sur internet, mais aucune fonctionne.

    Je n'arrive donc pas à remédier à ce problème...

    Si quelqu'un à déjà eu ce problème n'hésitez pas

    Merci d'avance.

    Cordialement,

  2. #2
    Membre à l'essai
    Homme Profil pro
    Conseil - Consultant en systèmes d'information
    Inscrit en
    avril 2010
    Messages
    6
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Conseil - Consultant en systèmes d'information

    Informations forums :
    Inscription : avril 2010
    Messages : 6
    Points : 10
    Points
    10

    Par défaut J ai résolu un problème qui me semble similaire

    Il y a deux semaines de cela, j'ai eu un problème similaire.
    Webpack a une difficulté avec une commande IMPORT avec un chemin erroné, qu 'il n a pas detecté.
    Au lancement de l'application, j'ai eu une erreur Runtime Fatale dont le message était erroné aussi.

    Si tu peux retirer ta commande REQUIRE ou changer le path, tu auras peut etre une explication.

    Pour mon cas la cause était un path linux endommagé par un serveur HS.

    La configuration de Webpack permet de ne pas traiter les erreurs comme il le faudrait. Et la configuration de Webpack ce n'est pas mon métier, donc une semaine de galère ....

Discussions similaires

  1. [Toutes versions] actualisation de la date ne fonctionne pas
    Par Ewenguillou dans le forum Access
    Réponses: 9
    Dernier message: 29/05/2017, 09h27
  2. Réponses: 6
    Dernier message: 27/01/2004, 11h14
  3. UNION qui ne fonctionne pas
    Par r-zo dans le forum Langage SQL
    Réponses: 7
    Dernier message: 21/07/2003, 10h04
  4. Un Hint sur un PopupMenu ne fonctionne pas !!??
    Par momox dans le forum C++Builder
    Réponses: 6
    Dernier message: 26/05/2003, 16h48
  5. ca ne fonctionne pas (generateur auto-incrémentant)
    Par tripper.dim dans le forum SQL
    Réponses: 7
    Dernier message: 26/11/2002, 00h10

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo