Bonjour,

Avant de poser mes questions voici ma configuration système

Linux debian Squetch avec ISPConfig3
PHP installé par défaut 7.0.33
version composer = Composer version 1.6.4 2018-04-13

Pour installer Symfony 4.2 ou même 4.1 j'ai installé ceci

- Version PHP supplémentaire 7.1.26
- Paramétrage via ISPConfig OK
- information php_info = PHP Version 7.1.26
- configuration profil local ajouter =
Code :Sélectionner tout -Visualiser dans une fenêtre à part
alias php='/opt/php-7.1/bin/php'

- interrogation version php =

Code :Sélectionner tout -Visualiser dans une fenêtre à part
1
2
3
4
5
 PHP 7.1.26 (cli) (built: Feb  5 2019 00:10:38) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.1.0, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.1.26, Copyright (c) 1999-2018, by Zend Technologies
    with Xdebug v2.6.1, Copyright (c) 2002-2018, by Derick Rethans



Mon problème : Je n'arrive pas à installer symfony 4.1 ou 4.2 ou même 4.0, il m'installe par défaut la version symfony 3.4.22
lorsque que j'indique dans mon installation une version cela ne fonctionne pas, car le système m'indique que ma version de PHP n'est pas suffisante (7.0.33)

Mes questions :
- Où le système symfony va chercher l'information sur la version de PHP ? car malgré ma modification, il arrive à trouver la version général de PHP et pas celle configuré pour mon site.
- Comment faire pour passer outre ?
- Est-il possible de télécharger différemment la version de symfony que je souhaite ? Autrement que par composer
- Qu'est ce qu'il manque dans ma configuration pour ne plus rencontrer ce problème ?

Je vous remercie par avance.