Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Discussion: Dongle wifi sur RPI

  1. #1
    Membre régulier
    Profil pro
    Développeur informatique
    Inscrit en
    février 2008
    Messages
    194
    Détails du profil
    Informations personnelles :
    Localisation : France, Var (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : février 2008
    Messages : 194
    Points : 120
    Points
    120

    Par défaut Dongle wifi sur RPI

    Bonjour,
    j'ai récupéré un RPI 2 sur lequel je veux utiliser un dongle wifi TEW-648UBM de chez TrendNet. San succès pour le moment.

    Je pense que ce produit est supporté car la page https://wiki.debian.org/fr/rtl819x#rtl8192cu indique ceci:
    Module produit dans le noyau: rtl8192cu
    USB: 20F4:648B TRENDnet TEW-648UBM 802.11n 150Mbps Micro Wireless N Adapter [Realtek RTL8188CUS]

    Il y a une allusion au realtek RTL8188CUS, je ne sais pas pourquoi...

    lsusb me dit:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    Bus 001 Device 005: ID 046d:c05b Logitech, Inc. M-U0004 810-001317 [B110 Optical USB Mouse]
    Bus 001 Device 004: ID 046d:c31c Logitech, Inc. Keyboard K120 for Business
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
    Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. 
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    je ne vois pas mon dongle.
    lsmod me dit:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    bcm2835_gpiomem         3940  0 
    8192cu                582217  0 
    cfg80211              543027  1 8192cu
    le module du 8192cu est chargé.
    dmesg me dit:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    dmesg |grep wlan0
    [   10.539612] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    
    dmesg |grep 8192cu
    [    5.872271] usbcore: registered new interface driver rtl8192cu
    [   10.740070] Modules linked in: evdev joydev snd_bcm2835 snd_pcm snd_timer i2c_bcm2835 i2c_bcm2708 snd i2c_dev bcm2835_gpiomem 8192cu cfg80211 rfkill uio_pdrv_genirq fixed uio w1_therm w1_gpio wire cn fuse ipv6
    [   10.742688] [<80629768>] (unregister_netdev) from [<7f1f8a68>] (rtw_unregister_netdevs+0x54/0x74 [8192cu])
    [   10.743053] [<7f1f8a68>] (rtw_unregister_netdevs [8192cu]) from [<7f1f998c>] (rtw_dev_remove+0x2c/0x7c [8192cu])
    [   10.743251] [<7f1f998c>] (rtw_dev_remove [8192cu]) from [<8055ef34>] (usb_unbind_interface+0x8c/0x2a0)
    Ok, plusieurs problèmes

    Mon fichier /etc/network/interfaces:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    # Include files from /etc/network/interfaces.d:
    source-directory /etc/network/interfaces.d
    
    auto lo
    iface lo inet loopback
    
    iface eth0 inet manual
    auto wlan0
    allow-hotplug wlan0
    iface wlan0 inet dhcp
    wpa-ssid "Mon SSID"
    wpa-psk "Mon PWD"
    et mon fichier /etc/wpa_supplicant/wpa_supplicant.conf avec ses valeurs initiales:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    update_config=1
    country=GB
    
    network={
    	ssid="MAGIC"
    	psk="sniffsniff"
    	key_mgmt=WPA-PSK
    }
    
    network={
    	ssid="Remi B"
    	psk="gateaucerise"
    	key_mgmt=WPA-PSK
    }
    Je ne vois pas trop ce qui m'empêche d'avoir le wlan0 avec ifconfig.
    Si quelqu'un a utilisé ce dongle ou détecte l'erreur, Merci pour vos réponses

  2. #2
    Expert éminent sénior Avatar de Artemus24
    Homme Profil pro
    Agent secret au service du président Ulysses S. Grant !
    Inscrit en
    février 2011
    Messages
    3 788
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 79
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Agent secret au service du président Ulysses S. Grant !
    Secteur : Finance

    Informations forums :
    Inscription : février 2011
    Messages : 3 788
    Points : 11 576
    Points
    11 576

    Par défaut

    Salut rdtech.

    Citation Envoyé par rdtech
    j'ai récupéré un RPI 2 sur lequel je veux utiliser un dongle wifi TEW-648UBM de chez TrendNet. San succès pour le moment.
    Il est fort possible que vous ayez besoin d'un driver.
    Le mieux serait d'acheter un dongle wifi compatible Raspberry, c'est-à-dire sans driver.

    --> https://www.gotronic.fr/art-dongle-b...2649-23889.htm
    --> https://www.gotronic.fr/art-module-u...1012-20674.htm
    --> https://www.kubii.fr/claviers-et-per...111000385.html
    --> https://www.kubii.fr/claviers-et-per...496004825.html

    Détail de votre dongle wifi de chez Trendnet :
    --> https://www.trendnet.com/langfr/prod...195_TEW-648UBM

    Vous pouvez trouver un driver ici :
    --> https://www.trendnet.com/support/sup...195_TEW-648UBM

    Citation Envoyé par rdtech
    Il y a une allusion au realtek RTL8188CUS, je ne sais pas pourquoi...
    Parce que c'est le driver qui est utilisé.

    En faisant une petite recherche, j'ai trouve ceci :
    --> https://elinux.org/RPi_USB_Wi-Fi_Adapters
    où il est dit :
    Trendnet
    TEW-648UBM USB ID: 20f4:648b, works OOTB with Adafruit Occidentials Raspbian Wheezy variant as it includes kernel with RTL8188CUS driver built-in (B)
    Donc le driver est bien le RTL8188CUS.

    Si en faisant un "lsub" vous ne voyez pas votre dongle wifi, c'est que le dongle wifi n'est pas reconnu par le rapsberry.
    Hormis le noyau, je vois une souris (device 005) et un clavier (device 004).

    Quelle distribution Raspbian utilisez-vous ? Wheezy ? Jessie ? Stretch ?
    Dans le cas de stretch (ce que j'utilise), je ne travaille plus avec le fichier "/etc/network/interfaces", mais seulement avec le fichier /etc/wpa_supplicant/wpa_supplicant.conf.
    Pourquoi mettre "country=GB" ? Etes-vous résident en angleterre ?
    Pourquoi utilisez ceci : "key_mgmt=WPA-PSK" ? N'avez-vous pas la possibilité de mettre "Key_mgmt=WPA2-PSK" ?
    Autrement dit votre box ne sait gérer que le "WPA-PSK" ?

    @+
    Si vous êtes de mon aide, vous pouvez cliquer sur .
    Mon site : http://www.jcz.fr

  3. #3
    Membre régulier
    Profil pro
    Développeur informatique
    Inscrit en
    février 2008
    Messages
    194
    Détails du profil
    Informations personnelles :
    Localisation : France, Var (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : février 2008
    Messages : 194
    Points : 120
    Points
    120

    Par défaut

    Bonjour Artemus Gordon,
    mon matériel est de récupération. Donc avec une configuration existante et peut-être mon prédécesseur était-il en Angleterre? J'ai aussi hérité de 8 clé wifi usb, je vais essayer de ne pas les jeter...
    J'amènerai les modifs nécessaires et je vais essayer d'installer ce module rtl8188cus.
    Je travaille avec Jessie 8.0

    Merci pour la réponse.

  4. #4
    Expert éminent sénior Avatar de Artemus24
    Homme Profil pro
    Agent secret au service du président Ulysses S. Grant !
    Inscrit en
    février 2011
    Messages
    3 788
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 79
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Agent secret au service du président Ulysses S. Grant !
    Secteur : Finance

    Informations forums :
    Inscription : février 2011
    Messages : 3 788
    Points : 11 576
    Points
    11 576

    Par défaut

    Salut rdtech.

    Je ne me suis pas trop cassé la tête. Mon matériel, je l'ai acheté chez Go Tronic puis chez Kubii.
    Mes principales clefs sont compatibles Raspberry, sans driver. Du coup, c'est bien plus simple à gérer.

    Citation Envoyé par rdtech
    Je travaille avec Jessie 8.0
    Il faudrait peut-être envisager de passer à stretch, non ?

    @+
    Si vous êtes de mon aide, vous pouvez cliquer sur .
    Mon site : http://www.jcz.fr

  5. #5
    Membre confirmé Avatar de Lekno
    Femme Profil pro
    Étudiant
    Inscrit en
    septembre 2010
    Messages
    727
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Âge : 29
    Localisation : France

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : septembre 2010
    Messages : 727
    Points : 553
    Points
    553

    Par défaut

    Comme l'a dit Artemus24, un upgrade vers Stretch va très probablement régler ton soucis

  6. #6
    Membre régulier
    Profil pro
    Développeur informatique
    Inscrit en
    février 2008
    Messages
    194
    Détails du profil
    Informations personnelles :
    Localisation : France, Var (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : février 2008
    Messages : 194
    Points : 120
    Points
    120

    Par défaut

    bonjour et merci pour vos réponses.
    J'abandonne provisoirement ces clés pour les utiliser sur d'autres matériels. Un collègue nous a prêté une DLink qui fonctionne bien. Mais j'y reviendrai, je vais faire une carte SD avec Stretch et quand le RPI sera dispo je testerai.
    Si j'ai toujours des soucis, je créerai une autre message.
    Merci.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Réponses: 3
    Dernier message: 03/03/2007, 23h47
  2. Pb de connexion Wifi sur 1 réseau
    Par sal dans le forum Hardware
    Réponses: 3
    Dernier message: 20/01/2006, 06h09
  3. Réponses: 12
    Dernier message: 15/12/2005, 14h32
  4. Carte Wifi sur Compaq Presario sur Ubuntu
    Par Jack_serious dans le forum Matériel
    Réponses: 6
    Dernier message: 02/12/2005, 19h04
  5. WIFI sur un seul ordi
    Par perlaud dans le forum Hardware
    Réponses: 3
    Dernier message: 21/01/2005, 22h13

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo