Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Discussion: TComPort et Bluetooth

  1. #1
    Membre à l'essai
    Profil pro
    Inscrit en
    février 2008
    Messages
    19
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : février 2008
    Messages : 19
    Points : 10
    Points
    10

    Par défaut TComPort et Bluetooth

    Bonjour .
    J'ai crée une appli avec CportLib avec Delphi 7. Cette appli me permet de contrôler par voie série un montage autour d'un Arduino afin de modifier certains paramètres. ça marche très bien.
    Mais je voudrai me dispenser de la liaison série filaire et utiliser le Bluetooth (ajouté à mon Arduino). Actuellement je peux le faire (c'est fastidieux et dérouterait l'utilisateur final) à partir de ma tablette.
    L'utilisation du PC simplifierait les commandes disponibles dans un menu.
    Voici ma question : Peut-on utiliser le TComPort pour le Bluetooth. Je n'ai trouvé que des réponses du style "on doit pouvoir le faire..." Mais comment ??? ou avec quelle autre librairie ??
    Je vous remercie .
    Chamac.

  2. #2
    Rédacteur/Modérateur

    Avatar de SergioMaster
    Homme Profil pro
    Développeur informatique
    Inscrit en
    janvier 2007
    Messages
    9 849
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 62
    Localisation : France, Loire Atlantique (Pays de la Loire)

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : Industrie

    Informations forums :
    Inscription : janvier 2007
    Messages : 9 849
    Points : 24 306
    Points
    24 306
    Billets dans le blog
    17

    Par défaut

    Bonjour,

    en passant à la dernière version de Delphi communauty au lieu de rester en D7 vous pourriez vous épargner beaucoup de tracas
    La seule chose absolue dans un monde comme le nôtre, c'est l'humour. » Albert Einstein

    Delphi installés : D3,D7,D2010,XE4,XE7,D10 (Berlin, Tokyo) et peut être quelques autres
    SGBD : Firebird 2.5, 3, SQLite
    générateurs Etats : FastReport, Rave, QuickReport
    OS : Window Vista, Windows 10, Ubuntu, Androïd

  3. #3
    Membre à l'essai
    Profil pro
    Inscrit en
    février 2008
    Messages
    19
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : février 2008
    Messages : 19
    Points : 10
    Points
    10

    Par défaut

    Merci. Je ne savais pas que cette version était gratuite.

  4. #4
    Membre à l'essai
    Profil pro
    Inscrit en
    février 2008
    Messages
    19
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : février 2008
    Messages : 19
    Points : 10
    Points
    10

    Par défaut

    Bonjour.
    J'ai donc changé de système et suis passé à Delphi community. Par contre je n'ai aucune aide sur les composants, indispensable pour les nouveaux. J'ai beau faire des recherches sur internet je ne trouve rien. J'ai compris (??) qu'il me fallait lancer Help_Setup.exe. Mais je n'ai téléchargé que l'exécutable d'installation radstudio10_3_0_esd_94364.exe..... et ne trouve pas ce Help chez Embarcadero ni ailleurs.
    Quelqu'un peut-il me dépanner ??
    Petite parenthèse...j'ai commencé la programmation avec le début du Turbo Pascal ce qui sous entend que ma vitesse de compréhension a fortement diminué ...
    Je vous remercie.

  5. #5
    Rédacteur/Modérateur

    Avatar de SergioMaster
    Homme Profil pro
    Développeur informatique
    Inscrit en
    janvier 2007
    Messages
    9 849
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 62
    Localisation : France, Loire Atlantique (Pays de la Loire)

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : Industrie

    Informations forums :
    Inscription : janvier 2007
    Messages : 9 849
    Points : 24 306
    Points
    24 306
    Billets dans le blog
    17

    Par défaut

    Bonjour,

    C'est la première fois que je lis quelque chose à propos de Help_Setup

    Je ne peux évidemment pas tester une version de Communauty puisque je suis en version Entreprise. Seuls ceux qui ont installé cette version pourrait vraiment aider pour cette partie. Ce que je préconise cependant c'est plutôt d'utiliser l'iso que le programme web d'installation.

    Pour ce qui est Delphi+Arduino , dépassant mon domaine actuel, je sais qu'il y a pas mal de blogs/articles /vidéos sur le sujet (évidemment la plupart en anglais )
    Quant à l'aide, c'est vrai que par rapport à D7 le système est, je dirai, "différent, moins bon ? ..." je passe le plus souvent par le docwiki dès que la touche F1 n'est plus très explicite
    La seule chose absolue dans un monde comme le nôtre, c'est l'humour. » Albert Einstein

    Delphi installés : D3,D7,D2010,XE4,XE7,D10 (Berlin, Tokyo) et peut être quelques autres
    SGBD : Firebird 2.5, 3, SQLite
    générateurs Etats : FastReport, Rave, QuickReport
    OS : Window Vista, Windows 10, Ubuntu, Androïd

  6. #6
    Membre à l'essai
    Profil pro
    Inscrit en
    février 2008
    Messages
    19
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : février 2008
    Messages : 19
    Points : 10
    Points
    10

    Par défaut

    Bonjour et merci.
    Comme je n'ai pas vu beaucoup de demandes à ce sujet j'ai installé sur un autre PC en allant plus doucement .....
    J'avais oublié de cocher "Help" [qui devrait l'être par défaut à mon sens ..]
    C'est donc résolu.
    Merci.

  7. #7
    Membre éprouvé

    Profil pro
    Inscrit en
    août 2005
    Messages
    688
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : août 2005
    Messages : 688
    Points : 1 288
    Points
    1 288

    Par défaut

    Bonjour,

    J'ai piloté une carte ARDUINO avec une appli sous Delphi starter et le composant Tcomport. Je l'ai récemment recompilé sous Community sans problème

    Il faut un module Bluetooth à quelques euros relié à la carte Arduino, une clé USB bluetooth connectée au PC (pas de Bluetooth sur mon PC Fixe).
    ça suffit : un port com virtuel est créé automatiquement, il suffit de sélectionner ce port virtuel dans l'appli Delphi. ça se gère exactement comme un port com physique.
    Mais ça date de plusieurs années. Eventuellement je pourrai essayer de rebrancher pour me rafraichir la mémoire si tu as d'autres questions. A la première connexion Arduino / PC il y a code a saisir coté PC. Avant la connexion la led bleue du module Arduino clignote quand la connexion est établie elle passe au fixe (à moins que ce soit l'inverse).
    Bon courage.

    PS :
    Pour Arduino il y a une librairie a utiliser pour le module bluetooth.
    Coté PC et Delphi il faut juste le composant série TCOMPORT (Tcomport est un composant très ancien, il y a deux versions qui sont ok pour Community une de Warren Postma compatible XE5 , et une de [www.gudangprogram.in] les deux divergent sur la gestion de l'Unicode mais pour piloter Arduino c'est sans importance.
    Petite particularité pour le composant Tcomport en plus d'indiquer son chemin dans la bibliothèque il faut aussi l'indiquer aussi dans les options du projet -> compilateur -> chemin de recherche .

  8. #8
    Rédacteur/Modérateur

    Avatar de SergioMaster
    Homme Profil pro
    Développeur informatique
    Inscrit en
    janvier 2007
    Messages
    9 849
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 62
    Localisation : France, Loire Atlantique (Pays de la Loire)

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : Industrie

    Informations forums :
    Inscription : janvier 2007
    Messages : 9 849
    Points : 24 306
    Points
    24 306
    Billets dans le blog
    17

    Par défaut

    Bonjour,

    si j'ai indiqué d'utiliser plutôt la dernière version de Delphi
    c'est d'une part parce que ce serait dommage de passer à côté
    et mais surtout pour la bibliothèque de tethering permettant une liaison bluetooth entre postes

    quant à la documentation je pensais par exemple à une vidéo du coderage 11

    et à un expert dans ce domaine Boian Mitov (faire des recherches avec les mots clés mitov+delphi+arduino+tutorials)
    La seule chose absolue dans un monde comme le nôtre, c'est l'humour. » Albert Einstein

    Delphi installés : D3,D7,D2010,XE4,XE7,D10 (Berlin, Tokyo) et peut être quelques autres
    SGBD : Firebird 2.5, 3, SQLite
    générateurs Etats : FastReport, Rave, QuickReport
    OS : Window Vista, Windows 10, Ubuntu, Androïd

  9. #9
    Membre à l'essai
    Profil pro
    Inscrit en
    février 2008
    Messages
    19
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : février 2008
    Messages : 19
    Points : 10
    Points
    10

    Par défaut

    Bonjour.
    Merci pour ces précisions.
    J'hésitais à changer de version de Delphi mais je ne regrette pas . Il y a un monde entre les deux comme entre le Tutbo Pascal des années 80 et Delphi 5 ou 7. Il faut simplement s'adapter...
    Je vais également essayer la bibliothèque de tethering.
    Quant à l'utilisation de ComPort, aucun port virtuel n'est présent dans la liste des ports de l'application Delphi. Est ce parce que c'est un portable avec Bluetooth intégré ? Ou que je gère mal ComPort........
    Je ferai l'essai avec une nouvelle clé USB bluetooth (en commande) sur mon fixe. Si tu as des infos supplémentaire, je veux bien. Je me documente dans plusieurs directions .
    Pour la partie Arduino avec son TEC HC-05 ou avec ESP 32 je n'ai pas de problème.
    Merci.

  10. #10
    Membre éprouvé

    Profil pro
    Inscrit en
    août 2005
    Messages
    688
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : août 2005
    Messages : 688
    Points : 1 288
    Points
    1 288

    Par défaut

    Bonjour

    Est ce parce que c'est un portable avec Bluetooth intégré ?
    non il n'y a pas de raison.

    De mémoire le port com virtuel n'apparait que lorsque la connexion BT est établie (changement d'état de la led bleue sur le module Arduino (quand elle passe au fixe)).
    Il est visible dans l'appli Delphi (config du port com liste déroulante), dans le gestionnaire de périphériques, dans les infos BT du PC et aussi dans la base de registre.

    Dans un premier temps il faut que tu t'assures que la liaison en BT avec le PC est bien établie, est ce le cas ?
    Je suppose qu'on utilises le meme module BT pour Arduino mais c'est à vérifier.

    J'essaierai de rebrancher ma carte Arduino (c'est un montage sur platine de test d'il y a plusieurs années c'est pas gagné) pour être plus précis si tu souhaite poursuivre dans cette voie. J'ai laissé tomber Delphi et Arduino depuis longtemps .

    Un petit bout de code pour un item de menu que j'ai appelé "Aide config port série"
    Pour visualiser les ports disponibles (il lit la base de registre)
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    procedure TfrmAidePortSerie.Button1Click(Sender: TObject);
    var
      Registre: TRegistry;
      Names, Values: TStringList;
      NamesTs, ValuesTs: TStrings;
      i: Integer;
      Ports, Subkeys: TStringList;
    begin
      Ports := TStringList.Create;
      Subkeys := TStringList.Create;
      memo1.Lines.Clear;
      memo1.Lines.Add(' Clés de registre : HKEY_LOCAL_MACHINE\HARDWARE\DEVICEMAP\SERIALCOMM');
      application.ProcessMessages;
     
      if EnumComPorts(Ports, Subkeys) then
      begin
        // trié et sans doublons
          //  Ports.Sorted := True;
          //  Ports.Duplicates := dupIgnore;
        for i := 0 to Ports.Count - 1 do
          memo1.Lines.Add(Subkeys[i] + '    ' + Ports[i]);
      end
      else
      begin
        memo1.lines.Add(' Le programme doit etre lancé en mode administrateur');
        memo1.lines.Add(' Pour pouvoir lire cette clé ');
        memo1.lines.Add(' La liste des ports serie n''est disponible que si Module BT connecté ');
      end;
      Ports.Clear;
      Ports.Free;
    end;

  11. #11
    Membre éprouvé

    Profil pro
    Inscrit en
    août 2005
    Messages
    688
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : août 2005
    Messages : 688
    Points : 1 288
    Points
    1 288

    Par défaut

    Bonjour,

    J'ai rebranché ma carte Arduino, mais mauvaise nouvelle impossible d'établir une communication avec le PC.
    Le pairage s'effectue comme avant, avec le message de pairage puis "Nous configurons HC06" puis "Vous pouvez utiliser HC06" mais sans création de ports virtuels et la led du module continue de clignoter. J'ai testé sur mon PC fixe avec 2 clés Bluetooth différentes, sur mon portable qui a le Bluetooth intégré pareil.

    Le HC06 n'est plus supporté par Windows 10.
    Il y a de nombreux posts à ce sujet notamment sur Microsoft Community : With Windows 10, can't open any Bluetooth virtual com ports https://answers.microsoft.com/en-us/...abfbb46?page=4 avec 260 personnes qui ont le même problème … et une soixantaine de réponses/ solution (mettre a jour les drivers, attendre la prochaine version de Windows, une KB, démarrer manuellement le service DSMSVC etc...). Rien ne marche

    La cause serait :
    FINALLY, AN ANSWER.
    I have been told Windows 10 has an all-new Bluetooth stack.
    This new stack only supports SPP 1.2. We needed 1.1 supported.
    Migrating to RFCOMM.
    So I assume that the module needs SPP (Serial Port Profile) 1.1 that is not provided in Windows 10.
    Je ne connais pas Thetering mais j'aurais tendance a penser que le problème sera le même.
    A contrario la connnexion HC06, avec les terminaux série Android, que l'on trouve sur le play store fonctionne toujours.
    La solution ? peut-être un HC 06 récent ?? ou passer au HC05 (plus complet fonctionne en maitre ou esclave alors que le HC06 est uniquement esclave), ? ? ou un autre module plus récent 'il y en a plusieurs) ?

  12. #12
    Rédacteur/Modérateur

    Avatar de SergioMaster
    Homme Profil pro
    Développeur informatique
    Inscrit en
    janvier 2007
    Messages
    9 849
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 62
    Localisation : France, Loire Atlantique (Pays de la Loire)

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : Industrie

    Informations forums :
    Inscription : janvier 2007
    Messages : 9 849
    Points : 24 306
    Points
    24 306
    Billets dans le blog
    17

    Par défaut

    Bonjour,

    comme je l'ai écrit cela dépasse mon domaine de compétence, toutefois le vendredi je fais surtout dans la veille technologique. Inscrit à Delphi Academy je profite donc du visionnage du dernier coderage. Il s'avère que l'on y trouve une intervention de Boian Mitov : Controlling Visuino Programmed Arduino Robots from Delphi Apps by Boian Mitov, à partir de la 27 éme minute il commence le codage de la partie bluetooth Delphi et a priori il y a bien un HC-06 de nommé, par contre sa version de windows semble être inférieure à 10

    je suggère de s'inscrire à Delphi Academy (gratuit) et de profiter de toutes les vidéos de Coderage 2018 donct celle citée
    La seule chose absolue dans un monde comme le nôtre, c'est l'humour. » Albert Einstein

    Delphi installés : D3,D7,D2010,XE4,XE7,D10 (Berlin, Tokyo) et peut être quelques autres
    SGBD : Firebird 2.5, 3, SQLite
    générateurs Etats : FastReport, Rave, QuickReport
    OS : Window Vista, Windows 10, Ubuntu, Androïd

  13. #13
    Membre éprouvé

    Profil pro
    Inscrit en
    août 2005
    Messages
    688
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : août 2005
    Messages : 688
    Points : 1 288
    Points
    1 288

    Par défaut

    Bonjour,
    @ SergioMaster

    Merci pour la réponse. Il est sur que le HC-06 marchait parfaitement avec un terminal série Sous Delphi utilisant Tcomport , termite etc..Il y a 2 ou 3 ans.
    Actuellement j'ai constaté avec 2 modules HC-06 et 2 PC différents (dont un avec 2 clés Bluetooth différentes) que le pairage réussi a chaque fois, que Windows dit à la fin que le HC-06 est configuré et prêt à être utilisé mais que les ports virtuels ne sont pas créés et que la diode rouge du module continue à clignoter alors qu'elle devrait passer au fixe.

    Je n'ai pas de certitude mais au vu de recherches internet (je n'ai pas tout cité) je pense qu'avec le HC-06 il y a un problème de compatibilité Windows 10.

    Par curiosité je viens de commander sur un site chinois (Aliexpress) 1HC-06 de marque (avec un marquage apparent et lisible du CI, ce qui en général mieux qu'un CI sans inscriptions) et 1 HC-05 qui a priori a beaucoup de possibilités et queje suppose plus récent ) donc dans 1 mois environ je testerai.
    Si ça échoue je me rapprocherai de GoTronic qui est un vendeur réputé de modules Arduino et qui en a environ une dizaine différents
    Pour moi ce n'est pas fondamental puisque maintenant c'est du loisir !

    PS1 : Chamac qui a posé la question ( mais qui n'est pas revenu) et qui n'est pas débutant, a semble-t-il lui aussi constaté que les ports com n'étaient pas créés pour le HC-06
    Ps2 : la création des ports com virtuels c'est purement Windows.

    Pour thetering peut-être que le mode de communication avec Bluetooth est fondamentalement différent, j'ai jeté un œil à la doc mais vu le nombre de pages, pour tester 10 minutes ne seront pas suffisantes.

    Donc à suivre…
    Cela pourrait faire l'objet d'un tutoriel qui j'en suis persuadé aurait un lectorat important. Avis aux amateurs !

  14. #14
    Membre à l'essai
    Profil pro
    Inscrit en
    février 2008
    Messages
    19
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : février 2008
    Messages : 19
    Points : 10
    Points
    10

    Par défaut

    Bonjour.
    Je suis resté muet quelque temps. J'ai fait beaucoup de tentatives avec Comport et même avec l'exemple ClBluetooth sous Delphi 10. Rien à faire. J'avais incriminé le module Bluetooth (USB) mais même avec un nouveau c'est la même chose.
    Je me suis rabattu sur ma tablette et mon smartphone qui eux gèrent parfaitement le bluetooth. J'ai adapté mon sketch Arduino afin que les commandes à taper soient réduites à des nombres et tout est parfait.
    Si j'ai le temps j'essaierai sur Linux mais j'en doute... A 80 ans passés on n'a guère de temps de libre... et surtout on va moins vite.
    Je vous remercie tous.
    Chamac

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. [TComPort]Communication Bluetooth (RS232)
    Par bobish dans le forum Composants VCL
    Réponses: 3
    Dernier message: 11/09/2007, 16h32
  2. TComport - Envoyer information et attendre reponse
    Par Psykotik dans le forum C++Builder
    Réponses: 8
    Dernier message: 10/04/2004, 14h58
  3. Reception avec Tcomport
    Par web-angel dans le forum C++Builder
    Réponses: 16
    Dernier message: 27/01/2004, 17h20
  4. Pb reception TComPort....
    Par jeannot27 dans le forum C++Builder
    Réponses: 3
    Dernier message: 10/11/2003, 10h07
  5. [Débutant] Lenteur avec TComPort
    Par PhDt76 dans le forum C++Builder
    Réponses: 22
    Dernier message: 27/09/2003, 22h43

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo