Bonjour,

Je voudrais activer le CORS sous mon iste sous IIS 10, mais impossible, je continue d'avoir l'erreur sous Firefox : Blocage d’une requête multiorigines (Cross-Origin Request) : la politique « Same Origin » ne permet pas de consulter la ressource distante située sur http://monserveurweb. Raison : échec de la requête CORS.

Avant cela fonctionnait très bien sous IIS 7.5 en ajoutant le fichier web.config contenant ceci :
Code : Sélectionner tout - Visualiser dans une fenêtre à part
1
2
3
4
5
6
7
8
9
10
11
12
13
<?xml version="1.0" encoding="utf-8"?>
<configuration>
 <system.webServer>
   <httpProtocol>
     <customHeaders>
       <add name="Access-Control-Allow-Origin" value="*" />
       <add name="Access-Control-Allow-Headers" value="SOAPAction,Origin, X-Requested-With, Content-Type, Accept" />
       <add name="Access-Control-Allow-Methods" value="POST,GET,OPTIONS" />

     </customHeaders>
   </httpProtocol>
 </system.webServer>
</configuration>

Mais sous IIS10 j'ai donc l'erreur dont j'ai parlé ci-dessus.
J'ai donc modifié un peu le fichier en mettant :
Code : Sélectionner tout - Visualiser dans une fenêtre à part
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
<?xml version="1.0" encoding="UTF-8"?>
<configuration>
  <system.webServer>
    <cors enabled="true">
      <add origin="*">
        <allowMethods>
            <add method="POST" />
            <add method="GET" />
            <add method="OPTIONS" />
        </allowMethods>
               
      </add>
    </cors>
  </system.webServer>
</configuration>
Mais cela ne change rien.

Quelqu'un aurait une idée ?

Merci !