Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Discussion: XAMPP ou LAMPP

  1. #1
    Membre habitué

    Homme Profil pro
    Étudiant
    Inscrit en
    décembre 2016
    Messages
    112
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 22
    Localisation : Belgique

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : décembre 2016
    Messages : 112
    Points : 137
    Points
    137

    Par défaut XAMPP ou LAMPP

    Bonjour,
    Je préfère niveau accessibilité utiliser xampp plutot que lampp (APACHE, PHP,... installé traditionnellement en claire)
    Qu'en pensez vous?
    Que pensez vous de XAMPP comme serveur et non comme serveur local?
    je sais que xampp gere moins bien les maj d'Apache ou php
    mis à part ça qu'en pensez vous

    Merci d'avance

  2. #2
    Membre expert Avatar de psychadelic
    Profil pro
    Inscrit en
    mai 2010
    Messages
    2 013
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mai 2010
    Messages : 2 013
    Points : 3 957
    Points
    3 957

    Par défaut

    Ni l'un ni l'autre. ni de Vm, mais Docker = universel, multi configs, multiversions de seveurs(et autres), on active ce que l'on veut au moment ou l'on a besoin, la liste des containers est sans fin, et pret à l'emploi directement ( exemple: avec un wordPress, ou n'importe quel framework, une config pure NodeJS, etc...)
    «La pluralité des voix n'est pas une preuve, pour les vérités malaisées à découvrir, tant il est bien plus vraisemblable qu'un homme seul les ait rencontrées que tout un peuple.» [ René Descartes ] - Discours de la méthode

  3. #3
    Membre habitué

    Homme Profil pro
    Étudiant
    Inscrit en
    décembre 2016
    Messages
    112
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 22
    Localisation : Belgique

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : décembre 2016
    Messages : 112
    Points : 137
    Points
    137

    Par défaut

    Merci je vais tester ça

  4. #4
    Membre habitué

    Homme Profil pro
    Étudiant
    Inscrit en
    décembre 2016
    Messages
    112
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 22
    Localisation : Belgique

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : décembre 2016
    Messages : 112
    Points : 137
    Points
    137

    Par défaut

    Rebonjour,
    Je suis occupé d'installer dockers mais j'ai quelques soucis
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    USER:/$ sudo apt-get install docker-ce
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     docker-ce : Depends: docker-ce-cli but it is not going to be installed
                 Depends: containerd.io but it is not going to be installed
                 Depends: libseccomp2 (>= 2.3.0) but 2.1.1-1 is to be installed
    E: Unable to correct problems, you have held broken packages.
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    USER:/$ sudo apt install libseccomp2
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    libseccomp2 is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    USER:/$ sudo apt install containerd.io
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     containerd.io : Depends: libseccomp2 (>= 2.3.0) but 2.1.1-1 is to be installed
    E: Unable to correct problems, you have held broken packages.
    Une idée de comment je peux résoudre ça?

    OS: Debian GNU/Linux 8 \n \l

  5. #5
    Membre expert Avatar de psychadelic
    Profil pro
    Inscrit en
    mai 2010
    Messages
    2 013
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mai 2010
    Messages : 2 013
    Points : 3 957
    Points
    3 957

    Par défaut

    ? tu n'utilises pas utilise Synaptic ? ...

    pour ton install, pose plutôt ta question dans la section Linux, ils te répondront mieux que moi
    «La pluralité des voix n'est pas une preuve, pour les vérités malaisées à découvrir, tant il est bien plus vraisemblable qu'un homme seul les ait rencontrées que tout un peuple.» [ René Descartes ] - Discours de la méthode

  6. #6
    Membre habitué

    Homme Profil pro
    Étudiant
    Inscrit en
    décembre 2016
    Messages
    112
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 22
    Localisation : Belgique

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : décembre 2016
    Messages : 112
    Points : 137
    Points
    137

    Par défaut

    heu non je connais pas Synaptic :/
    mais je n'ai pas d'interface graphique je communique via putty avc mon vps
    je vais vite fais un peu voir du coté de Linux
    merci pour ton aide

+ Répondre à la discussion
Cette discussion est résolue.

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo