Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Candidat au Club
    Sauvegarde de toutes les base de données.
    Bonjour;
    moi quand j’essaie d’exécuter le script de sauvegarde de la base de données j'ai cette erreur.
    Je sais pas si c'est le format de la date ou bien.
    je l'ai exécuté aujourd'hui 30/11/2018
    Merci de votre aide.

    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    P_SAVE 'C:\! test sauve',   'bkp' ,     'SAUVEGARDE_SQL_SERVER',           1,          1,          0,             1,          0


    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    3
    (1*ligne(s) affectée(s))
    Msg*102, Niveau*15, État*1, Ligne*12
    Syntaxe incorrecte vers '2018'.

  2. ###raw>post.musername###
    Membre expérimenté
    Pourquoi n'utilises-tu pas des solutions déjà existante comme les jobs d'Ola Hallengren?

    Si c'est pas à faire plusieurs fois, voici un autre script (A tester car plus utilisé depuis longtemps)

    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    --https://www.mssqltips.com/sqlservertip/1070/simple-script-to-backup-all-sql-server-databases/
     
    DECLARE @name VARCHAR(50) -- database name  
    DECLARE @path VARCHAR(256) -- path for backup files  
    DECLARE @fileName VARCHAR(256) -- filename for backup  
    DECLARE @fileDate VARCHAR(20) -- used for file name
     
    -- specify database backup directory
    SET @path = '\\nas01\SQL\Backup\'
     
    -- specify filename format
    SELECT @fileDate = CONVERT(VARCHAR(20),GETDATE(),112) + REPLACE(CONVERT(VARCHAR(20),GETDATE(),108),':','')
     
    DECLARE db_cursor CURSOR READ_ONLY FOR  
    SELECT name 
    FROM master.dbo.sysdatabases 
    WHERE name NOT IN ('tempdb')  -- exclude these databases
    --WHERE name NOT IN ('master','model','msdb','tempdb')  -- exclude these databases
     
    OPEN db_cursor   
    FETCH NEXT FROM db_cursor INTO @name   
     
    WHILE @@FETCH_STATUS = 0   
    BEGIN   
       SET @fileName = @path + @name + '_' + @fileDate + '.BAK'  
       BACKUP DATABASE @name TO DISK = @fileName
     
    		-- ATTENTION, quand on fait un diff et un log, il faut absolument exclure les DB système
           --SET @fileName = @path + @name + '_' + @fileDate + '.DIF'
    	   ----BACKUP DATABASE @name TO DISK = @fileName WITH DIFFERENTIAL
     
    	   --SET @fileName = @path + @name + '_' + @fileDate + '.TRN'
    	   ----BACKUP LOG @name TO DISK = @fileName
     
       FETCH NEXT FROM db_cursor INTO @name   
    END   
     
    CLOSE db_cursor   
    DEALLOCATE db_cursor
      0  0

  3. #3
    Candidat au Club
    sauvegarde de tous les base de données.
    Merci pour votre reponse.
    le code marche bien je l'ai testé directement sur le serveur et ca marche.
    j'ai crée une procedure stockée dans laquelle j'ai mis le code.
    mais qd j'execute avce la commande sqlcmd j'ai une erreur qui me dit :

    commande : Sqlcmd –S C3SSIEGE_SRV –U test1 -P test1 -Q « EXEC rocedure_SAVE»

    Sqlcmd*: «*-S*»*: option inconnue. Entrez «*-?*» pour obtenir de l'aide.


  4. #4
    Rédacteur

    Il ne faut pas mettre des guillemets à la française, mais à l'anglaise => " et non «
    pas non pus des tirets cadratin, mais des tirets simples.

    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    Sqlcmd -S "C3SSIEGE_SRV" "U test1" -P "test1" -Q "EXEC procedure_SAVE"


    je soupçonne que vous avez dû utiliser Word pour mettre votre chaine de caractères et il a transformé vos caractères.....

    A +

    A +
    Cette signature n'a pas pu être affichée car elle comporte des erreurs.

  5. #5
    Candidat au Club
    sauvegarde de tous les base de données.
    OUI MERCI BCP.
    C'ETAIT LE PROBLEME

###raw>template_hook.ano_emploi###