Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Membre du Club Avatar de torrgovin
    Profil pro
    Inscrit en
    décembre 2009
    Messages
    94
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : décembre 2009
    Messages : 94
    Points : 65
    Points
    65

    Par défaut Installer Php7 sur Debian 7 Wheezy

    Salut à tous,

    Je galère depuis ce matin à installer php7 pour remplacer mon vieux 5.4.45

    J'ai essayé de suivre ce tuto : https://phil.writesthisblog.com/php-7-debian/

    Mais arrivé à la commande pour installer php7, soit

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    apt-get install libapache2-mod-php7.0 php7.0 php7.0-cli php7.0-common php7.0-curl php7.0-dev php7.0-fpm php7.0-gd php7.0-intl php7.0-json php7.0-mcrypt php7.0-memcache php7.0-memcached php7.0-mysql php7.0-readline php7.0-tidy
    J'ai le retour suivant

    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances
    Lecture des informations d'état... Fait
    Certains paquets ne peuvent être installés. Ceci peut signifier
    que vous avez demandé l'impossible, ou bien, si vous utilisez
    la distribution unstable, que certains paquets n'ont pas encore
    été créés ou ne sont pas sortis d'Incoming.
    L'information suivante devrait vous aider à résoudre la situation*:

    Les paquets suivants contiennent des dépendances non satisfaites*:
    libapache2-mod-php7.0 : Dépend: libpcre3 (>= 1:8.35) mais 1:8.30-5 devra être installé
    Dépend: php7.0-cli mais ne sera pas installé
    Dépend: php7.0-common (= 7.0.32-1~dotdeb+8.1) mais ne sera pas installé
    Dépend: php7.0-opcache mais ne sera pas installé
    Dépend: apache2-api-20120211 mais il n'est pas installable
    Dépend: libc6 (>= 2.15) mais 2.13-38+deb7u12 devra être installé
    php7.0 : Dépend: php7.0-common mais ne sera pas installé
    php7.0-curl : Dépend: php7.0-common (= 7.0.32-1~dotdeb+8.1) mais ne sera pas installé
    Dépend: libc6 (>= 2.14) mais 2.13-38+deb7u12 devra être installé
    php7.0-gd : Dépend: php7.0-common (= 7.0.32-1~dotdeb+8.1) mais ne sera pas installé
    Dépend: libc6 (>= 2.14) mais 2.13-38+deb7u12 devra être installé
    Dépend: libjpeg62-turbo (>= 1.3.1) mais il n'est pas installable
    Dépend: libwebp5 mais il n'est pas installable
    php7.0-geoip : Dépend: libc6 (>= 2.14) mais 2.13-38+deb7u12 devra être installé
    Recommande: geoip-database mais ne sera pas installé
    php7.0-gmp : Dépend: php7.0-common (= 7.0.32-1~dotdeb+8.1) mais ne sera pas installé
    php7.0-intl : Dépend: php7.0-common (= 7.0.32-1~dotdeb+8.1) mais ne sera pas installé
    Dépend: libc6 (>= 2.14) mais 2.13-38+deb7u12 devra être installé
    Dépend: libicu52 (>= 52~m1-1~) mais il n'est pas installable
    php7.0-json : Dépend: php7.0-common (= 7.0.32-1~dotdeb+8.1) mais ne sera pas installé
    Dépend: libc6 (>= 2.14) mais 2.13-38+deb7u12 devra être installé
    php7.0-mbstring : Dépend: php7.0-common (= 7.0.32-1~dotdeb+8.1) mais ne sera pas installé
    Dépend: libc6 (>= 2.14) mais 2.13-38+deb7u12 devra être installé
    php7.0-mcrypt : Dépend: php7.0-common (= 7.0.32-1~dotdeb+8.1) mais ne sera pas installé
    Dépend: libc6 (>= 2.14) mais 2.13-38+deb7u12 devra être installé
    php7.0-memcached : Dépend: php7.0-igbinary mais ne sera pas installé
    Dépend: libc6 (>= 2.14) mais 2.13-38+deb7u12 devra être installé
    php7.0-msgpack : Dépend: libc6 (>= 2.14) mais 2.13-38+deb7u12 devra être installé
    php7.0-mysql : Dépend: php7.0-common (= 7.0.32-1~dotdeb+8.1) mais ne sera pas installé
    Dépend: libc6 (>= 2.15) mais 2.13-38+deb7u12 devra être installé
    php7.0-sqlite3 : Dépend: php7.0-common (= 7.0.32-1~dotdeb+8.1) mais ne sera pas installé
    Dépend: libc6 (>= 2.14) mais 2.13-38+deb7u12 devra être installé
    Dépend: libsqlite3-0 (>= 3.7.15) mais 3.7.13-1+deb7u4 devra être installé
    php7.0-xml : Dépend: php7.0-common (= 7.0.32-1~dotdeb+8.1) mais ne sera pas installé
    Dépend: libc6 (>= 2.14) mais 2.13-38+deb7u12 devra être installé
    Dépend: libxml2 (>= 2.9.0) mais 2.8.0+dfsg1-7+wheezy12 devra être installé
    php7.0-zip : Dépend: php7.0-common (= 7.0.32-1~dotdeb+8.1) mais ne sera pas installé
    Dépend: libc6 (>= 2.14) mais 2.13-38+deb7u12 devra être installé
    Dépend: libzip2 (>= 0.11.2) mais ne sera pas installé
    E: Impossible de corriger les problèmes, des paquets défectueux sont en mode «*garder en l'état*».
    Que cela signifie t'il ?

    J'ai essayé de chercher ce message d'erreur sur différents forum mais rien n'est clair et je n'ai pas trouvé une solution concrète.

    Merci pour votre précieuse aide.

  2. #2
    Membre du Club Avatar de torrgovin
    Profil pro
    Inscrit en
    décembre 2009
    Messages
    94
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : décembre 2009
    Messages : 94
    Points : 65
    Points
    65

    Par défaut

    Salut à tous.

    En fait php7 pose des problèmes de compatibilité avec debian 7 (ancienne version).

    Il faut minimum Debian 8 pour que php 7 fonctionne.

    J'ai donc migré Debian 7 vers Debian 8 et comme par magie tout s'installe correctement.

    Cependant je n'arrive plus à accéder à Phpmyadmin. La page reste blanche, j'ai donc activé l'affichage des erreurs via php.ini et j'ai cette erreur quand j'essaye d'accès à Phpmyadmin

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    Fatal error: Uncaught Error: Call to undefined function __() in /usr/share/phpmyadmin/libraries/core.lib.php:235 Stack trace: #0 /usr/share/phpmyadmin/libraries/core.lib.php(308): PMA_fatalError('The [a@./url.ph...') #1 /usr/share/phpmyadmin/libraries/common.inc.php(90): PMA_warnMissingExtension('mbstring', true) #2 /usr/share/phpmyadmin/index.php(12): require_once('/usr/share/phpm...') #3 {main} thrown in /usr/share/phpmyadmin/libraries/core.lib.php on line 235
    Avez-vous une idée ?

    EDIT : J'ai l'impression que MySQL ne veut pas démarrer ou a un problème. Quand je lance la commande mysql en ssh, il me retourne l'erreur suivante :

    ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
    J'ai essayé de le désinstaller, réinstaller etc... Rien n'y fait... :'(

  3. #3
    Membre du Club Avatar de torrgovin
    Profil pro
    Inscrit en
    décembre 2009
    Messages
    94
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : décembre 2009
    Messages : 94
    Points : 65
    Points
    65

    Par défaut

    J'ai trouvé !!!

    il manquait l'extension php-mbstring

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    apt-get install php-mbstring

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Problème installation de PHP7>= sur Debian 9.3
    Par abdego dans le forum Debian
    Réponses: 1
    Dernier message: 27/01/2018, 21h10
  2. Installer Oracle sur Debian wheezy
    Par tifsa dans le forum Installation
    Réponses: 0
    Dernier message: 31/03/2015, 15h07
  3. [11g] Problème Installation Oracle-XE 11g sur Debian 7 Wheezy
    Par Pimousse22 dans le forum Installation
    Réponses: 2
    Dernier message: 02/02/2015, 14h58
  4. Problème install Mysql sur Debian
    Par robair dans le forum Débuter
    Réponses: 1
    Dernier message: 24/01/2007, 15h08
  5. Pas moyen d'installer k3b sur debian
    Par ZiMo dans le forum Applications et environnements graphiques
    Réponses: 30
    Dernier message: 20/12/2005, 18h09

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo