Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Membre à l'essai
    Profil pro
    Inscrit en
    mars 2013
    Messages
    12
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2013
    Messages : 12
    Points : 10
    Points
    10

    Par défaut URL_REWRITING ne focntionne pas

    Bonsoir

    Petit soucis, je n'arrive pas à faire fonctionner le rewriting, pourtant tout semble correctement déclaré :

    HTACCESS
    Options +FollowSymlinks

    RewriteEngine On

    RewriteCond %{REQUEST_FILENAME} -s [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]

    SITE.INI
    [urlrewriting]
    enabled=1
    class=plugin_routing
    conf=../conf/routing.php
    use4O4=0

    ROUTING.PHP
    $tab=array(
    'home' => array(
    'nav'=>'default::index',

    ),



    //page 404 (page non trouve)
    '404' => array(
    'nav' => 'article::list',
    ),

    );


    Builder 2.0.8 Framework 4.131.1

    Ou est mon erreur ??

    Merci de votre aide !

  2. #2
    Rédacteur
    Avatar de imikado
    Homme Profil pro
    Ingénieur développement
    Inscrit en
    décembre 2006
    Messages
    5 136
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 36
    Localisation : France, Val de Marne (Île de France)

    Informations professionnelles :
    Activité : Ingénieur développement
    Secteur : Finance

    Informations forums :
    Inscription : décembre 2006
    Messages : 5 136
    Points : 19 211
    Points
    19 211
    Billets dans le blog
    17

    Par défaut

    Bonjour,
    quel erreur avez vous ?

    pouvez vous faire
    1. un screenshot avec la barre d'adresse
    2. vous pouvez activez le log d'information dans conf/site.ini.php, section

    mettez
    [
    Framework php sécurisé et simple à prendre en main avec générateur web http://mkframework.com/ (hebergé sur developpez.com)
    Mes cours/tutoriaux

  3. #3
    Membre à l'essai
    Profil pro
    Inscrit en
    mars 2013
    Messages
    12
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2013
    Messages : 12
    Points : 10
    Points
    10

    Par défaut

    Citation Envoyé par imikado Voir le message
    Bonjour,
    quel erreur avez vous ?

    pouvez vous faire
    1. un screenshot avec la barre d'adresse
    2. vous pouvez activez le log d'information dans conf/site.ini.php, section

    mettez
    [
    Bonjour

    Aucune erreur ne s'affiche, après activation de la log j'ai ceci

    2018-11-02;14:47:12;info;plugin_routing parseUrl()
    2018-11-02;14:47:12;info;plugin_routing regle non trouve, utilisation de 404 loadModuleAndAction(default::index)

    url => https://www.bretagne1418.bzh/index.p...default::index

    Je sèche lamentablement !!

    Yannig

  4. #4
    Membre à l'essai
    Profil pro
    Inscrit en
    mars 2013
    Messages
    12
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2013
    Messages : 12
    Points : 10
    Points
    10

    Par défaut

    La honte

    J'ai trouvé pourquoi cela ne fonctionnait pas ......
    C'est dans la partie backend du site, j'ai un paramètre qui me permet d'activer ou non l'url_rewriting sans avoir à modifier le paramètre dans le fichier site.ini

    Désolé pour ce dérangement inutile !!

    Yannig

  5. #5
    Rédacteur
    Avatar de imikado
    Homme Profil pro
    Ingénieur développement
    Inscrit en
    décembre 2006
    Messages
    5 136
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 36
    Localisation : France, Val de Marne (Île de France)

    Informations professionnelles :
    Activité : Ingénieur développement
    Secteur : Finance

    Informations forums :
    Inscription : décembre 2006
    Messages : 5 136
    Points : 19 211
    Points
    19 211
    Billets dans le blog
    17

    Par défaut

    OK pas de soucis
    Framework php sécurisé et simple à prendre en main avec générateur web http://mkframework.com/ (hebergé sur developpez.com)
    Mes cours/tutoriaux

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Réponses: 3
    Dernier message: 10/05/2012, 19h03
  2. macro edit : change qui ne focntionne pas
    Par sam01 dans le forum z/OS
    Réponses: 5
    Dernier message: 18/03/2011, 12h26
  3. lien qui ne focntionne pas
    Par sam01 dans le forum Débuter
    Réponses: 2
    Dernier message: 28/06/2010, 14h52
  4. ping ne focntionne pas
    Par cherif1969 dans le forum VirtualBox
    Réponses: 13
    Dernier message: 09/04/2010, 11h10
  5. application ne focntionne pas sous linux
    Par boboss123 dans le forum Général Java
    Réponses: 6
    Dernier message: 18/01/2010, 13h47

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo