Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

MkFramework Discussion :

URL_REWRITING ne focntionne pas


Sujet :

MkFramework

  1. #1
    Membre à l'essai
    URL_REWRITING ne focntionne pas
    Bonsoir

    Petit soucis, je n'arrive pas à faire fonctionner le rewriting, pourtant tout semble correctement déclaré :

    HTACCESS
    Options +FollowSymlinks

    RewriteEngine On

    RewriteCond %{REQUEST_FILENAME} -s [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]

    SITE.INI
    [urlrewriting]
    enabled=1
    class=plugin_routing
    conf=../conf/routing.php
    use4O4=0

    ROUTING.PHP
    $tab=array(
    'home' => array(
    'nav'=>'default::index',

    ),



    //page 404 (page non trouve)
    '404' => array(
    'nav' => 'article::list',
    ),

    );


    Builder 2.0.8 Framework 4.131.1

    Ou est mon erreur ??

    Merci de votre aide !

  2. #2
    Rédacteur

    Bonjour,
    quel erreur avez vous ?

    pouvez vous faire
    1. un screenshot avec la barre d'adresse
    2. vous pouvez activez le log d'information dans conf/site.ini.php, section

    mettez
    Framework php sécurisé et simple à prendre en main avec générateur web http://mkframework.com/ (hebergé sur developpez.com)
    Mes cours/tutoriaux

  3. #3
    Membre à l'essai
    quoteBonjour,
    quel erreur avez vous ?

    pouvez vous faire
    1. un screenshot avec la barre d'adresse
    2. vous pouvez activez le log d'information dans conf/site.ini.php, section

    mettez
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    3
     
    [log]
    information=1
    [[/QUOTE]

    Bonjour

    Aucune erreur ne s'affiche, après activation de la log j'ai ceci

    2018-11-02;14:47:12;info;plugin_routing parseUrl()
    2018-11-02;14:47:12;info;plugin_routing regle non trouve, utilisation de 404 loadModuleAndAction(default::index)

    url => https://www.bretagne1418.bzh/index.p...default::index

    Je sèche lamentablement !!

    Yannig

  4. #4
    Membre à l'essai
    La honte

    J'ai trouvé pourquoi cela ne fonctionnait pas ......
    C'est dans la partie backend du site, j'ai un paramètre qui me permet d'activer ou non l'url_rewriting sans avoir à modifier le paramètre dans le fichier site.ini

    Désolé pour ce dérangement inutile !!

    Yannig

  5. #5
    Rédacteur

    OK pas de soucis
    Framework php sécurisé et simple à prendre en main avec générateur web http://mkframework.com/ (hebergé sur developpez.com)
    Mes cours/tutoriaux

###raw>template_hook.ano_emploi###