Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Langages serveur Discussion :

Accès Serveur localhost depuis poste local


Sujet :

Langages serveur

  1. #1
    Membre du Club
    Accès Serveur localhost depuis poste local
    Bonjour
    J' ai monté un serveur wamp sur une machine virtuel hyper V.
    Le serveur wamp tourne bien , j' ai accès a mon site bien qu ' ayant du modifier le port du localhost ( 3350 au lieu de 80 )
    sur ma machine virtuel je suis en Windows Serveur 2016 Essentials.
    J' ai essaye à partir de mon poste local de me connecter sur mon serveur via la navigateur chrome , et là rien ne se passe..Aucun accès.
    Après quelques recherches j' ai lu que je devais modifier le paramètre virtual host dans le fichier http--vhost.conf du répertoire Apache de mon serveur wamp
    au lieu de Require local j'ai ajouté Require all granted
    Voici d' ailleurs mes paramètres virtual host :
    Code apache :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    <VirtualHost *:3350>
      ServerName localhost
      ServerAlias localhost
      DocumentRoot "${INSTALL_DIR}/www"
      <Directory "${INSTALL_DIR}/www/">
        Options +Indexes +Includes +FollowSymLinks +MultiViews
        AllowOverride All
        Require all granted
      </Directory>
    </VirtualHost>


    Je ne sais pas si l'impossibilité de me connecter vient d' une mauvaise configuration de mon serveur wamp ou d' un souci sur ma machine virtuel.
    J'arrive à pinger ma machine virtuel en effectuant : ping xxx xxx xxx xxx mais sans préciser le port.

    Quelqu'un aurait il une idée du paramétrage qu' il me manquerait ou d' une piste à creuser.
    Merci à tous pour vos réponses

  2. #2
    Membre actif
    Bonjour,

    Si tes deux machines sont independantes l'une de l'autre.
    Lorsque tu essaye de te connecter a localhost, eh bien c'est pas sur ta vm que ca se passe.

    La solution n'est pas de tout autoriser car le probleme n'est pas la....

    Si tu veux te connecter au serveur installé il faut donner l'adresse ip de ta machine contenant le serveur avec le port specifié.

    http://adresseIp:port/appli/

    Le probleme que tu peux rencontrer est un probleme reseau car il faut que ton serveur soit sur un reseau et ait une adresse

    Si tu tiens vraiment à taper localhost pour te connecter ,eh bien il faudra configurer l'adresse de ta machine dans le fichier hosts qui est un fichier de correspondance nom adresse ip



    Bon courage

###raw>template_hook.ano_emploi###