Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #21
    Modérateur

    Homme Profil pro
    Inscrit en
    octobre 2005
    Messages
    12 314
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Canada

    Informations forums :
    Inscription : octobre 2005
    Messages : 12 314
    Points : 18 765
    Points
    18 765

    Par défaut

    Desole, je ne suis pas equipe pour faire ce genre de test.

    Dans ta BD de test, tu envoies le mail a partir du formulaire, c'est cela ?

    Si oui, est-ce que tu peux faire un test sans ouvrir le formulaire et voir si cela cree le meme bug.

    Aussi essaye de juste creer CDO sans rien faire d'autre jusqu'au Set Nothing.

    Est-ce que cela creer le bug ?

    A+
    Vous voulez une réponse rapide et efficace à vos questions téchniques ?
    Ne les posez pas en message privé mais dans le forum, vous bénéficiez ainsi de la compétence et de la disponibilité de tous les contributeurs.
    Et aussi regardez dans la FAQ Access et les Tutoriaux Access. C'est plein de bonnes choses.

  2. #22
    Membre à l'essai
    Homme Profil pro
    Chargé d'affaire
    Inscrit en
    juin 2014
    Messages
    34
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 41
    Localisation : France, Val d'Oise (Île de France)

    Informations professionnelles :
    Activité : Chargé d'affaire
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : juin 2014
    Messages : 34
    Points : 14
    Points
    14

    Par défaut

    J'ai créé un module puis y ait déplacé le code dans une fonction publique envoimail.
    J'ai créé une macro lançant la fonction envoimail

    Dans le formulaire, sur clic, je lance envoimail


    bilan des courses idem, si je lance la macro, le mail est envoyé. si ensuite j'ouvre le formulaire, je ne peux plus sélectionner de date.


    Quelqu'un peut il essayer chez lui?

  3. #23
    Modérateur

    Homme Profil pro
    Inscrit en
    octobre 2005
    Messages
    12 314
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Canada

    Informations forums :
    Inscription : octobre 2005
    Messages : 12 314
    Points : 18 765
    Points
    18 765

    Par défaut

    Est-ce que tu peux lancer la macro sans ouvrir le form avant ?

    A+
    Vous voulez une réponse rapide et efficace à vos questions téchniques ?
    Ne les posez pas en message privé mais dans le forum, vous bénéficiez ainsi de la compétence et de la disponibilité de tous les contributeurs.
    Et aussi regardez dans la FAQ Access et les Tutoriaux Access. C'est plein de bonnes choses.

  4. #24
    Membre à l'essai
    Homme Profil pro
    Chargé d'affaire
    Inscrit en
    juin 2014
    Messages
    34
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 41
    Localisation : France, Val d'Oise (Île de France)

    Informations professionnelles :
    Activité : Chargé d'affaire
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : juin 2014
    Messages : 34
    Points : 14
    Points
    14

    Par défaut

    oui, c'est ce que j'ai essayé d'expliquer dans mon msg précédent

    je lance la macro….. mail ok
    j'ouvre formulaire date ko

  5. #25
    Modérateur

    Homme Profil pro
    Inscrit en
    octobre 2005
    Messages
    12 314
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Canada

    Informations forums :
    Inscription : octobre 2005
    Messages : 12 314
    Points : 18 765
    Points
    18 765

    Par défaut

    Bonjour.

    Peux-tu verifier la propriete ShowDatePicker de ton controle avant et apres le CDO ?
    C'est apparement elle qui s'occupe de l'affichage du calendrier.
    Si elle est desactiver elle vaut 0 donc probablement -1, true si activee.

    A+
    Vous voulez une réponse rapide et efficace à vos questions téchniques ?
    Ne les posez pas en message privé mais dans le forum, vous bénéficiez ainsi de la compétence et de la disponibilité de tous les contributeurs.
    Et aussi regardez dans la FAQ Access et les Tutoriaux Access. C'est plein de bonnes choses.

  6. #26
    Membre à l'essai
    Homme Profil pro
    Chargé d'affaire
    Inscrit en
    juin 2014
    Messages
    34
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 41
    Localisation : France, Val d'Oise (Île de France)

    Informations professionnelles :
    Activité : Chargé d'affaire
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : juin 2014
    Messages : 34
    Points : 14
    Points
    14

    Par défaut

    le calendrier s'affiche bien. c'est le clic qui ne donne rien.

    j'ai tout de même fait le test pour voir. la valeur de la propriété est la même avant et après l'execution de la macro (valeur = 1)

  7. #27
    Modérateur

    Homme Profil pro
    Inscrit en
    octobre 2005
    Messages
    12 314
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Canada

    Informations forums :
    Inscription : octobre 2005
    Messages : 12 314
    Points : 18 765
    Points
    18 765

    Par défaut

    Par curiosite et parce que la je commence a manquer d'idee.

    Essaye de reforcer la valeur de la propriete apres l'appel a CDO.

    Quelque chose du genre :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    Me.MonControle.ShowDatePicker=0
    Me.MonControle.ShowDatePicker=1
    A+
    Vous voulez une réponse rapide et efficace à vos questions téchniques ?
    Ne les posez pas en message privé mais dans le forum, vous bénéficiez ainsi de la compétence et de la disponibilité de tous les contributeurs.
    Et aussi regardez dans la FAQ Access et les Tutoriaux Access. C'est plein de bonnes choses.

  8. #28
    Membre à l'essai
    Homme Profil pro
    Chargé d'affaire
    Inscrit en
    juin 2014
    Messages
    34
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 41
    Localisation : France, Val d'Oise (Île de France)

    Informations professionnelles :
    Activité : Chargé d'affaire
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : juin 2014
    Messages : 34
    Points : 14
    Points
    14

    Par défaut

    pas mieux….

    peux tu essayer mon code sur ton pc?

  9. #29
    Modérateur

    Homme Profil pro
    Inscrit en
    octobre 2005
    Messages
    12 314
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Canada

    Informations forums :
    Inscription : octobre 2005
    Messages : 12 314
    Points : 18 765
    Points
    18 765

    Par défaut

    Non, comme je l'ai dit je ne suis pas equipe pour cela.

    Desole.

    A+
    Vous voulez une réponse rapide et efficace à vos questions téchniques ?
    Ne les posez pas en message privé mais dans le forum, vous bénéficiez ainsi de la compétence et de la disponibilité de tous les contributeurs.
    Et aussi regardez dans la FAQ Access et les Tutoriaux Access. C'est plein de bonnes choses.

  10. #30
    Membre à l'essai
    Homme Profil pro
    Chargé d'affaire
    Inscrit en
    juin 2014
    Messages
    34
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 41
    Localisation : France, Val d'Oise (Île de France)

    Informations professionnelles :
    Activité : Chargé d'affaire
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : juin 2014
    Messages : 34
    Points : 14
    Points
    14

    Par défaut

    ok, merci quand même

  11. #31
    Membre à l'essai
    Homme Profil pro
    Chargé d'affaire
    Inscrit en
    juin 2014
    Messages
    34
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 41
    Localisation : France, Val d'Oise (Île de France)

    Informations professionnelles :
    Activité : Chargé d'affaire
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : juin 2014
    Messages : 34
    Points : 14
    Points
    14

    Par défaut

    Bonjour,

    Je crois que mon problème vient de la fonction Msgbox..... lorsque j la supprime, je n'ai plus de soucis !!!!!
    Quelqu'un a un avis?

    Je vais passer ce sujet en résolu mais j'attends car peut être il y a des prérequis à l'utilisation du Msgbox qui pourraient être interessant de connaître.

    Merci

  12. #32
    Rédacteur/Modérateur
    Avatar de loufab
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    avril 2005
    Messages
    10 854
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : avril 2005
    Messages : 10 854
    Points : 21 983
    Points
    21 983

    Par défaut

    Bonjour,

    Test effectué RAS. Par contre je ne suis pas en 2010 mais en 2013.

    Réparation Office ?

    Cordialement,
    Détecter les modifications formulaire Cloud storage et ACCESS
    Classe MELA(CRUD) Opérateur IN et zone de liste Opérateur LIKE
    Visitez mon Blog
    Les questions techniques par MP ne sont pas lues et je ne pratique pas la bactériomancie

  13. #33
    Membre à l'essai
    Homme Profil pro
    Chargé d'affaire
    Inscrit en
    juin 2014
    Messages
    34
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 41
    Localisation : France, Val d'Oise (Île de France)

    Informations professionnelles :
    Activité : Chargé d'affaire
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : juin 2014
    Messages : 34
    Points : 14
    Points
    14

    Par défaut

    Bonjour Loufab,

    C'est étrange car j'ai aussi compilé l'application sur une version 2013 32 bits pour voir et le problème est le même.
    Bon, il faut de toute façon que je la passe sous Access 2016. Je verrai bien ce qu'il se passe.

    Merci pour tout en tout cas, je passe le sujet en résolu et l'alimenterai si j'ai plus d'infos

+ Répondre à la discussion
Cette discussion est résolue.
Page 2 sur 2 PremièrePremière 12

Discussions similaires

  1. Réponses: 0
    Dernier message: 16/10/2017, 10h09
  2. Réponses: 0
    Dernier message: 03/06/2009, 11h09
  3. feuille de style non prise en compte dans un module
    Par Phenomenium dans le forum Zend Framework
    Réponses: 14
    Dernier message: 17/07/2008, 12h17
  4. Réponses: 24
    Dernier message: 17/04/2008, 14h24
  5. Réponses: 1
    Dernier message: 08/08/2007, 11h26

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo