Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Candidat au Club
    index unique introuvable dans le chompréférencé d'une table principale
    salam, j'ai une question et j'espere bien que je peux trouver le bon reponse , j'ai crée des tableaux dans access et quand j'ai essayé de relié entre eux avec des relations il m'affiche un message d'erreur comme indiqué dans l'image

  2. #2
    Modérateur

    Bonjour.

    C'est parce que tu n'as pas defini la clef primaire ou un index unique sur le champ dont tu te sers dans la table de reference.

    1. La solution la plus immediate est de modifier tes tables et d'indiquer que le Num_ de chaque table est la clef primaire.
      Tu vas dans la table, tu cliques sur la clef actuelle (le id) pour la supprimer.
      Tu cliques sur la ligne de champ Num_ et tu appuis sur l'icone Clef.
    2. Une autre soltion consite a utiliser le Id au lieu du Num dans les tables dependantes.
      Tu supprime les champs Num_ des tables liees et tu les remplace par quelquechose du genre Id_TableRef (entier long).
      Apres tu define ta relation entre TableRef.Id et TableDependante.Id_TableRef.
    3. Enfin tu peux definir un index unique sur le Num_.
      Tu vas dans ta table en modif de structure.
      Tu ouvres le gestionnaire d'index en appuyamt sur l'icone avec l'eclair.
      Tu te mets sur une ligne vierge.
      Dans la 1ere colonne tu donnes un nom a ton index (ex : Unicite), dans la 2ieme colonne tu choisis le champ Num_.
      En bas en dessous des lignes tu coches Unique.


    Perso je prefere l'option 2, avec l'option 3 pour etre sur de ne pas avoir 2 fois le meme numero.

    A+
    Vous voulez une réponse rapide et efficace à vos questions téchniques ?
    Ne les posez pas en message privé mais dans le forum, vous bénéficiez ainsi de la compétence et de la disponibilité de tous les contributeurs.
    Et aussi regardez dans la FAQ Access et les Tutoriaux Access. C'est plein de bonnes choses.

  3. #3
    Candidat au Club
    Merçi, beaucoup , j'ai résolu le problem,
    le solution est : aller dans la table a coté gouche, click droite choisir mode creation, ensuit dans la premier cellule de la table button droite ici dans la propriétés du champ vous devez changer just "Null interdit " a Oui, ensuit, "Indexé" a Oui-sans doublons".

  4. #4
    Modérateur

    OK, je ne connaissais pas ce raccourci pour la solution "avec Index Unique".

    A+
    Vous voulez une réponse rapide et efficace à vos questions téchniques ?
    Ne les posez pas en message privé mais dans le forum, vous bénéficiez ainsi de la compétence et de la disponibilité de tous les contributeurs.
    Et aussi regardez dans la FAQ Access et les Tutoriaux Access. C'est plein de bonnes choses.