Pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter, inscrivez-vous gratuitement !

 

Discussion: lot SSIS ne s'exécutant pas [2014]

  1. #1
    Membre du Club
    Profil pro
    Inscrit en
    décembre 2008
    Messages
    85
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : décembre 2008
    Messages : 85
    Points : 68
    Points
    68

    Par défaut lot SSIS ne s'exécutant pas

    Bonjour

    J'ai récupéré un lot dtsx (package) SSIS d'un serveur 2008.
    Mon lot récupère des données dans un fichier.csv et les transfère en base de données.
    Sur le serveur 2008, la tâche agent lançant ce lot s'exécute très bien.

    J'ai modifié mon fichier dtsx pour qu'il corresponde à mon nouveau serveur 2014.
    Je me connecte avec le compte utilisé par l'agent (connexion windows uniquement) sur mon serveur SQL 2014 et j'ouvre mon fichier (dans explorateur windows).
    Je demande l'exécution du lot.
    Celui-ci s'exécute sans problème avec juste un warning (Could not open global shared memory to communicate with performance DLL.......).
    En base, mes données ont bien été intégrées.

    Si depuis management studio du serveur 2014, je démarre la tâche agent lançant ce lot. Je vois le sablier qui tourne indéfiniment.
    Rien n’apparaît en base de données.
    Si je regarde l'historique de ma tâche, je ne vois rien.
    Finalement j'arrête la tâche (sans problème) et regarde à nouveau l'historique de ma tâche, dès fois que cela m'affiche quelque chose de plus, mais rien.

    Comment savoir ce qui coince ?

    Merci pour votre aide.

  2. #2
    Membre du Club
    Profil pro
    Inscrit en
    décembre 2008
    Messages
    85
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : décembre 2008
    Messages : 85
    Points : 68
    Points
    68

    Par défaut solution au problème

    J'ai trouvé la solution par un autre biais.
    Le compte Windows, servant à l'agent SQL, quoique membre du rôle sysadmin, était limité en droits sur les bases systèmes sur un schéma au nom de son compte windows (??).
    J'ai supprimé ce schéma et ces restrictions et tout fonctionne comme sur le serveur 2008.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. [2008] Erreur d'exécution d'un lot SSIS: violation de Primary key
    Par lamen0031 dans le forum SSIS
    Réponses: 3
    Dernier message: 07/02/2013, 13h06
  2. Champ ds état visible ssi il n'est pas vide !
    Par Fredri dans le forum Access
    Réponses: 11
    Dernier message: 20/12/2005, 12h15
  3. mon programe asp ne s'exécute pas????????????
    Par ghita269 dans le forum ASP
    Réponses: 1
    Dernier message: 07/11/2005, 11h23
  4. jar Eclipse/bureau -> exécute pas mes requetes !!!
    Par Elea49 dans le forum Eclipse Java
    Réponses: 5
    Dernier message: 04/08/2005, 15h11
  5. Réponses: 3
    Dernier message: 09/10/2002, 11h35

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo