Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Membre éclairé
    Avatar de BlackoOSX
    Homme Profil pro
    Lycéen
    Inscrit en
    septembre 2014
    Messages
    347
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 17
    Localisation : France, Vienne (Poitou Charente)

    Informations professionnelles :
    Activité : Lycéen
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : septembre 2014
    Messages : 347
    Points : 660
    Points
    660
    Billets dans le blog
    3

    Par défaut Serveur OwnCloud accessible de l'extérieur

    Bonjour à tous!
    J'en tenté de faire un serveur OwnCloud sur mon réseau local avec un rpi2 et cela fonctionne parfaitement.
    Maintenant que je l'ai fais sur mon réseau local j'essaie de le rendre accessible de l'extérieur.
    J'ai fais toutes les ouvertures de ports nécessaire sur ma livebox (version 3):
    Nom : Capture du 2018-09-03 12-47-38.png
Affichages : 87
Taille : 191,5 Ko
    Je me suis fais un nom de domaine avec le service No-Ip:
    Nom : Capture du 2018-09-03 12-48-56.png
Affichages : 83
Taille : 188,6 Ko

    Et j'ai vérifié avec ce site (https://www.whatsmydns.net/#A/rpi2cloud.ddns.net) que mon nom de domaine était accessible partout dans le monde ce qui est le cas.
    De plus la box c'est déjà mise à jour avec le nom de domaine.

    Sauf que quand je rentre l'url que j'ai configurer dans mon navigateur il ne la trouve pas...
    Nom : Capture du 2018-09-03 12-52-04.png
Affichages : 84
Taille : 158,8 Ko

    Je n'arrive pas à comprendre pourquoi...
    Merci d'avance!
    Cordialement,
    Herman Adrien.

  2. #2
    Membre actif Avatar de cedd70
    Homme Profil pro
    Ingénieur R&D
    Inscrit en
    mars 2012
    Messages
    137
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Doubs (Franche Comté)

    Informations professionnelles :
    Activité : Ingénieur R&D
    Secteur : High Tech - Électronique et micro-électronique

    Informations forums :
    Inscription : mars 2012
    Messages : 137
    Points : 243
    Points
    243

    Par défaut

    Salut,

    Essaye vraiment depuis l'extérieur. Genre depuis un téléphone (en 4G) ca devrait marcher

  3. #3
    Membre éclairé
    Avatar de BlackoOSX
    Homme Profil pro
    Lycéen
    Inscrit en
    septembre 2014
    Messages
    347
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 17
    Localisation : France, Vienne (Poitou Charente)

    Informations professionnelles :
    Activité : Lycéen
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : septembre 2014
    Messages : 347
    Points : 660
    Points
    660
    Billets dans le blog
    3

    Par défaut

    Non ça ne fonctionne pas...
    J'ai changer de service pour passer chez DNSdynamic.
    J'ai tout configurer correctement dans la box (comme sur les images précédentes), j'ai installer l'application ddclient en faisant ces réglages dans le fichier /etc/ddclient.conf:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    47
    48
    49
    #
    
    # Configuration file for ddclient generated by debconf
    
    
    #
    
    
    # /etc/ddclient.conf
    
    
    daemon=60                        # check every 60 seconds
    
    
    syslog=yes                       # log update msgs to syslog
    
    
    mail=root                        # mail all msgs to root
    
    
    mail-failure=root                # mail failed update msgs to root
    
    
    pid=/var/run/ddclient.pid        # record PID in file.
    
    
    ssl=yes                          # use ssl-support.
    
    
    use=web, web=myip.dnsdynamic.com # get ip from server.
    
    
    server=www.dnsdynamic.org        # default server
    
    
    login=herman1.adrien@gmail.com                 # your login
    
    
    password=??????????????           # your password
    
    
    server=www.dnsdynamic.org,       \
    
    
    protocol=dyndns2                 \
    
    
    www.rpi???.dnsdynamic.com
    Bien sûr les ???? sont pour la confidentialité de mes données mais le nom de domaine et le mot de passe sont bon.
    Malgré avoir paramétrer tout cela je n'arrive toujours pas à accéder au rpi via cette addresse http://www.rpi???.dnsdynamic.com
    Avez-vous une solution?
    Merci d'avance!
    Cordialement,
    Herman Adrien.

  4. #4
    Expert éminent sénior Avatar de Artemus24
    Homme Profil pro
    Agent secret au service du président Ulysses S. Grant !
    Inscrit en
    février 2011
    Messages
    3 551
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 78
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Agent secret au service du président Ulysses S. Grant !
    Secteur : Finance

    Informations forums :
    Inscription : février 2011
    Messages : 3 551
    Points : 11 080
    Points
    11 080

    Par défaut

    Salut à tous.

    Citation Envoyé par BlackoOSX
    J'en tenté de faire un serveur OwnCloud sur mon réseau local avec un rpi2 et cela fonctionne parfaitement.
    Qu'est-ce qui fonctionne parfaitement ?
    Je ne connais pas votre serveur OwnCloud. Inversement, je connais bien Apache.
    Pour rendre un site local accessible depuis l'extérieur, vous devez attribuer une adresse IPv4 autre qu'une adresse commençant par 127.0.0.x
    Par exemple, l'adresse Ipv4 de votre ordinateur dans votre réseau local : 192.168.1.33.

    Mais vous devez aussi créer des virtalHosts afin d'associer le répertoire racine où se trouve votre site, au nom de votre site.
    De plus vous devez autoriser les accès à votre site pour toutes les adresses autre que la votre.
    Par exemple, mettre "Require all granted".

    Mais surtout, est-ce que votre adresse wan est fixe ou dynamique ?

    La configuration NAT/PAT ne va pas du tout.
    Normalement quand on ouvre les ports 80 & 443, il faut indiquer dans le NAT (Network address translation) l'adresse IPv4 & IPv6 de la redirection vers votre raspberry.
    Là, je ne sais pas trop où va votre flux entrant pour les ports 80 & 443.

    Citation Envoyé par BlackoOSX
    Sauf que quand je rentre l'url que j'ai configurer dans mon navigateur il ne la trouve pas...
    Vous ne pouvez pas le faire depuis votre raspberry, ni depuis votre réseau local, mais depuis l'internet.
    C'est-à-dire au delà de la box free.

    @+
    Si vous êtes de mon aide, vous pouvez cliquer sur .
    Mon site : http://www.jcz.fr

  5. #5
    Membre éclairé
    Avatar de BlackoOSX
    Homme Profil pro
    Lycéen
    Inscrit en
    septembre 2014
    Messages
    347
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 17
    Localisation : France, Vienne (Poitou Charente)

    Informations professionnelles :
    Activité : Lycéen
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : septembre 2014
    Messages : 347
    Points : 660
    Points
    660
    Billets dans le blog
    3

    Par défaut

    Bonjour et merci de votre réponse,
    Je vais créer le virtualHost plus tard (juste après ce message).
    J'aimerais juste comprendre pourquoi ma livebox ne me laisse pas la possibilité de dire vers où vont être redirigés ces ports?
    Voici les pages de configuration nécessaires de la livebox:
    Nom : Capture du 2018-09-08 12-41-37.png
Affichages : 59
Taille : 204,2 Ko
    Nom : Capture du 2018-09-08 12-41-50.png
Affichages : 58
Taille : 203,7 Ko
    Nom : Capture du 2018-09-08 12-42-11.png
Affichages : 57
Taille : 194,2 Ko
    Nom : Capture du 2018-09-08 12-42-19.png
Affichages : 57
Taille : 175,5 Ko
    Après réflexion, la livebox me laisse le choix de redirection vers l'appareil que je veux mais elle ne me laisse pas choisir l'ip mais juste son nom sur le réseau donc je suppose qu'elle le fait automatiquement.
    Merci d'avance!
    Cordialement,
    Herman Adrien.

  6. #6
    Expert éminent sénior Avatar de Artemus24
    Homme Profil pro
    Agent secret au service du président Ulysses S. Grant !
    Inscrit en
    février 2011
    Messages
    3 551
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 78
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Agent secret au service du président Ulysses S. Grant !
    Secteur : Finance

    Informations forums :
    Inscription : février 2011
    Messages : 3 551
    Points : 11 080
    Points
    11 080

    Par défaut

    Salut BlackoOSX.

    Je n'ai pas un box de chez orange, mais une box de chez SFR (NB6v2).

    1) dans la partie NAT, vous devez ouvrir les ports 80 & 443 de cette façon (chez SFR) :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    +-------+-----------+------+--------------+-------------------+---------------------+
    |  Nom  | Protocole | Type | Port Externe | Id de Destination | Port de Destination |
    +-------+-----------+------+--------------+-------------------+---------------------+
    | HTTP  | Les  Deux | Port |      80      |    192.168.1.33   |          80         |
    | HTTPS | Les  Deux | Port |     443      |    192.168.1.33   |         443         |
    +-------+-----------+------+--------------+-------------------+---------------------+
    "Les deux" pour le protocole signifie "TCP" et "UDP".

    2) pour la partie DHCP (chez SFR) :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    Serveur DHCP :
    Activation : ON
    Première adresse : 192.168.1.100
    Dernière adresse : 192.168.1.240
    Bail (en seconde) : 86400
    
    Adresse Statique :
    +--------------+-------------------+
    |  Adresse IP  |    Adresse MAC    |
    +--------------+-------------------+
    | 192.168.1.33 | XX:XX:XX:XX:XX:XX |
    +--------------+-------------------+
    3) configuration DNS : aucun intérêt !

    Si vous ne savez pas quoi mettre, mettre ceux de chez Google : 8.8.8.8 & 8.8.4.4

    4) le virtualhosts :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    <VirtualHost 192.168.1.33:80  [xx:xx:xx:xx:x:x:x:330]:80>
    	ServerName votre.domaine.fr
    	DocumentRoot "f:/Site-01/"
    #
    	ErrorLog  "f:/Site-01/Logs/error.log"
    	CustomLog "f:/Site-01/Logs/custom.log" common
    #
    	<Directory />
    		Options -Indexes +FollowSymLinks +MultiViews
    		AllowOverride all
    		<RequireAny>
    			Require all granted
    		</RequireAny>
    	</Directory>
    </VirtualHost>
    192.168.1.33 est l'adresse IPv4 de votre ordinateur, là où se trouve votre serveur apache (enfin web).
    xx:xx:xx:xx:xx:xx est l'adresse IPv6 de votre ordinateur. Même remarque.

    "Require all granted" donne l'accès à votre serveur apache, à toutes les adresses WAN, donc celle d'internet.

    5) Le plus important : le pare-feu !!!
    Il faut créer une règle dans votre pare-feu afin d'autoriser les accès à votre serveur apache.

    Chez moi, apache, c'est : "Apache 2.4.34".
    Il se trouve dans : "F:\Wamp\bin\apache\apache2.4.34\bin\httpd.exe".
    Ouvrir les ports TCP 80 et 443. Attention au sens de "local" et à "distance" (sous windows) pour les ports.
    A faire aussi bien pour le flux entrant que le flux sortant.

    Et c'est tout.

    @+
    Si vous êtes de mon aide, vous pouvez cliquer sur .
    Mon site : http://www.jcz.fr

  7. #7
    Membre éclairé
    Avatar de BlackoOSX
    Homme Profil pro
    Lycéen
    Inscrit en
    septembre 2014
    Messages
    347
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 17
    Localisation : France, Vienne (Poitou Charente)

    Informations professionnelles :
    Activité : Lycéen
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : septembre 2014
    Messages : 347
    Points : 660
    Points
    660
    Billets dans le blog
    3

    Par défaut

    Bonjour!
    J'ai réussi à configurer mon raspberry et à le faire accéder depuis l'extérieur via mon dns depuis l'extérieur.
    Tout fonctionne à présent.
    Merci!
    Juste une dernière question: Comment ce fait-il que je ne puisse pas accéder à mon raspberry comme si j'étais à l'extérieur quand je suis à l'intérieur de mon réseau local?
    Parce que du coup le raspberry me sert de serveur de fichier ownCloud et j'utilise un outil de synchronisation qui se sert d'une adresse pour synchroniser les fichiers vers le raspberry et donc je suis obligé de changer d'adresse (IpV4 ou nom de domaine si je suis de l'extérieur) quand je change de router....
    Avez-vous une solution à ce petit problème?
    Merci d'avance!
    Cordialement,
    Herman Adrien.

  8. #8
    Expert éminent sénior Avatar de Artemus24
    Homme Profil pro
    Agent secret au service du président Ulysses S. Grant !
    Inscrit en
    février 2011
    Messages
    3 551
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 78
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Agent secret au service du président Ulysses S. Grant !
    Secteur : Finance

    Informations forums :
    Inscription : février 2011
    Messages : 3 551
    Points : 11 080
    Points
    11 080

    Par défaut

    Salut BlackoOSX.

    Citation Envoyé par BlackoOSX
    Comment ce fait-il que je ne puisse pas accéder à mon raspberry comme si j'étais à l'extérieur quand je suis à l'intérieur de mon réseau local?
    Il est facile de comprendre que venant de l'extérieur, vous passez obligatoirement par votre box/routeur qui au travers de votre NAT va vous diriger vers le bon périphérique.
    Mais à l'intérieur de votre réseau local, votre requête ignore où aller.

    Pour résoudre ce genre de problème, vous devez posséder deux niveaux pour l'attribution des adresses IP à votre nom de site.
    Si à l'extérieur, donc sous internet, vous possédez un nom de domaine, chez votre registar, vous pouvez attribuer par exemple www.domaine.fr à l'adresse wan de votre box.
    Mais voilà, cette adresse wan ne vous sert à rien dans votre LAN, ce qui vous oblige soit à utiliser le DNS de votre box pour attribuer dans votre réseau local, le nom de votre site www.domaine.fr à une adresse local, c'est-à-dire à quelque chose du genre 192.168.1.x qui est l'adresse IP où se trouve votre serveur web.
    C'est la bonne méthode, ce qui permet de rendre accessible, ce nom de site à tous vos périphérique.

    L'autre méthode, plus simple et plus contraignante, consiste à mettre ce même couple (www.domaine.fr, 192.168.1.x) dans le fichier hosts de tous vos ordinateurs et autres tablettes.

    @+
    Si vous êtes de mon aide, vous pouvez cliquer sur .
    Mon site : http://www.jcz.fr

  9. #9
    Membre éclairé
    Avatar de BlackoOSX
    Homme Profil pro
    Lycéen
    Inscrit en
    septembre 2014
    Messages
    347
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 17
    Localisation : France, Vienne (Poitou Charente)

    Informations professionnelles :
    Activité : Lycéen
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : septembre 2014
    Messages : 347
    Points : 660
    Points
    660
    Billets dans le blog
    3

    Par défaut

    D'accord merci beaucoup pour vos réponses !
    Cordialement,
    Herman Adrien.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Serveur local accessible de l'extérieur
    Par zerkos dans le forum Apache
    Réponses: 2
    Dernier message: 07/03/2012, 11h18
  2. Serveur sous Tomcat : accessible depuis l'extérieur ?
    Par Monkey_D.Luffy dans le forum Tomcat et TomEE
    Réponses: 2
    Dernier message: 19/06/2008, 13h37
  3. Serveur Apache accessible de l'extérieur
    Par figarojuju dans le forum Apache
    Réponses: 5
    Dernier message: 13/05/2008, 13h13
  4. serveur IIS + access => base vérouillée
    Par infameus dans le forum Access
    Réponses: 4
    Dernier message: 11/10/2005, 09h25
  5. Pb Procedure Stockée sous SQL SERVEUR et ACCESS
    Par alexcluzel dans le forum MS SQL-Server
    Réponses: 24
    Dernier message: 30/07/2004, 16h31

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo