Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Membre à l'essai
    Profil pro
    Inscrit en
    avril 2007
    Messages
    46
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2007
    Messages : 46
    Points : 18
    Points
    18

    Par défaut PB Perte de connexion entre base dorsale et frontale sur réseau erreur 3343

    Bonjour
    Voila depuis mi juillet nous avons des coupures intempestives et aléatoires entre la base de données ou sont stockées les tables sur l'ordinateur "serveur" windows 10 et les bdd avec formulaire sur chaque poste utilisateurs windows 10 pro également.
    mes infos : Access 2016 à jour et windows 10 à jour.
    ce qui se passe :
    aléatoirement d'un seul coup il y a un message d'erreur qui s'affiche "Format de base non reconnue, impossible d'accès.... erreur 3343"
    ce que je suis obligé de faire :
    supprimer le fichier avec le petit cadenas,
    ouvrir la base de donnée avec les tables
    elle me propose de la réparer, cette opération marche avec succès puis je ferme
    et tout refonctionne.
    Après il peux y avoir 2 heures ou juste 30 minutes avant que cela se reproduise c'est complètement aléatoire, et ce n'est pas sur un formulaire particulier.
    j'ai vérifié le réseau, je ne pense pas que cela proviennent de là car j'ai une autre application qui est sur serveur et qui distribue données sur pc et la rien à signaler.
    J'ai carrément recopier les données dans une nouvelle BDD vierge pour éliminer ce problème mais rien n'y change.
    J'ai changé l'emplacement de la BDD avec données sur un autre PC pour voir si ça n'était pas l'ordinateur qui avait un prob, cela se reproduit quand même.
    J'ai essayé de remettre une version d'access datant de fin juin avant le problème, et cela ne change rien non plus.

    est ce que vous auriez une idée d'ou vient ce problème?

    Cordialement

  2. #2
    Membre régulier
    Homme Profil pro
    Administrateur systèmes et réseaux
    Inscrit en
    janvier 2012
    Messages
    78
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Algérie

    Informations professionnelles :
    Activité : Administrateur systèmes et réseaux
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : janvier 2012
    Messages : 78
    Points : 73
    Points
    73

    Par défaut

    A ma "modeste" connaissance, Je ne crois pas que ça existe une solution a ce problème coté Access/VBA

    La seul solution c'est de trouver la source de ces coupures, revérifier les câbles, les connexions, les switchs, les par feu l'alimentation électrique des armoires informatiques, s'il y a des coupures du courant il faut utiliser un onduleur pour chaque armoire et l'alimentation des switchs, modems, routers etc il faut qu'elle soit ininterrompue

    Aussi il ne faut pas arrêter/redémarrer le serveur avant de fermer les bdd sur les postes clients

  3. #3
    Membre à l'essai
    Homme Profil pro
    Développeur informatique
    Inscrit en
    juin 2011
    Messages
    26
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : Aéronautique - Marine - Espace - Armement

    Informations forums :
    Inscription : juin 2011
    Messages : 26
    Points : 24
    Points
    24

    Par défaut Relations index clé primaire

    Bonjour,

    J'ai eu le même cas ces dernières semaines les choses semblent revenues à la normale aussi invraisemblable que cela puisse paraître dans mon cas le compactage avait entraîné une perte d'index et de clé primaire sur deux trois tables.

    Dès que tout ceci a été remis d'aplomb tout est redevenu normal en espérant que cela soit pareil pour toi.

    Cordialement

  4. #4
    Membre à l'essai
    Profil pro
    Inscrit en
    avril 2007
    Messages
    46
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2007
    Messages : 46
    Points : 18
    Points
    18

    Par défaut

    ok merci pour ces infos
    alors chaque poste est équipé d'un onduleur, donc j'ai un doute sur cette piste
    par contre je vais explorer du côté des indexs etc

    Je vous tiendrais informé

    Merci

  5. #5
    Membre à l'essai
    Homme Profil pro
    Développeur informatique
    Inscrit en
    juin 2011
    Messages
    26
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : Aéronautique - Marine - Espace - Armement

    Informations forums :
    Inscription : juin 2011
    Messages : 26
    Points : 24
    Points
    24

    Par défaut Avancé...

    Bonjour,

    Avez vous pu avancer sur votre problématique ?

  6. #6
    Membre à l'essai
    Profil pro
    Inscrit en
    avril 2007
    Messages
    46
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2007
    Messages : 46
    Points : 18
    Points
    18

    Par défaut

    Bonjour
    désolé du temps de réponse
    en fait non le problème n'est pas résolu toujours les mêmes symptômes et complètement aléatoire.
    pendant 5 jours tout vas bien et ensuite plusieurs fois dans la journée ça recommence...
    je pensais que c'étais du aux Màj de office, mais non.
    Je désespére car personne d'autre apparement a ce problème.

  7. #7
    Expert éminent
    Avatar de tee_grandbois
    Homme Profil pro
    retraité mais encore activé
    Inscrit en
    novembre 2004
    Messages
    4 365
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 62
    Localisation : France, Yvelines (Île de France)

    Informations professionnelles :
    Activité : retraité mais encore activé

    Informations forums :
    Inscription : novembre 2004
    Messages : 4 365
    Points : 7 462
    Points
    7 462

    Par défaut

    bonjour,
    est-ce que par hasard la carte réseau du serveur ou du PC ne se mettrait pas en mode veille ? cela peut être une cause possible.
    Quand on est derrière l'écran on n'a aucun clavier sous les mains ...

  8. #8
    Membre chevronné Avatar de hyperion13
    Homme Profil pro
    Calot120 - Enseignant Post Bac
    Inscrit en
    octobre 2007
    Messages
    1 368
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 54
    Localisation : France

    Informations professionnelles :
    Activité : Calot120 - Enseignant Post Bac
    Secteur : Enseignement

    Informations forums :
    Inscription : octobre 2007
    Messages : 1 368
    Points : 2 099
    Points
    2 099

    Par défaut

    Salut
    La bdd en *.mdb ou *.accdb ?
    "Le savoir est la seule matière qui s'accroit quand on la partage" (Socrate)
    GMT+4 - 21°19'18" S - 055°25'32" E
    Inutile de me contacter par MP
    Merci de cliquer sur si la réponse est pertinente. N'oubliez pas svp de clôturer le sujet en cliquant sur

  9. #9
    Membre à l'essai
    Profil pro
    Inscrit en
    avril 2007
    Messages
    46
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2007
    Messages : 46
    Points : 18
    Points
    18

    Par défaut

    Bonjour
    pour ce qui est de la carte réseau j'ai même déplacé la base sur un autre PC
    même symptôme et aléatoire.
    (par ex : aujourd'hui pour l'instant 0 plantage...)

    Pour le format des bases :
    dorsale et celle des formulaires en : .accdb

    Cordialement.

Discussions similaires

  1. connexion entre base access et VBa ecxel
    Par slakode dans le forum Macros et VBA Excel
    Réponses: 1
    Dernier message: 16/02/2015, 20h45
  2. Connexion entre base de données et Android (JSON)
    Par omarouen dans le forum Android
    Réponses: 5
    Dernier message: 24/02/2012, 15h31
  3. [Data] Perte de connexion à la base sans auto-reconnexion
    Par Yoann.chambonnet dans le forum Spring
    Réponses: 0
    Dernier message: 02/10/2009, 15h04
  4. perte de connexion à une base FireBird
    Par djool dans le forum Connexion aux bases de données
    Réponses: 2
    Dernier message: 17/02/2009, 17h24
  5. Réponses: 7
    Dernier message: 12/06/2007, 11h07

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo