Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Membre régulier

    Homme Profil pro
    retraité
    Inscrit en
    septembre 2006
    Messages
    48
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Gironde (Aquitaine)

    Informations professionnelles :
    Activité : retraité
    Secteur : Aéronautique - Marine - Espace - Armement

    Informations forums :
    Inscription : septembre 2006
    Messages : 48
    Points : 104
    Points
    104

    Par défaut Installation impossible de Lazarus 1.8.2

    Bonjour,
    J'etais sous linux mint 17 sur 2 pc depuis plus de 2 ans avec lazarus 1.6
    J'avais eu quelques soucis pour l'installation au début, mais depuis pas de problème sur mes 2 pc.
    Je viens de passer sous linux mint 19 (réinstallation complète).
    Sur mon premier pc,installation de lazarus 1.8.2 sans problème à partir des dépôts officiels.
    Mais sur le second pc,impossible de faire l'installation de lazarus,Erreur : "fpc.cfg" est absent.

    J'ai installé fpcdeluxe,qui m'a demandé subversion et cmaque,et la pas de problème.

  2. #2
    Membre confirmé
    Homme Profil pro
    Technicien maintenance
    Inscrit en
    novembre 2012
    Messages
    240
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Vienne (Poitou Charente)

    Informations professionnelles :
    Activité : Technicien maintenance
    Secteur : Administration - Collectivité locale

    Informations forums :
    Inscription : novembre 2012
    Messages : 240
    Points : 566
    Points
    566

    Par défaut

    Bonjour,

    Le compilateur Free Pascal est-il entièrement installé ? Il se compose de pas mal de paquets du genre fpc ou fp-compiler et d'autres paquets pour les Unit (fp-units-base, fp-units-misc etc..)

  3. #3
    Membre régulier

    Homme Profil pro
    retraité
    Inscrit en
    septembre 2006
    Messages
    48
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Gironde (Aquitaine)

    Informations professionnelles :
    Activité : retraité
    Secteur : Aéronautique - Marine - Espace - Armement

    Informations forums :
    Inscription : septembre 2006
    Messages : 48
    Points : 104
    Points
    104

    Par défaut

    Bonjour,
    Merci pour ta réponse.
    Sur mes 2 pc j'ai fait la mème installation,avec le gestionnaire d'installation.
    Comme d'habitude j'ai installé :
    Fpc
    Fpc source
    Lazarus
    Ce qui entraine l'installation de nombreuses dépendances,et sans erreur.

  4. #4
    Membre émérite
    Avatar de BeanzMaster
    Homme Profil pro
    Amateur Passionné
    Inscrit en
    septembre 2015
    Messages
    886
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Suisse

    Informations professionnelles :
    Activité : Amateur Passionné
    Secteur : Tourisme - Loisirs

    Informations forums :
    Inscription : septembre 2015
    Messages : 886
    Points : 2 452
    Points
    2 452
    Billets dans le blog
    2

    Par défaut

    Bonsoir

    Il semblerai que ce soit un problème lié au chemin d'accès. Attention à l'ordre d'installation

    FPC-Source
    FPC
    Lazarus

    Je te conseillerai de désinstaller Lazarus et FPC et de nettoyer les caches de Mint et de recommencer l'installation.
    Les versions de FPC et FPC-Sources dans les dépôts sont-elles les bonnes versions entre elles et par rapport à Lazarus 1.8.2. ?
    Sinon utilise FPCUpDeluxe ce qui te permettra d'installer la 1.8.4

    Bonne soirée
    • "L'Homme devrait mettre autant d'ardeur à simplifier sa vie qu'il met à la compliquer" - Henri Bergson
    • "Bien des livres auraient été plus clairs s'ils n'avaient pas voulu être si clairs" - Emmanuel Kant
    • "La simplicité est la sophistication suprême" - Léonard De Vinci
    • "Ce qui est facile à comprendre ou à faire pour toi, ne l'est pas forcément pour l'autre." - Mon pèrei

    Mes projets sur Github - Blog - Site DVP

  5. #5
    Membre régulier

    Homme Profil pro
    retraité
    Inscrit en
    septembre 2006
    Messages
    48
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Gironde (Aquitaine)

    Informations professionnelles :
    Activité : retraité
    Secteur : Aéronautique - Marine - Espace - Armement

    Informations forums :
    Inscription : septembre 2006
    Messages : 48
    Points : 104
    Points
    104

    Par défaut

    Bonsoir et merci.
    J'avais installé FPCUpdeluxe,et il fonctionne très bien.
    Je laisse tomber l'installation de Lazarus.

  6. #6
    Expert éminent sénior
    Avatar de Jipété
    Profil pro
    Inscrit en
    juillet 2006
    Messages
    7 438
    Détails du profil
    Informations personnelles :
    Localisation : France, Hérault (Languedoc Roussillon)

    Informations forums :
    Inscription : juillet 2006
    Messages : 7 438
    Points : 10 712
    Points
    10 712

    Par défaut

    Salustre,
    Citation Envoyé par BeanzMaster Voir le message
    Attention à l'ordre d'installation

    FPC-Source
    FPC
    Lazarus
    C'est bizarre, ce n'est pas ce que j'ai dans mes fiches pense-bête :
    Citation Envoyé par mémofiches-ordrinstall
    1-FPC
    2-FPC-Source
    3-Lazarus
    et ça a toujours parfaitement bien fonctionné, depuis au moins la 1.0.8.
    Il a à vivre sa vie comme ça et il est mûr sur ce mur se creusant la tête : peutêtre qu'il peut être sûr, etc.
    Oui, je milite pour l'orthographe et le respect du trait d'union à l'impératif.
    Après avoir posté, relisez-vous ! Et en cas d'erreur ou d'oubli, il existe un bouton « Modifier », à utiliser sans modération
    On a des lois pour protéger les remboursements aux faiseurs d’argent. On n’en a pas pour empêcher un être humain de mourir de misère.
    Mes 2 cts,
    --
    jp

  7. #7
    Membre émérite
    Avatar de BeanzMaster
    Homme Profil pro
    Amateur Passionné
    Inscrit en
    septembre 2015
    Messages
    886
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Suisse

    Informations professionnelles :
    Activité : Amateur Passionné
    Secteur : Tourisme - Loisirs

    Informations forums :
    Inscription : septembre 2015
    Messages : 886
    Points : 2 452
    Points
    2 452
    Billets dans le blog
    2

    Par défaut

    Salut Jipete merci de confirmer que je me suis trompé je n'étais plus très sûr

    A pluche
    • "L'Homme devrait mettre autant d'ardeur à simplifier sa vie qu'il met à la compliquer" - Henri Bergson
    • "Bien des livres auraient été plus clairs s'ils n'avaient pas voulu être si clairs" - Emmanuel Kant
    • "La simplicité est la sophistication suprême" - Léonard De Vinci
    • "Ce qui est facile à comprendre ou à faire pour toi, ne l'est pas forcément pour l'autre." - Mon pèrei

    Mes projets sur Github - Blog - Site DVP

  8. #8
    Membre régulier

    Homme Profil pro
    retraité
    Inscrit en
    septembre 2006
    Messages
    48
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Gironde (Aquitaine)

    Informations professionnelles :
    Activité : retraité
    Secteur : Aéronautique - Marine - Espace - Armement

    Informations forums :
    Inscription : septembre 2006
    Messages : 48
    Points : 104
    Points
    104

    Par défaut Lazarus 1.8.4 finalement installé

    Bonsoir.
    Après avoir fait un ménage complet avec synaptic en supprimant tout ce qui concerne:
    lazarus
    fpc
    fpcsrc
    fp-compiler
    fp-ide
    fp-units-rtl
    J'ai pu installer la version 1.8.4 a partir des 3 fichiers .deb
    fpc
    fpcsrc
    lazarus
    ___________________________
    mes 2 installations 1.8.2 et 1.9 faites avec fpcupdeluxe fonctionnent toujours très bien.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. installation impossible de gimp !
    Par Bibouda dans le forum Autres Logiciels
    Réponses: 8
    Dernier message: 16/12/2005, 18h37
  2. Erreur installation impossible ..
    Par ronando dans le forum PostgreSQL
    Réponses: 4
    Dernier message: 29/07/2005, 12h20
  3. Réponses: 1
    Dernier message: 05/06/2005, 15h57
  4. [Install]Impossible de lancer eclipse
    Par kaishef dans le forum Eclipse Java
    Réponses: 1
    Dernier message: 10/05/2005, 11h02
  5. Installation impossible des drivers
    Par MrEddy dans le forum Matériel
    Réponses: 4
    Dernier message: 02/05/2004, 12h58

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo