Pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter, inscrivez-vous gratuitement !

 

  1. #1
    Nouveau Candidat au Club
    Homme Profil pro
    Étudiant
    Inscrit en
    août 2018
    Messages
    2
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Aube (Champagne Ardenne)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : août 2018
    Messages : 2
    Points : 1
    Points
    1

    Par défaut Aide pour mes premiers exercices en algorithmique

    Bonjours , je suis un nouvel étudiant en math et informatique en Algérie la rentrée scolaire est prévus pour le 16 septembre mais ma curiosité m'a pousser a aller faire des recherches sur les modules qu'on va étudier je suis tomber sur l'algorithme j'ai vu quelques vidéos et je suis tomber sur des exercices vu que je ne connais aucune personne qui s'y connais en info je me permet de poster mes solution en espérant que quelqu’un puisse me corriger merci a vous

    donc exercice 1 Écrire un algorithme permettant de vérifier si un nombre entier est pair ou impair

    exercice 2 Écrire un algorithme qui affiche le maximum de trois nombres saisis.

    exercice 3 Écrire un algorithme qui permet d'afficher une mention à un étudiant selon la moyenne de ses notes : ** "Très bien" pour une moyenne comprise entre 16 et 20 ** "Bien" pour une moyenne comprise entre 14 et 16 ** "Assez bien" pour une moyenne comprise entre 12 et 14 ** "Passable" pour une moyenne comprise entre 10 et 12
    Fichiers attachés Fichiers attachés

  2. #2
    Expert confirmé
    Avatar de anapurna
    Homme Profil pro
    Développeur informatique
    Inscrit en
    mai 2002
    Messages
    2 679
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : Arts - Culture

    Informations forums :
    Inscription : mai 2002
    Messages : 2 679
    Points : 4 292
    Points
    4 292

    Par défaut

    salut

    le premier me semble correcte par contre le second tu as oublié la lecture de la variable c
    est tes test ne sont pas cohérent tu fait des fin si avant un sinon le fin si marque la fin du block si
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    ALGORITHME Max
     
    PROCEDURE MAIN 
    VARIABLES
       a,b,c : réel;
    DEBUT 
       Ecrire ("saisissez une valeur pour a :");
       Lire(a);
       Ecrire ("saisissez une valeur pour b :");
       Lire(b);
       Ecrire ("saisissez une valeur pour c :");
       Lire(C);
       SI a > b ALORS 
          SI a > C ALORS
             Ecrire ("le maximum des trois nombres saisis est a :" ,a ); // a SUP b et a SUP C
          SINON
              Ecrire ("le maximum des trois nombres saisis est c :" ,c ); // a SUP b et a INF C
          FINSI  
       SINON     
          SI b >C ALORS  
             Ecrire ("le maximum des trois nombres saisis est b :" ,b ); // A INF B et b SUP C
          SINON     
             Ecrire ("le maximum des trois nombres saisis est c :" ,c ); // A INF B et b INF C
          FINSI
      FINSI
    FIN
    dans le 3ieme exercice tu fait la meme erreur que dans le second
    la mention FIN SI termine le block SI ALORS [SINON] FINSI la mention SINON n'est pas obligatoire


    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    ALGORITHME mention
    
    PROCEDURE MAIN 
    VARIABLES 
      a : réel;
    DEBUT
      Ecrire (" entrez votre moyenne : ") ;
      Lire (a);
      SI ( a <10 ) ALORS  
         Ecrire ("Votre moyenne est de",a " vous n'avez pas de mention "); 
      SINON
        SI ( 10≤a<12 ) ALORS  
            Ecrire ("Votre moyenne est de" ,a " vous avez une mention passable");
        SINON
           SI ( 12≤a<14) ALORS  
               Ecrire ("Votre moyenne est de" ,a " vous avez une mention assez bien");
           SINON 
               SI ( 14≤a<16) ALORS   
                  Ecrire ("Votre moyenne est de" ,a " vous avez une mention bien");
               SINON 
                    Ecrire ("Votre moyenne est de" ,a " vous avez une mention trés bien"); 
               FINSI
           FINSI
         FINSI
       FINSI
    FIN
    Nous souhaitons la vérité et nous trouvons qu'incertitude. [...]
    Nous sommes incapables de ne pas souhaiter la vérité et le bonheur, et sommes incapables ni de certitude ni de bonheur.
    Blaise Pascal
    PS : n'oubliez pas le tag

  3. #3
    Membre expérimenté

    Homme Profil pro
    Formation: Chimie et Physique (structure de la matière)
    Inscrit en
    décembre 2010
    Messages
    672
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 72
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Formation: Chimie et Physique (structure de la matière)
    Secteur : Enseignement

    Informations forums :
    Inscription : décembre 2010
    Messages : 672
    Points : 1 347
    Points
    1 347
    Billets dans le blog
    5

    Par défaut

    Bonjour,

    Ex_2: La condition
    (a>b,c)
    n'est pas claire (bien qu'on la devine), et se réfère implicitement à deux autres:
    Il peut être plus simple de faire intervenir une quatrième variable, qui permet de se limiter à deux comparaisons successives:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    VARIABLES a,b,c, m : réel;
    Ecrire ("saisissez une valeur pour a :");
    Lire(a);
    Ecrire ("saisissez une valeur pour b :");
    Lire(b);
    Ecrire ("saisissez une valeur pour c :");
    Lire(c);
    
    DEBUT
    SI (a>b) ALORS m:=a          // on affecte alors la valeur de (a) à la variable (m)
             SINON m:=b;         // on affecte alors la valeur de (b) à la variable (m)
    FINSI;
    SI (m<c) ALORS m:=c;         // on affecte alors la valeur de (c) à la variable (m)
    FINSI;
    Ecrire ("le maximum des trois nombres saisis est:  " , m );
    FIN
    On renonce alors à afficher de quelle variable il s'agit (ce que l'énoncé ne demande pas).
    L'avantage est l'évitement des réponses arbitraires et fausses dans le cas ennuyeux des valeurs égales (a=b , b=c , a=c ou pire encore: a=b=c).
    Ma notation du pseudo-code est un peu approximative.


    Le français, notre affaire à tous
    Grand Dictionnaire Terminologique

  4. #4
    Nouveau Candidat au Club
    Homme Profil pro
    Étudiant
    Inscrit en
    août 2018
    Messages
    2
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Aube (Champagne Ardenne)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : août 2018
    Messages : 2
    Points : 1
    Points
    1

    Par défaut

    ah d'accord merci a vous j'ai compris pour le cas de wiwaxia je me sens unpeu stupide de ne pas y avoir pensée merci a vous j'ai une question est ce que je dois mettre ce topic en résolu ? ou bien je peux le laisser non résolu et y re poster des exos pour m'aider ?


    et encore merci

  5. #5
    Membre expérimenté

    Homme Profil pro
    Formation: Chimie et Physique (structure de la matière)
    Inscrit en
    décembre 2010
    Messages
    672
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 72
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Formation: Chimie et Physique (structure de la matière)
    Secteur : Enseignement

    Informations forums :
    Inscription : décembre 2010
    Messages : 672
    Points : 1 347
    Points
    1 347
    Billets dans le blog
    5

    Par défaut Aide pour mes premiers exercices en algorithmique

    Si les réponses te conviennent, tu marques le sujet "résolu".

    Tu lanceras une autre discussion pour d'autres questions - un seul sujet à la fois.


    Le français, notre affaire à tous
    Grand Dictionnaire Terminologique

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. De l'aide pour mes premiers pas
    Par bafff dans le forum Débuter
    Réponses: 2
    Dernier message: 18/03/2014, 14h03
  2. Bsoin d'aide pour mon premier site
    Par Ifrit-ultima dans le forum Débuter
    Réponses: 0
    Dernier message: 29/01/2008, 22h13
  3. besoin d'aide pour mes plans de carrière
    Par angelmn dans le forum Etudes
    Réponses: 15
    Dernier message: 05/07/2007, 15h46
  4. Besoin d'aide pour mon premier article tex
    Par amel666 dans le forum Erreurs - Avertissements
    Réponses: 2
    Dernier message: 21/02/2007, 13h18
  5. Réponses: 4
    Dernier message: 28/07/2005, 16h22

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo