Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Applications et environnements graphiques Discussion :

LibreOffice writer ne se lance pas


Sujet :

Applications et environnements graphiques

  1. #1
    Membre régulier

    Inscrit en
    octobre 2003
    Messages
    152
    Détails du profil
    Informations forums :
    Inscription : octobre 2003
    Messages : 152
    Points : 115
    Points
    115
    Par défaut LibreOffice writer ne se lance pas
    Bonsoir.

    Je suis sur Lubuntu 17.10.
    J'ai installé libreoffice et impossible d'exécuter writer.
    Calc se lance correctement de même que les autre applicatifs de libreoffice mais rien à faire avec writer.
    J'ai installe libreoffice 6 mais idem.

    Je ne comprend pas pourquoi et surtout, je n'arrive pas à trouver le fichier de log où trouver des billes pour me débloquer.
    Toute aide sera la bienvenue.

    Olivier

  2. #2
    Expert éminent sénior
    Avatar de Jipété
    Profil pro
    Inscrit en
    juillet 2006
    Messages
    8 763
    Détails du profil
    Informations personnelles :
    Localisation : France, Hérault (Languedoc Roussillon)

    Informations forums :
    Inscription : juillet 2006
    Messages : 8 763
    Points : 12 463
    Points
    12 463
    Par défaut
    Salut,

    lance-le depuis un terminal, ça en dira peut-être plus : soffice --writer.
    Il a à vivre sa vie comme ça et il est mûr sur ce mur se creusant la tête : peutêtre qu'il peut être sûr, etc.
    Oui, je milite pour l'orthographe et le respect du trait d'union à l'impératif.
    Après avoir posté, relisez-vous ! Et en cas d'erreur ou d'oubli, il existe un bouton « Modifier », à utiliser sans modération
    On a des lois pour protéger les remboursements aux faiseurs d’argent. On n’en a pas pour empêcher un être humain de mourir de misère.
    Mes 2 cts,
    --
    jp

  3. #3
    Membre chevronné

    Homme Profil pro
    Retraité
    Inscrit en
    juin 2012
    Messages
    1 036
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Retraité
    Secteur : Biens de consommation

    Informations forums :
    Inscription : juin 2012
    Messages : 1 036
    Points : 2 022
    Points
    2 022
    Par défaut
    Citation Envoyé par Jipété Voir le message
    Salut,

    lance-le depuis un terminal, ça en dira peut-être plus : soffice --writer.
    On peut aussi faire soffice tout court et si ça démarre choisir ensuite document writer pour voir ce qui se passe.

  4. #4
    Membre régulier

    Inscrit en
    octobre 2003
    Messages
    152
    Détails du profil
    Informations forums :
    Inscription : octobre 2003
    Messages : 152
    Points : 115
    Points
    115
    Par défaut
    Voici ce que j'obtiens :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    soffice --writer
    ** (soffice:1229): WARNING **: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not provided by any .service files
    Mais j'obtiens le même message avec et pour autant, calc s'exécute correctement...

  5. #5
    Responsable Systèmes


    Homme Profil pro
    Technicien maintenance
    Inscrit en
    août 2011
    Messages
    12 223
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Technicien maintenance
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : août 2011
    Messages : 12 223
    Points : 27 313
    Points
    27 313
    Par défaut
    Installes dbus ou libdbus.

    Peut-être que calc n'en a pas besoin, ou du moins pour démarrer.

    C'est un warning, le problème peut être aussi ailleurs.
    Ma page sur developpez.com : http://chrtophe.developpez.com/ (avec mes articles)
    Mon article sur la création d'un système : http://chrtophe.developpez.com/tutoriels/minisysteme/
    Mon article sur le P2V : http://chrtophe.developpez.com/tutoriels/p2v/
    Consultez nos FAQ : Windows, Linux, Virtualisation

  6. #6
    Membre chevronné

    Homme Profil pro
    Retraité
    Inscrit en
    juin 2012
    Messages
    1 036
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Retraité
    Secteur : Biens de consommation

    Informations forums :
    Inscription : juin 2012
    Messages : 1 036
    Points : 2 022
    Points
    2 022
    Par défaut
    Je crois me souvenir qu'une version particulière du Kernel posait ce problème. A tout hasard essayer en démarrant avec un autre kernel.

  7. #7
    Membre régulier

    Inscrit en
    octobre 2003
    Messages
    152
    Détails du profil
    Informations forums :
    Inscription : octobre 2003
    Messages : 152
    Points : 115
    Points
    115
    Par défaut
    chrtophe, voici ce que j'obtiens pour l'insatll de dbus
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    $ sudo apt-get install dbus
    [sudo] Mot de passe de didou*: 
    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances       
    Lecture des informations d'état... Fait
    dbus est déjà la version la plus récente (1.10.22-1ubuntu1).
    0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
    mm_71, une autre version de kernel, ça veut dire une autre version d'ubuntu?

  8. #8
    Membre chevronné

    Homme Profil pro
    Retraité
    Inscrit en
    juin 2012
    Messages
    1 036
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Retraité
    Secteur : Biens de consommation

    Informations forums :
    Inscription : juin 2012
    Messages : 1 036
    Points : 2 022
    Points
    2 022
    Par défaut
    mm_71, une autre version de kernel, ça veut dire une autre version d'ubuntu?
    Non, pas du tout. Au moment du démarrage au lieu de conserver l'option par défaut de grub va ( rapidement ) sur "options avancées et tu devrais avoir une liste des noyaux utilisés précédemment. Celui marqué d'un * est celui par défaut. Choisis en un autre ( La ligne sans upstart ou recovery mode ) et vois si ça change quelque chose.
    Voir aussi dans le gestionnaire de mises à jour si dans édition->préférences les cases
    "Inclure les mises à jour qui nécéssitent..."
    "Toujours afficher les mises à jour du noyau"
    "Toujours sélectionner les mises à jour du noyau"
    sont bien cochées.
    Si le noyau est à jour ça devrait être un 4.15, il est possible que tu te traînes une vielle version qui avait un bug empêchant l'usage de writer.

  9. #9
    Membre régulier

    Inscrit en
    octobre 2003
    Messages
    152
    Détails du profil
    Informations forums :
    Inscription : octobre 2003
    Messages : 152
    Points : 115
    Points
    115
    Par défaut
    Bonsoir.

    Milles excuses d'avoir déserté la discussion si longtemps. Je n'avais pas oublié mais j'ai été pris par ailleurs.
    Je n'ai pas de proposition d'anciennes versions au démarrage.
    Probablement par ce que j'ai abusé du
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    sudo apt-get autoremove

    Je vais attendre un nouvelle version de lubuntu. Je verrai ce qu'il en est et je compléterai cette discussion.

    Merci en tout cas de vous être penchés sur mon problème.

  10. #10
    Membre chevronné

    Homme Profil pro
    Retraité
    Inscrit en
    juin 2012
    Messages
    1 036
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Retraité
    Secteur : Biens de consommation

    Informations forums :
    Inscription : juin 2012
    Messages : 1 036
    Points : 2 022
    Points
    2 022
    Par défaut
    Je n'ai pas de proposition d'anciennes versions au démarrage.
    Il faut se déplacer rapidement sur "options avancées" de grub quand il apparaît pour pouvoir sélectionner un autre noyau. apt-get autoremove n'enlève pas les anciennes versions du noyau sous Linux Mint, je doute qu'il le fasse avec ubuntu.

  11. #11
    Responsable Systèmes


    Homme Profil pro
    Technicien maintenance
    Inscrit en
    août 2011
    Messages
    12 223
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Technicien maintenance
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : août 2011
    Messages : 12 223
    Points : 27 313
    Points
    27 313
    Par défaut
    Essayes peut-être de passer en 18.04 avec do-release-upgrade (qu'il faut installer). Nécessite update-manager-core.
    Mais attention passer en 18.04 peut te générer d'autres probs.
    Ma page sur developpez.com : http://chrtophe.developpez.com/ (avec mes articles)
    Mon article sur la création d'un système : http://chrtophe.developpez.com/tutoriels/minisysteme/
    Mon article sur le P2V : http://chrtophe.developpez.com/tutoriels/p2v/
    Consultez nos FAQ : Windows, Linux, Virtualisation

  12. #12
    Membre régulier

    Inscrit en
    octobre 2003
    Messages
    152
    Détails du profil
    Informations forums :
    Inscription : octobre 2003
    Messages : 152
    Points : 115
    Points
    115
    Par défaut
    Bonsoir.

    J'ai enfin trouvé le temps lubunu 18.04.
    Hélas, 1000 fois hélas rien a changé...
    dans /var/log/apport.log j'ai trouvé ce message d'erreur
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    gdbus call error: Error: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
    J'ai commencé à chercher mais pour l'instant, je n'ai trouvé que des choses en rapport avec l'usage de sudo ou gksudo.
    A priori pas grand chose à voir avec le lancement de writer

    To be continued comme disent nos voisin d'outre-atlantique ou d'outre-manche .

  13. #13
    Membre régulier

    Inscrit en
    octobre 2003
    Messages
    152
    Détails du profil
    Informations forums :
    Inscription : octobre 2003
    Messages : 152
    Points : 115
    Points
    115
    Par défaut
    tadaaaaa. j'ai trouvé.

    C'est un problème avec JAVA.
    Donc, dans libreoffice
    outils / options / LibreOffice / Avancé : décocher Utiliser un environnement d'exécution java
    et write fonctionne!

  14. #14
    Expert éminent sénior Avatar de Flodelarab
    Homme Profil pro
    Inscrit en
    septembre 2005
    Messages
    4 165
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Charente (Poitou Charente)

    Informations forums :
    Inscription : septembre 2005
    Messages : 4 165
    Points : 10 287
    Points
    10 287
    Par défaut
    Bonjour

    Bien.
    Mais la vraie solution ne serait-elle pas d'installer correctement java et/ou donner le lien correct à LibreOffice ?
    Cette réponse vous apporte quelque chose ? Cliquez sur en bas à droite du message.

  15. #15
    Membre régulier

    Inscrit en
    octobre 2003
    Messages
    152
    Détails du profil
    Informations forums :
    Inscription : octobre 2003
    Messages : 152
    Points : 115
    Points
    115
    Par défaut
    ben... honnêtement, je ne me suis pas posé la question.
    Telle que libre office me présentait les choses, je n'ai pas pensé qu'il pouvait s'agir d'un problème d'installation ou de lien.
    Je vais donc pousser dans ce sens et ferai un retour.
    Merci pour la suggestion

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Bootloader qui ne lance pas le Kernel
    Par Jb59 dans le forum Programmation d'OS
    Réponses: 2
    Dernier message: 01/08/2005, 23h29
  2. mmc.exe qui ne se lance pas
    Par r0d dans le forum Autres Logiciels
    Réponses: 2
    Dernier message: 27/04/2005, 18h11
  3. [Kylix] Ne se lance pas sous Fedora core 3
    Par John@EuroDevz dans le forum EDI
    Réponses: 3
    Dernier message: 14/02/2005, 17h27
  4. Mysql ne se lance pas problème de socket
    Par Riko dans le forum Installation
    Réponses: 5
    Dernier message: 05/02/2004, 10h28
  5. Envoi d'un mail en VBA: outlook ne se lance pas
    Par Hannibal dans le forum VBA Access
    Réponses: 4
    Dernier message: 01/06/2003, 16h24

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo