Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Rédacteur/Modérateur

    La nouvelle version de l'EDI Eclipse est disponible, Photon apporte le support de Java 10 et JUnit 5.1
    Eclipse 4.8 Photon est disponible en téléchargement
    la nouvelle version de l'environnement de développement Eclipse apporte le support de Java 10 et JUnit 5.1


    Eclipse Photon se compose de 85 projets, regroupant le travail de 620 contributeurs pour 73 millions de lignes de code.

    Les principales nouveautés de cette version sont :
    • Le support de Java 10


    • Le support complet de Java 9


    • Le support de JUnit 5.1


    • La création de la notion de templates pour les "Launch Configuration", qui permettent donc de fournir un ensemble de paramètres prédéfinis pour lancer un projet. Ces templates sont notamment disponibles pour les projets de type "Java" et "Eclipse Plug-ins"



    • La possibilité de modifier les "Project Natures", ces éléments qui permettent de définir les outils Eclipse devant contribuer à un projet


    • La gestion parallèle des "builds" dans le workspace, permettant d'augmenter la rapidité des builds


    • De nombreuses améliorations d'interface ont été apportées, notamment sur le "dark theme", et la perspective de "debug" a été complètement remaniée


    Enfin, la nouvelle version de l'EDI apporte deux nouvelles fonctionnalités très prisées des utilisateurs de VSCode ou IntelliJ, et qui ont été intégrées dans la plateforme Eclipse par un membre actif de Developpez.com, Angelo Zerr :
    • Le support du "CodeMining" qui permet d'afficher directement dans le code source des informations supplémentaires. Cette fonction est très facilement intégrable dans tous les éditeurs de type "Generic" via un point d'extension


    • Le support des "Inline Annotations" qui permettent de déclencher des actions sur des annotations du code, permettant par exemple d'afficher un sélecteur de couleur pour des propriétés de ce type


    Il est aussi important de mentionner que cette version marque la fin du cycle de releases annuelles qui était en place depuis de nombreuses années, au profit de releases espacées de 13 semaines. Les versions ne seront donc plus nommées spécifiquement, mais identifiées par leur numéro de release, par exemple "2018-09" pour celle qui sera disponible en septembre.

    Pour télécharger cette nouvelle version, rendez-vous sur la page de téléchargement d'Eclipse : http://www.eclipse.org/downloads/

    Pour plus d'informations, vous pouvez consulter la page du projet Photon : https://www.eclipse.org/photon/

    Et vous ?

    • Que pensez-vous de cette nouvelle version ? Et de ces nouvelles fonctionnalités ?
    • Avez-vous déjà essayé cette nouvelle version ?
    • Allez-vous migrer prochainement ?


    Retrouvez les meilleurs cours et tutoriels pour développer avec Eclipse
    Pas de messages techniques par MP, les forums sont là pour ça.
    Rédacteur d'articles sur la plateforme Eclipse

    N'oubliez pas de consulter les FAQ Eclipse et les cours et tutoriels Eclipse

  2. #2
    Expert confirmé
    Citation Envoyé par alain.bernard Voir le message

    • Le support de Java 10


    • Le support complet de Java 9

    Euhhh est-ce que ca suppose que le support de Java 10 n'est pas complet?

  3. #3
    Modérateur

    Probable, mais cette histoire de "var" ... j'aime pas du tout, je sais pas pourquoi :/ (mais c'est hs par rapport a eclipse)

    Edit : Quelqu'un a testé cette release avec windowBuilder ? Le plugin s'installe bien, mais pas moyen d'editer une interface déjà faite ou même ne serait-ce que creer un nouvelle JFrame a l'aide de l'UI (par exemple).
    Edit2 : Ok, il faut la verions 1.9.1 de WB, la 1.9.0 ne semble pas fonctionner avec photon.
    (Les "ça ne marche pas", même écrits sans faute(s), vous porteront discrédit ad vitam æternam et malheur pendant 7 ans)

    N'oubliez pas de consulter les FAQ Java et les cours et tutoriels Java

  4. #4
    Membre émérite
    Citation Envoyé par micka132 Voir le message
    Euhhh est-ce que ca suppose que le support de Java 10 n'est pas complet?
    L'histoire c'est que Java 9 ca a ete de tres gros changements par rapport au 8. Donc Eclipse IDE a release a l'epoque de la release de Java 9 un support incomplet, mais suffisant pour pas mal de cas qui permettait d'utiliser quand meme du Java 9 correctement.
    D'autres features qui etaient prevues mais n'avait pas eu le temps d'etre faites ont ete depuis rajoutees, d'ou le "support complet de Java 9".

    Le support de Java 10 est plus tranquille et routinier, donc il n'y a pas besoin a priori de faire une difference entre le support de base et le support complet. Le support est cense etre complet.
    Pour du HTML, CSS, JavaScript, TypeScript, JSon, Yaml, Node... dans Eclipse IDE, installe Eclipse Wild Web Developer
    Pour du Rust dans Eclipse IDE, installe Eclipse Corrosion
    Follow me on twitter