1. #1
    Candidat au Club
    Femme Profil pro
    Technicien de recherche
    Inscrit en
    juin 2016
    Messages
    3
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Âge : 35
    Localisation : France, Hérault (Languedoc Roussillon)

    Informations professionnelles :
    Activité : Technicien de recherche
    Secteur : Agroalimentaire - Agriculture

    Informations forums :
    Inscription : juin 2016
    Messages : 3
    Points : 2
    Points
    2

    Par défaut problème d'installation du package Factoshiny

    Bonjour,

    Je n'arrive pas à installer le package "Factoshiny" sur mon PC. J'ai bien installé et appelé avant la librairie "FactoMineR" et j'ai essayé aussi d'installer en amont "colourpicker" et "miniUI" mais rien n'y fait, impossible, et j'ai aussi essayé avec plusieurs versions de Rstudio mais pas de changement !
    Voici le message d'erreur sous RStudio 1.0.136 et R en version 3.3.2 :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    > install.packages("colourpicker")
      There are binary versions available but the source versions are later:
           binary  source needs_compilation
    httpuv  1.4.1 1.4.4.1              TRUE
    later   0.7.1   0.7.3              TRUE
    miniUI  0.1.1 0.1.1.1             FALSE
    shiny   1.0.5   1.1.0             FALSE
    Warning in install.packages :
      running command '"C:/PROGRA~1/R/R-33~1.2/bin/x64/R" CMD INSTALL -l "C:\Users\penalver\Documents\R\win-library\3.3" C:\Users\penalver\AppData\Local\Temp\RtmpaMAvJd/downloaded_packages/miniUI_0.1.1.1.tar.gz' had status 1
    Warning in install.packages :
      installation of package ‘miniUI’ had non-zero exit status
     
    > library(Factoshiny)
    Le chargement a nécessité le package : colourpicker
    Error in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]) : 
      aucun package nommé ‘miniUI’ n'est trouvé
    In addition: Warning messages:
    1: le package ‘Factoshiny’ a été compilé avec la version R 3.3.3 
    2: le package ‘colourpicker’ a été compilé avec la version R 3.3.3 
    Error: le package ‘colourpicker’ ne peut être chargé
    Quelqu'un peut-t-il m'aider ?
    Merci par avance
    Amandine

  2. #2
    Membre habitué
    Homme Profil pro
    Data scientist
    Inscrit en
    février 2017
    Messages
    80
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Data scientist
    Secteur : Conseil

    Informations forums :
    Inscription : février 2017
    Messages : 80
    Points : 149
    Points
    149

    Par défaut

    Bonjour,

    Essaye de d'installer yaml et miniUi et puis réinstaller Factoshiny:

    Essaye ca :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
     
    install.packages("yaml")
    install.packages("miniUI")
    install.packages("Factoshiny")
     
    require(Factoshiny)
    Cordialement,

  3. #3
    Candidat au Club
    Femme Profil pro
    Technicien de recherche
    Inscrit en
    juin 2016
    Messages
    3
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Âge : 35
    Localisation : France, Hérault (Languedoc Roussillon)

    Informations professionnelles :
    Activité : Technicien de recherche
    Secteur : Agroalimentaire - Agriculture

    Informations forums :
    Inscription : juin 2016
    Messages : 3
    Points : 2
    Points
    2

    Par défaut

    Bonjour,

    Merci de votre réponse, malheureusement ça n'a pas été suffisant pour résoudre mon problème.
    J'ai ce message d'erreur :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
     There are binary versions available but the source versions are later:
           binary  source needs_compilation
    httpuv  1.4.1 1.4.4.1              TRUE
    later   0.7.1   0.7.3              TRUE
    shiny   1.0.5   1.1.0             FALSE
     
      Binaries will be installed
     
    * installing *source* package 'shiny' ...
    ** package 'shiny' correctement décompressé et sommes MD5 vérifiées
    ** R
    ** inst
    ** preparing package for lazy loading
    Error in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]) : 
      namespace 'httpuv' 1.4.1 is being loaded, but >= 1.4.3 is required
    ERROR: lazy loading failed for package 'shiny'
    * removing 'C:/Users/penalver/Documents/R/win-library/3.3/shiny'
    Warning in install.packages :
      running command '"C:/PROGRA~1/R/R-33~1.2/bin/x64/R" CMD INSTALL -l "C:\Users\penalver\Documents\R\win-library\3.3" C:\Users\penalver\AppData\Local\Temp\RtmpSEh0iw/downloaded_packages/shiny_1.1.0.tar.gz' had status 1
    Warning in install.packages :
      installation of package ‘shiny’ had non-zero exit status
    > require(Factoshiny)
    Le chargement a nécessité le package : Factoshiny
    Le chargement a nécessité le package : colourpicker
    Error in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]) : 
      aucun package nommé ‘miniUI’ n'est trouvé
    In addition: Warning messages:
    1: le package ‘Factoshiny’ a été compilé avec la version R 3.3.3 
    2: le package ‘colourpicker’ a été compilé avec la version R 3.3.3 
    Failed with error:  ‘le package ‘colourpicker’ ne peut être chargé’
    et donc la librairie "Factoshiny" ne fonctionne pas.

    J'ai trouvé une autre alternative, j'ai copié mon répertoire win-library sur ce 2ème PC et là ça fonctionne en installant la même version R et Rstudio que celle où j'ai pris le dossier win-library

    Amandine

  4. #4
    Membre averti
    Inscrit en
    février 2011
    Messages
    154
    Détails du profil
    Informations forums :
    Inscription : février 2011
    Messages : 154
    Points : 321
    Points
    321

    Par défaut

    Bonjour,

    D'après ce message d'erreur :
    Error in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]) :
    namespace 'httpuv' 1.4.1 is being loaded, but >= 1.4.3 is required
    Je dirais qu'il faut que tu mettes à jour le package httpuv avant de réinstaller Factoshiny.

    cdlt

  5. #5
    Membre confirmé
    Homme Profil pro
    Chercheur
    Inscrit en
    décembre 2015
    Messages
    201
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : Chercheur
    Secteur : Enseignement

    Informations forums :
    Inscription : décembre 2015
    Messages : 201
    Points : 486
    Points
    486

    Par défaut

    Installe aussi la dernière version de R et au minimum R.3.3. Pour comment faire, voir le package installr

  6. #6
    Candidat au Club
    Femme Profil pro
    Technicien de recherche
    Inscrit en
    juin 2016
    Messages
    3
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Âge : 35
    Localisation : France, Hérault (Languedoc Roussillon)

    Informations professionnelles :
    Activité : Technicien de recherche
    Secteur : Agroalimentaire - Agriculture

    Informations forums :
    Inscription : juin 2016
    Messages : 3
    Points : 2
    Points
    2

    Par défaut

    Bonjour,

    malheureusement ça ne fonctionne toujours pas, c'est à présent le package colourpicker qui pose problème....j'ai essayé un peu dans tous les sens mais aucun résultat
    library(colourpicker)
    Error in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]) :
    aucun package nommé ‘miniUI’ n'est trouvé
    In addition: Warning message:
    le package ‘colourpicker’ a été compilé avec la version R 3.3.3
    Error: le chargement du package ou de l'espace de noms a échoué pour ‘colourpicker’
    ce que je ne comprends pas surtout c'est que ça marche très bien sur mon ordi avec la version R 3.3.2 et RStudio 1.0.44 et là impossible de faire quoi que ce soit sans un message d'erreur d'installation de librairies.
    Au final, voilà la solution qui marche si jamais vous êtes dans la même galère :
    J'ai pris l'URL de la même version de RStudio (et non la dernière en date : il suffit de modifier dans la barre de site directement en changeant dans le titre par la version que vous cherchez).
    Puis importer sur clé usb la win-library qui fonctionne vers le nouveau PC à installer,
    je m'en suis sortie comme ça...
    mais sincèrement j'ai aucune idée pourquoi ça ne fonctionne pas autrement...
    Merci à tous pour vos réponses
    Cordialement,
    Amandine

Discussions similaires

  1. [TOMCAT] Problème à l'installation du package admin.
    Par TheRussian dans le forum Tomcat
    Réponses: 4
    Dernier message: 12/03/2008, 13h33
  2. Problème d'installation avec package
    Par JLASSI dans le forum Composants VCL
    Réponses: 0
    Dernier message: 21/01/2008, 11h48
  3. Problème d'installation du package ExpressGuantumGrid
    Par jamal27 dans le forum Composants VCL
    Réponses: 0
    Dernier message: 17/10/2007, 10h16
  4. [REDHAT] Problème pour installer un package
    Par ch3ch3 dans le forum RedHat / CentOS / Fedora
    Réponses: 5
    Dernier message: 18/06/2007, 15h39
  5. Problème d'installation du package net-snmp
    Par tck-lt dans le forum Administration système
    Réponses: 5
    Dernier message: 27/02/2007, 16h29

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo