Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Nouveau Candidat au Club
    Homme Profil pro
    Développeur Web
    Inscrit en
    mars 2017
    Messages
    3
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Togo

    Informations professionnelles :
    Activité : Développeur Web

    Informations forums :
    Inscription : mars 2017
    Messages : 3
    Points : 1
    Points
    1

    Par défaut Problème avec rawsyscall

    Bonjour,
    J'utilise ubuntu 18.04 j'ai installé golang 1.10.1 jusque là tout fonctionne bien.
    j'ai installé beego avec ces codes:

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    go get github.com/astaxie/beego
    go get -u github.com/astaxie/beego
    sa a marché.
    C'est lorsque j'ai voulu installé bee avec ce code :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    go get github.com/beego/bee
    que les problèmes ont commencés. Voici une partie du code qui apparaît:

    # github.com/beego/bee/vendor/golang.org/x/sys/unix
    go/src/github.com/beego/bee/vendor/golang.org/x/sys/unix/syscall_linux_amd64.go:65:1: error: redefinition of ‘gettimeofday’
    func gettimeofday(tv *Timeval) (err syscall.Errno)
    ^
    go/src/github.com/beego/bee/vendor/golang.org/x/sys/unix/gccgo_linux_amd64.go:14:1: note: previous definition of ‘gettimeofday’ was here
    func gettimeofday(tv *Timeval) (err syscall.Errno) {
    ^
    go/src/github.com/beego/bee/vendor/golang.org/x/sys/unix/syscall_unix.go:52:1: error: redefinition of ‘Syscall’
    func Syscall(trap, a1, a2, a3 uintptr) (r1, r2 uintptr, err syscall.Errno)
    ^
    go/src/github.com/beego/bee/vendor/golang.org/x/sys/unix/gccgo.go:17:1: note: previous definition of ‘Syscall’ was here
    func Syscall(trap, a1, a2, a3 uintptr) (r1, r2 uintptr, err syscall.Errno) {
    ^

    je sais pas quoi faire. Merci

  2. #2
    Nouveau Candidat au Club
    Homme Profil pro
    Développeur informatique
    Inscrit en
    août 2009
    Messages
    1
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : août 2009
    Messages : 1
    Points : 1
    Points
    1

    Par défaut

    J'ai eu une erreur similaire, tu as peut-être le même probleme : j'ai mis à jour go sans désinstaller une version précédente version. Et avec des structures et fonctions qui ont du changer de fichiers avec la dernière version de go, il fallait d'abord supprimer l'ancienne install pour éviter des conflits à la compil.

    J'ai résolu le problème en faisant une reinstall de go propre (j'utilise les dossiers par defaut) :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    sudo rm -Rf /usr/local/go/
    sudo tar -C /usr/local -xzf go1.10.3.linux-amd64.tar.gz
    (go1.10.3.linux-amd64.tar.gz étant le dernier package stable à cet instant)

    puis à nouveau

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    go get github.com/beego/bee

  3. #3
    Nouveau Candidat au Club
    Homme Profil pro
    Développeur Web
    Inscrit en
    mars 2017
    Messages
    3
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Togo

    Informations professionnelles :
    Activité : Développeur Web

    Informations forums :
    Inscription : mars 2017
    Messages : 3
    Points : 1
    Points
    1

    Par défaut

    merci je vais essayé.

  4. #4
    Nouveau Candidat au Club
    Homme Profil pro
    Développeur Web
    Inscrit en
    mars 2017
    Messages
    3
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Togo

    Informations professionnelles :
    Activité : Développeur Web

    Informations forums :
    Inscription : mars 2017
    Messages : 3
    Points : 1
    Points
    1

    Par défaut

    Bonsoir ça na pas marché.

Discussions similaires

  1. VC++ Direct3D8, problème avec LPD3DXFONT et LPD3DTEXTURE8
    Par Magus (Dave) dans le forum DirectX
    Réponses: 3
    Dernier message: 03/08/2002, 11h10
  2. Problème avec [b]struct[/b]
    Par Bouziane Abderraouf dans le forum CORBA
    Réponses: 2
    Dernier message: 17/07/2002, 10h25
  3. Problème avec le type 'Corba::Any_out'
    Par Steven dans le forum CORBA
    Réponses: 2
    Dernier message: 14/07/2002, 18h48
  4. Problème avec la mémoire virtuelle
    Par Anonymous dans le forum CORBA
    Réponses: 13
    Dernier message: 16/04/2002, 16h10

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo