1. #1
    Membre éclairé Avatar de Drowan
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    juin 2014
    Messages
    348
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 23
    Localisation : France, Isère (Rhône Alpes)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Électronique et micro-électronique

    Informations forums :
    Inscription : juin 2014
    Messages : 348
    Points : 700
    Points
    700

    Par défaut "SWT Browser could not be created" = Problème affchage Javadoc


    Dans mon Eclipse, quand je passe ma souris sur une entité pour voir la javadoc correspondante, j'obtient à chaque fois le message suivant :
    NOTE: The SWT Browser widget could not be created. This fallback mode doesn't show links and misses other functionality.
    Capture d'écran :
    Nom : Untitled.jpg
Affichages : 91
Taille : 126,9 Ko

    La javadoc s'affiche donc mais comme indiqué dans le message d'erreur le navigateur SWT ne peut être créé. Et donc il manque des fonctionnalités. Par exemple, dans la capture d'écran jointe, les liens ne fonctionnent pas.

    Comment puis-je régler ce problème ?
    Est-ce dû à une mauvaise installation d'Eclipse ? un plugin manquant ?
    Est-ce du à l'OS qui ne supporte pas SWT ? J'ai lu des forums comme quoi il ya des problèmes avec GTK2 ou 3.
    "On sera toujours mieux installé assis en 1ère que debout en 2nde", un illustre inconnu


    Avant de poser une question vérifiez si elle n'a pas déjà une réponse dans les cours et tutoriels
    Si votre problème est pensez à marquer la conversation comme telle
    Si un message est utile, pertinent, et/ou vous êtes d'accord avec, pensez à à l'inverse s'il est inutile, faux ou que vous n'êtes pas d'accord, pensez à

  2. #2
    Membre émérite
    Avatar de Mickael_Istria
    Homme Profil pro
    Développeur Expert Eclipse IDE/RCP, pour Red Hat
    Inscrit en
    juillet 2008
    Messages
    1 184
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Isère (Rhône Alpes)

    Informations professionnelles :
    Activité : Développeur Expert Eclipse IDE/RCP, pour Red Hat
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : juillet 2008
    Messages : 1 184
    Points : 2 515
    Points
    2 515

    Par défaut

    C'est quoi ton OS et ta version de GTK et de Eclipse IDE?
    Deja, soit sur d'utiliser une version recent d'Eclipse IDE (Oxygen.2 par exemple)
    En effet, certaines version de GTK ne sont plus vraiment supportee par Eclipse IDE. Elle vont encore marcher parce que le code est stable, mais personne ne teste avec ni ne cherche a fixer les bugs dessus. Donc deja, tu peux commencer par verifier la version de gtk que tu utilises et voir si tu peux faire des mises a jour.
    Ensuite, tu devrais peut-etre chercher a installer les packages xulrunner et webkit-gtk si tu ne les a pas deja. Plus d'infos: https://www.eclipse.org/swt/faq.php#browserlinux
    Tu fais du JEE/Web/Mobile dans Eclipse IDE? Essaye JBoss Tools !
    Follow me on twitter

Discussions similaires

  1. Réponses: 0
    Dernier message: 13/09/2013, 15h55
  2. [3.1][Debian]problème de Could not find library 'swt-pi-gtk
    Par zlavock dans le forum Eclipse Java
    Réponses: 1
    Dernier message: 27/09/2005, 13h07
  3. Erreur : "could not create process"
    Par spéculteur dans le forum C++
    Réponses: 3
    Dernier message: 29/03/2005, 11h31

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo