IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Debian Discussion :

Debian Linux/ Problème téléchargement adobe flash player pour jouer en ligne


Sujet :

Debian

  1. #1
    Membre du Club
    Homme Profil pro
    Inscrit en
    février 2012
    Messages
    136
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : février 2012
    Messages : 136
    Points : 47
    Points
    47
    Par défaut Debian Linux/ Problème téléchargement adobe flash player pour jouer en ligne
    Bonjour,

    J'ai voulu jouer en ligne sur jeuxgratuits.com mais le site me demande d'installer adobe flash player. Il m'a proposé de télécharger APT pour debian/ubuntu pour linux 32-bit, français,firefox
    Mais au final, j'ai un message: "l'adresse n'a pas été reconnue. Firefox ne sait pas ouvrir cette adresse car l'un des protocoles suivants (apt) n'est associé à aucun programme ou n'est pas autorisé dans ce contexte"
    Pouvez vous me dire svp comment régler ce problème ? Merci.

    nb: j'ai un petit netbook de 1go de ram et de 32 bit

  2. #2
    Responsable Systèmes


    Homme Profil pro
    Technicien maintenance
    Inscrit en
    août 2011
    Messages
    14 683
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Technicien maintenance
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : août 2011
    Messages : 14 683
    Points : 34 019
    Points
    34 019
    Par défaut
    En ligne de commande :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    apt-get install flashplugin-nonfree
    Ma page sur developpez.com : http://chrtophe.developpez.com/ (avec mes articles)
    Mon article sur le P2V, mon article sur le cloud
    Consultez nos FAQ : Windows, Linux, Virtualisation

  3. #3
    Membre du Club
    Homme Profil pro
    Inscrit en
    février 2012
    Messages
    136
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : février 2012
    Messages : 136
    Points : 47
    Points
    47
    Par défaut
    Voici ce que cela me donne ci-dessous:

    enzomorin@enzomorin:~$ sudo su
    [sudo] Mot de passe de enzomorin*:*
    root@enzomorin:/home/enzomorin# apt-get install flashplugin-nonfree
    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances
    Lecture des informations d'état... Fait
    Aucune version du paquet flashplugin-nonfree n'est disponible, mais il existe dans la base
    de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
    ou qu'il n'est disponible que sur une autre source

    E: Le paquet «*flashplugin-nonfree*» n'a pas de version susceptible d'être installée
    root@enzomorin:/home/enzomorin#

  4. #4
    Responsable Systèmes


    Homme Profil pro
    Technicien maintenance
    Inscrit en
    août 2011
    Messages
    14 683
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Technicien maintenance
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : août 2011
    Messages : 14 683
    Points : 34 019
    Points
    34 019
    Par défaut
    Quel navigateur utilises tu ?

    Essayes Chrome, il intègre Flash.
    Ma page sur developpez.com : http://chrtophe.developpez.com/ (avec mes articles)
    Mon article sur le P2V, mon article sur le cloud
    Consultez nos FAQ : Windows, Linux, Virtualisation

  5. #5
    Membre du Club
    Homme Profil pro
    Inscrit en
    février 2012
    Messages
    136
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : février 2012
    Messages : 136
    Points : 47
    Points
    47
    Par défaut Problème installation Adobe flash player sur debian
    Je pense que ce n'est pas possible.
    Apparemment cela exige un système de 64 bits et moi il ne fait que 32 bits.

  6. #6
    Membre du Club
    Homme Profil pro
    Inscrit en
    février 2012
    Messages
    136
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : février 2012
    Messages : 136
    Points : 47
    Points
    47
    Par défaut
    Sinon, j'ai Firefox actuellement comme navigateur

  7. #7
    Invité
    Invité(e)
    Par défaut


    Qu'indique la commande suivante :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    # apt-cache policy chromium
    J'avais un ordi en 32b, et chromium fonctionnait très bien dessus, puisqu'il est dans les 2 versions

    A bientôt

  8. #8
    Membre du Club
    Homme Profil pro
    Inscrit en
    février 2012
    Messages
    136
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : février 2012
    Messages : 136
    Points : 47
    Points
    47
    Par défaut
    enzomorin@enzomorin:~$ sudo su
    [sudo] Mot de passe de enzomorin*:*
    root@enzomorin:/home/enzomorin# apt-cache policy chromium
    chromium:
    Installé*: (aucun)
    Candidat*: 63.0.3239.84-1~deb9u1
    Table de version*:
    63.0.3239.84-1~deb9u1 500
    500 http://security.debian.org/debian-security stretch/updates/main i386 Packages
    62.0.3202.89-1~deb9u1 500
    500 http://ftp.fr.debian.org/debian stretch/main i386 Packages
    root@enzomorin:/home/enzomorin# ^C
    root@enzomorin:/home/enzomorin# ^C
    root@enzomorin:/home/enzomorin#

  9. #9
    Invité
    Invité(e)
    Par défaut

    Tu vois qu'il est disponible pour ta version
    il ne te reste plus qu'à :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    apt-get install chromium chromium-l10n
    et zou...
    Tu auras chromium à dispo, et comme l'a bien expliqué Christophe, il intègre flash

  10. #10
    Membre du Club
    Homme Profil pro
    Inscrit en
    février 2012
    Messages
    136
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : février 2012
    Messages : 136
    Points : 47
    Points
    47
    Par défaut
    Pas sure que l'opération soit bien exécutée:


    enzomorin@enzomorin:~$ sudo su
    [sudo] Mot de passe de enzomorin*:*
    root@enzomorin:/home/enzomorin# apt-get install chromium chromium-l10n
    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances
    Lecture des informations d'état... Fait
    The following additional packages will be installed:
    libminizip1 libre2-3
    Paquets suggérés*:
    chromium-shell chromium-driver chromium-widevine
    Les NOUVEAUX paquets suivants seront installés*:
    chromium chromium-l10n libminizip1 libre2-3
    0 mis à jour, 4 nouvellement installés, 0 à enlever et 0 non mis à jour.
    Il est nécessaire de prendre 52,6 Mo dans les archives.
    Après cette opération, 211 Mo d'espace disque supplémentaires seront utilisés.
    Souhaitez-vous continuer ? [O/n] O
    Err:1 http://security.debian.org/debian-security stretch/updates/main i386 chromium i386 63.0.3239.84-1~deb9u1
    404 Not Found [IP*: 2a04:4e42:3::204 80]
    Réception de:2 http://security.debian.org/debian-security stretch/updates/main i386 chromium-l10n all 63.0.3239.84-1~deb9u1 [2 769 kB]
    Réception de:3 http://ftp.fr.debian.org/debian stretch/main i386 libminizip1 i386 1.1-8+b1 [24,3 kB]
    Réception de:4 http://ftp.fr.debian.org/debian stretch/main i386 libre2-3 i386 20170101+dfsg-1 [187 kB]
    2 981 ko réceptionnés en 2s (1 278 ko/s)
    E: Impossible de récupérer http://security.debian.org/debian-se...eb9u1_i386.deb 404 Not Found [IP*: 2a04:4e42:3::204 80]
    E: Impossible de récupérer certaines archives, peut-être devrez-vous lancer apt-get update ou essayer avec --fix-missing*?
    root@enzomorin:/home/enzomorin#

  11. #11
    Responsable 2D/3D/Jeux


    Avatar de LittleWhite
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    mai 2008
    Messages
    25 942
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Ingénieur développement logiciels

    Informations forums :
    Inscription : mai 2008
    Messages : 25 942
    Points : 207 544
    Points
    207 544
    Billets dans le blog
    85
    Par défaut
    Bonjour,

    Je pense qu'il faille faire un :
    Pour mettre à jour la liste des logiciels/paquets disponibles.

    Ensuite, je conseillerai de faire les mises à jour :
    De là, vous pourrez installer tranquillement chromium.
    Pour installer le premier paquet indiqué dans la discussion (soit "flashplugin-nonfree"), il faut ajouter "non-free" dans les options des sources des paquets (dans le fichier /var/apt/sources.list ajouter non-free après main pour chaque URL inscrite dans le fichier).

    Aussi, toutes ces opérations sont possibles avec le gestionnaire de paquets graphique (synaptic ou autre).
    Vous souhaitez participer à la rubrique 2D/3D/Jeux ? Contactez-moi

    Ma page sur DVP
    Mon Portfolio

    Qui connaît l'erreur, connaît la solution.

  12. #12
    Membre du Club
    Homme Profil pro
    Inscrit en
    février 2012
    Messages
    136
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : février 2012
    Messages : 136
    Points : 47
    Points
    47
    Par défaut
    J'ai fait: apt-get update, puis apt-get upgrade et apt-get install chromium chromium-l10n
    Après pour l'opération ajouter non-free après main pour chaque URL dans /var/apt/sources.list, là je suis un peu perdu et je ne sais pas trop où aller et comment faire cette manipulation;



    enzomorin@enzomorin:~$ sudo su
    [sudo] Mot de passe de enzomorin*:*
    root@enzomorin:/home/enzomorin# apt-get install flashplugin-nonfree
    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances
    Lecture des informations d'état... Fait
    Aucune version du paquet flashplugin-nonfree n'est disponible, mais il existe dans la base
    de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
    ou qu'il n'est disponible que sur une autre source

    E: Le paquet «*flashplugin-nonfree*» n'a pas de version susceptible d'être installée
    root@enzomorin:/home/enzomorin# apt-get install chromium chromium-l10n
    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances
    Lecture des informations d'état... Fait
    The following additional packages will be installed:
    libminizip1 libre2-3
    Paquets suggérés*:
    chromium-shell chromium-driver chromium-widevine
    Les NOUVEAUX paquets suivants seront installés*:
    chromium chromium-l10n libminizip1 libre2-3
    0 mis à jour, 4 nouvellement installés, 0 à enlever et 1 non mis à jour.
    Il est nécessaire de prendre 50,2 Mo/50,4 Mo dans les archives.
    Après cette opération, 189 Mo d'espace disque supplémentaires seront utilisés.
    Souhaitez-vous continuer ? [O/n] O
    Réception de:1 http://security.debian.org/debian-security stretch/updates/main i386 chromium i386 64.0.3282.119-1~deb9u1 [47,4 MB]
    Réception de:2 http://security.debian.org/debian-security stretch/updates/main i386 chromium-l10n all 64.0.3282.119-1~deb9u1 [2 756 kB]
    50,2 Mo réceptionnés en 51s (979 ko/s)
    Sélection du paquet libminizip1:i386 précédemment désélectionné.
    (Lecture de la base de données... 95656 fichiers et répertoires déjà installés.)
    Préparation du dépaquetage de .../libminizip1_1.1-8+b1_i386.deb ...
    Dépaquetage de libminizip1:i386 (1.1-8+b1) ...
    Sélection du paquet libre2-3:i386 précédemment désélectionné.
    Préparation du dépaquetage de .../libre2-3_20170101+dfsg-1_i386.deb ...
    Dépaquetage de libre2-3:i386 (20170101+dfsg-1) ...
    Sélection du paquet chromium précédemment désélectionné.
    Préparation du dépaquetage de .../chromium_64.0.3282.119-1~deb9u1_i386.deb ...
    Dépaquetage de chromium (64.0.3282.119-1~deb9u1) ...
    Sélection du paquet chromium-l10n précédemment désélectionné.
    Préparation du dépaquetage de .../chromium-l10n_64.0.3282.119-1~deb9u1_all.deb ...
    Dépaquetage de chromium-l10n (64.0.3282.119-1~deb9u1) ...
    Paramétrage de libminizip1:i386 (1.1-8+b1) ...
    Traitement des actions différées («*triggers*») pour mime-support (3.60)*...
    Traitement des actions différées («*triggers*») pour desktop-file-utils (0.23-1)*...
    Paramétrage de libre2-3:i386 (20170101+dfsg-1) ...
    Traitement des actions différées («*triggers*») pour libc-bin (2.24-11+deb9u1)*...
    Paramétrage de chromium (64.0.3282.119-1~deb9u1) ...
    Traitement des actions différées («*triggers*») pour man-db (2.7.6.1-2)*...
    Traitement des actions différées («*triggers*») pour hicolor-icon-theme (0.15-1)*...
    Paramétrage de chromium-l10n (64.0.3282.119-1~deb9u1) ...
    root@enzomorin:/home/enzomorin#

  13. #13
    Invité
    Invité(e)
    Par défaut

    Pour ajouter ou retirer des "options", indiques nous :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    cat /etc/apt/sources.list
    cat, te permet de lire le sourceslist, sans aucun danger

    pour le modifier, perso, j'utilise nano, qui est "simple"... et relativement intuitif

    mais, dans un premier temps, listes le sources.list , ça va aider ce qui pourront t'aider

  14. #14
    Invité
    Invité(e)
    Par défaut
    Au fait, as-tu réussi à ouvrir chromium ?

  15. #15
    Membre du Club
    Homme Profil pro
    Inscrit en
    février 2012
    Messages
    136
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : février 2012
    Messages : 136
    Points : 47
    Points
    47
    Par défaut
    C'est fait ci dessous.
    Oui, j'ai bien un chromium dans ma liste d'applications. Lorsque je clique dessus, cela me propose d'ouvrir une session en me connectant avec mon compte google pour synchroniser les mots de passe et historiques. Par contre, je n'ai pas encore ouvert de session chromium et le navigateur s'ouvre toujours par défaut avec firefox.


    enzomorin@enzomorin:~$ sudo su
    [sudo] Mot de passe de enzomorin*:*
    root@enzomorin:/home/enzomorin# cat /etc/apt/sources.list
    #

    # deb cdrom:[Debian GNU/Linux 9.3.0 _Stretch_ - Official i386 NETINST 20171209-13:03]/ stretch main

    #deb cdrom:[Debian GNU/Linux 9.3.0 _Stretch_ - Official i386 NETINST 20171209-13:03]/ stretch main

    deb http://ftp.fr.debian.org/debian/ stretch main
    deb-src http://ftp.fr.debian.org/debian/ stretch main

    deb http://security.debian.org/debian-security stretch/updates main
    deb-src http://security.debian.org/debian-security stretch/updates main

    # stretch-updates, previously known as 'volatile'
    deb http://ftp.fr.debian.org/debian/ stretch-updates main
    deb-src http://ftp.fr.debian.org/debian/ stretch-updates main
    root@enzomorin:/home/enzomorin#

  16. #16
    Invité
    Invité(e)
    Par défaut
    Citation Envoyé par boubas53 Voir le message
    C'est fait ci dessous.
    Oui, j'ai bien un chromium dans ma liste d'applications. Lorsque je clique dessus, cela me propose d'ouvrir une session en me connectant avec mon compte google pour synchroniser les mots de passe et historiques. Par contre, je n'ai pas encore ouvert de session chromium et le navigateur s'ouvre toujours par défaut avec firefox.
    Normal, il faudra choisir celui que tu souhaites mettre par défaut !



    Citation Envoyé par boubas53 Voir le message
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    enzomorin@enzomorin:~$ sudo su
    [sudo] Mot de passe de enzomorin*:*
    root@enzomorin:/home/enzomorin# cat /etc/apt/sources.list
    # 
     
    # deb cdrom:[Debian GNU/Linux 9.3.0 _Stretch_ - Official i386 NETINST 20171209-13:03]/ stretch main
     
    #deb cdrom:[Debian GNU/Linux 9.3.0 _Stretch_ - Official i386 NETINST 20171209-13:03]/ stretch main
     
    deb <a href="http://ftp.fr.debian.org/debian/" target="_blank">http://ftp.fr.debian.org/debian/</a> stretch main
    deb-src <a href="http://ftp.fr.debian.org/debian/" target="_blank">http://ftp.fr.debian.org/debian/</a> stretch main
     
    deb <a href="http://security.debian.org/debian-security" target="_blank">http://security.debian.org/debian-security</a> stretch/updates main
    deb-src <a href="http://security.debian.org/debian-security" target="_blank">http://security.debian.org/debian-security</a> stretch/updates main
     
    # stretch-updates, previously known as 'volatile'
    deb <a href="http://ftp.fr.debian.org/debian/" target="_blank">http://ftp.fr.debian.org/debian/</a> stretch-updates main
    deb-src <a href="http://ftp.fr.debian.org/debian/" target="_blank">http://ftp.fr.debian.org/debian/</a> stretch-updates main
    root@enzomorin:/home/enzomorin#
    Pour t'aider à modifier le fichier sources.list, voici de quoi t'aider :
    https://wiki.debian.org/fr/SourcesList

    j'ai mis ton texte avec les balises code, pour plus de lisibilité

    je méconnais l'ordi tel que le tien, aussi, j'éviterai de t'indiquer l'ajout de telle source, plutôt qu'une autre...


    je suis sous Stretch, et j'utilise des programmes qui ont besoin de wine... et cela a été un poil galère pour le faire fonctionner... avec un mélange de 32 et 64bits...

  17. #17
    Responsable 2D/3D/Jeux


    Avatar de LittleWhite
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    mai 2008
    Messages
    25 942
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Ingénieur développement logiciels

    Informations forums :
    Inscription : mai 2008
    Messages : 25 942
    Points : 207 544
    Points
    207 544
    Billets dans le blog
    85
    Par défaut
    Note : si vous avez installé Chromium, pas besoin de vous embêter avec le sources.list. J'essayais de donner une réponse complète, pour tous les soucis rencontrées au cours de la discussion.
    De plus, j'ai indiqué l'existence d'outils graphiques, que je vous conseille .
    Vous souhaitez participer à la rubrique 2D/3D/Jeux ? Contactez-moi

    Ma page sur DVP
    Mon Portfolio

    Qui connaît l'erreur, connaît la solution.

  18. #18
    Expert éminent sénior Avatar de Flodelarab
    Homme Profil pro
    Inscrit en
    septembre 2005
    Messages
    4 798
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Charente (Poitou Charente)

    Informations forums :
    Inscription : septembre 2005
    Messages : 4 798
    Points : 12 056
    Points
    12 056
    Par défaut
    Bonjour

    Je vais faire hurler ceux qui détestent les logiciels propriétaires, mais pour Adobe Flash, il y a bien longtemps que je ne m'embête plus : je vais sur le site officiel, récupérer la version officielle et je l'installe moi-même.

    Ça évite ce genre de bourbier.
    Cette réponse vous apporte quelque chose ? Cliquez sur en bas à droite du message.

  19. #19
    Responsable Systèmes


    Homme Profil pro
    Technicien maintenance
    Inscrit en
    août 2011
    Messages
    14 683
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Technicien maintenance
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : août 2011
    Messages : 14 683
    Points : 34 019
    Points
    34 019
    Par défaut
    La solution chrome est plus simple, chrome intégrant flash.

    Je vais faire hurler ceux qui détestent les logiciels propriétaires
    Même si on déteste les logiciels propriétaires, Flash l’étant on a pas le choix, sinon de se passer des sites l'utilisant. Et le récupérer depuis leur site permettra d'avoir une version plus à jour que celle des dépôts non-free.
    Ma page sur developpez.com : http://chrtophe.developpez.com/ (avec mes articles)
    Mon article sur le P2V, mon article sur le cloud
    Consultez nos FAQ : Windows, Linux, Virtualisation

  20. #20
    Invité
    Invité(e)
    Par défaut

    Citation Envoyé par boubas53 Voir le message
    C'est fait ci dessous.
    Oui, j'ai bien un chromium dans ma liste d'applications. Lorsque je clique dessus, cela me propose d'ouvrir une session en me connectant avec mon compte google pour synchroniser les mots de passe et historiques. Par contre, je n'ai pas encore ouvert de session chromium et le navigateur s'ouvre toujours par défaut avec firefox.
    Alors, où en es-tu pour les jeux ?
    Réussi avec chrome ou chromium ?

Discussions similaires

  1. Adobe Flash Player sous linux Debian
    Par xfraisex dans le forum Linux
    Réponses: 3
    Dernier message: 13/09/2014, 10h11
  2. Debian, Ubuntu, Fedora, Freebsd : adobe flash player
    Par skyorion dans le forum Distributions
    Réponses: 12
    Dernier message: 24/06/2011, 17h52
  3. Comment utiliser 2 plugins pour Adobe Flash Player
    Par mihaispr dans le forum Flash/Flex
    Réponses: 4
    Dernier message: 13/03/2011, 21h57
  4. Probleme audio avec Adobe Flash Player
    Par maadadi dans le forum Audio
    Réponses: 5
    Dernier message: 07/11/2007, 23h54
  5. Problème avec le flash player
    Par danick dans le forum IE
    Réponses: 1
    Dernier message: 02/05/2007, 13h21

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo