Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

NetBeans Java Discussion :

La version stable d'Apache NetBeans 9.0 est disponible


Sujet :

NetBeans Java

  1. #21
    Membre expert
    Le grand retour de Netbeans, près de 2 ans (déjà...) après son transfert d'Oracle à Apache.

    Les projets qui vont chez Apache sont souvent des projets dont les meilleures années sont derrière eux et qui représentent plus le passé que l'avenir, comme OpenOffice et Subversion. Voir Netbeans les rejoindre n'était pas forcément de bon augure. Du coup qu'on fait les utilisateurs depuis la dernière màj il y a presque 2 ans ? Sont-ils restés fidèles ? A-t-on eu un exode plus ou moins massif de Netbeans vers Eclipse ou IntelliJ ? Il serait intéressant de le savoir.
    "Ils ne savaient pas que c'était impossible alors ils l'ont fait." Mark Twain

    Mon client Twitter Qt cross-platform Windows et Linux. (en cours de développement).

  2. #22
    Membre éclairé
    Citation Envoyé par air-dex Voir le message
    Le grand retour de Netbeans, près de 2 ans (déjà...) après son transfert d'Oracle à Apache.

    Les projets qui vont chez Apache sont souvent des projets dont les meilleures années sont derrière eux et qui représentent plus le passé que l'avenir, comme OpenOffice et Subversion. Voir Netbeans les rejoindre n'était pas forcément de bon augure. Du coup qu'on fait les utilisateurs depuis la dernière màj il y a presque 2 ans ? Sont-ils restés fidèles ? A-t-on eu un exode plus ou moins massif de Netbeans vers Eclipse ou IntelliJ ? Il serait intéressant de le savoir.
    Après Netbeans et OpenOffice (le reste je sais pas) le gros problème c'est moins d'aller chez apache mais surtout d'avoir été aquis par Oracle

  3. #23
    Membre éclairé
    il parle des plugins ici
    https://blogs.apache.org/netbeans/en...happened-to-my


    en somme en attendant....il mentionner comment installer ceux de la version 8.2

  4. #24
    Membre actif
    Juste pour info : il a fallu attendre presque un an pour que le code de base (qui est dans la version 9.0) soit effectivement donné et le code entreprise (PHP, Java EE, ...) vient d'être donné ce qui explique son absence.
    Le don de code n'est pas un processus simple hélas ...
    Après le support de Java 9, 10 et 11 est déjà proposé ce qui est loin d'être négligeable

  5. #25
    Membre habitué
    Très déçu par cette première version : pas de paquet .deb de disponible, on dézippe mais pas compatible openjdk-11 sous Ubuntu 18.04 sans décommenter "assistive_technologies", interface dégradé sous GTK+, pas de plugin PHP disponible sans revenir sur le catalogue 8.2, ...

  6. #26
    Membre actif
    openjdk-11 alors que la RC1 est sortie il y a à peine quelques jours ?

    PHP faisait partie de la 2eme donation donc il faut 'nettoyer' le code en question avant de le mettre dans le projet en cours.
    Apache ne fournit pas d'installateur mais la communauté en propose. Si le deb manque il pourrait être sympa de le proposer

  7. #27
    Membre à l'essai
    Citation Envoyé par ehsavoie Voir le message
    L'éditeur PHP comme la partie Java EE font partie du deuxième don de code de la part d'Oracle.
    Ce code n'a pas été intégré pour la version 9.0 (ce qui explique d'ailleurs l'absence des différents packages) et c'est en cours de discussion pour savoir comment récupérer tout cela (avec l'historique bien sûr).
    Effectivement, si on se réfère au Confluence (outil de collaboration d'Atlassian) de NetBeans le support de PHP 7.1, 7.2 voire 7.3 (et donc de PHP en général ?) sera pour NetBeans 10 https://cwiki.apache.org/confluence/...Feature%3A+PHP

  8. #28
    Membre du Club
    Apache Netbeans PHP
    Bonjour,

    la version PHP est prévu dans la release 10 apparemment:

    https://cwiki.apache.org/confluence/display/NETBEANS/Apache+NetBeans+10

  9. #29
    Membre régulier
    Netbeans 9.0 supporte php7.0 .
    La version netbeans 9.0 supporte php7.0. Pour cela, il faut:
    - installer netbeans 9.0 (y'a juste à dézipper).
    - suivre les instructions de ce lien Apache:
    https://blogs.apache.org/netbeans/entry/what-s-happened-to-my .

###raw>template_hook.ano_emploi###