1. #1
    Futur Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    avril 2016
    Messages
    4
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Belgique

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Services de proximité

    Informations forums :
    Inscription : avril 2016
    Messages : 4
    Points : 6
    Points
    6

    Par défaut CentOS - Yum ne trouve pas mes packages

    Bonjour,

    J'aimerais configurer un serveur Asterisk mais pour ça, je dois d'abord installer des dépendances.

    J'ai vérifier sur plusieurs sites et la commande à utiliser est

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    apt-get install build-essential libxml2-dev libncurses5-dev linux-headers-`uname -r` libsqlite3-dev libssl-dev
    J'ai donc tapé

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    yum install build-essential libxml2-dev libncurses5-dev linux-headers-`uname -r` libsqlite3-dev libssl-dev
    car je suis sur CentOS (je débute donc je raccompte peut-être des bêtises).

    Malheureusement, la commande me renvoie :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    Loaded plugins: fastestmirror, langpacks
    Loading mirror speeds from cached hostfile
     * base: be.mirror.guru
     * extras: fr.mirror.babylon.network
     * updates: be.mirror.guru
    No package build-essential available.
    No package libxml2-dev available.
    No package libncurses5-dev available.
    No package linux-headers-3.10.0-514.26.2.el7.x86_64 available.
    No package libsqlite3-dev available.
    No package libssl-dev available.
    Error: Nothing to do
    J'ai au prélable exécuté la commande

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    yum update && yum upgrade
    et j'ai réussi à installer d'autres packages avec yum.

    Toute aide est grandement appréciée!

  2. #2
    Futur Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    avril 2016
    Messages
    4
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Belgique

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Services de proximité

    Informations forums :
    Inscription : avril 2016
    Messages : 4
    Points : 6
    Points
    6

    Par défaut

    Résolu. Je pensais que je pouvais juste changer le apt-get en yum mais en fait non. Voici la commande que j'ai dénichée pour CentOS :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    sudo yum install -y epel-release dmidecode gcc-c++ ncurses-devel libxml2-devel make wget openssl-devel newt-devel kernel-devel sqlite-devel libuuid-devel gtk2-devel jansson-devel binutils-devel

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Réponses: 2
    Dernier message: 03/12/2007, 11h28
  2. Trouve pas mes classes sur le serveur de production
    Par batataw dans le forum Tomcat
    Réponses: 2
    Dernier message: 22/09/2007, 13h01
  3. Mon programme ne trouve pas le package jt400
    Par Greg.shogun dans le forum JDBC
    Réponses: 2
    Dernier message: 11/05/2007, 11h21
  4. Javac ne trouve pas mes autres packages
    Par bibx dans le forum ANT
    Réponses: 1
    Dernier message: 17/08/2006, 11h34
  5. [JNI] Java ne trouve pas mes méthodes natives
    Par carotte31 dans le forum APIs
    Réponses: 5
    Dernier message: 14/06/2006, 22h47

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo