1. #1
    Membre à l'essai
    Homme Profil pro
    Étudiant
    Inscrit en
    mai 2014
    Messages
    24
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Industrie

    Informations forums :
    Inscription : mai 2014
    Messages : 24
    Points : 20
    Points
    20

    Par défaut Problème avec Send_arp et Gratuitous ARP

    Bonjour,

    Je me suis aperçu d'un problème concernant le send_arp lors d'un bascule de cluster d'un nœud à l'autre, je m'explique.

    Mon setup :

    OS : Redhat 7.4

    Applications :
    • Pacemaker 1.1.16
    • resource-agents 3.9.5
    • corosync 2.4.0


    Je dispose d'un cluster pacemaker avec des VIP, à chaque bascule le script /usr/lib/ocf/resource.d/heartbeat/IPaddr prévoit d'envoyer des Gratuitous ARP en se basant sur /usr/libexec/heartbeat/send_arp afin d'annoncer au switch le changement d'adresse MAC liée à la VIP.

    Au moment de ma bascule je constate dans /var/log/message que le commande suivante est envoyée :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    Feb  9 10:50:19 [localhost] IPaddr2-centreon(vip_centreon)[692]: INFO: /usr/libexec/heartbeat/send_arp -i 200 -r 5 -p /var/run/resource-agents/send_arp-10.10.20.10 eth0 10.10.20.10 auto not_used not_used
    (10.10.20.10 étant l'adresse de ma VIP)

    Sauf que quand j’exécute cette commande manuellement j'ai le message suivant :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    [root@machine_backup run]# /usr/libexec/heartbeat/send_arp -i 200 -r 5 -p /var/run/resource-agents/send_arp-10.10.20.10 eth0 10.10.20.10 auto not_used not_used
    /usr/libexec/heartbeat/send_arp: invalid option -- 'r'
    Usage: send_arp [-fqbDUAV] [-c count] [-w timeout] [-I device] [-s source] destination
      -f : quit on first reply (not available in libnet version)
      -q : be quiet (not available in libnet version)
      -b : keep broadcasting, don't go unicast (not available in libnet version)
      -i : repeat interval in milliseconds (ignored)
      -p : pid file (ignored)
      -D : duplicate address detection mode (not available in libnet version)
      -U : Unsolicited ARP mode, update your neighbours (not available in libnet version)
      -A : ARP answer mode, update your neighbours (not available in libnet version)
      -V : print version and exit (not available in libnet version)
      -c count : how many packets to send
      -w timeout : how long to wait for a reply (not available in libnet version)
      -I device : which ethernet device to use (eth0)
      -s source : source ip address (not available in libnet version)
      -m mac : source MAC address (ignored).
      destination : ask for what ip address
    L'argument n'est pas correcte me direz-vous. Mais sur d'autres cluster que j'ai fais dans le passé je n'ai pas cette erreur avec la commande similaire. La commande send_arp fonctionne sur les versions d'OS/application suivantes :

    OS : Redhat 6.9

    Applications :
    • Pacemaker 1.1.12
    • resource-agents 3.9.5
    • corosync 1.4.7


    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    [root@autre_cluster]# /usr/libexec/heartbeat/send_arp -i 200 -r 5 -p /var/run/resource-agents/send_arp-10.10.20.11 eth3 10.10.20.11 auto not_used not_used
    ARPING 10.10.20.11 from 10.10.20.11 eth3
    Sent 5 probes (5 broadcast(s))
    Received 0 response(s)

    Voilà, je ne comprends absolument pas le problème donc si quelqu'un a une idée je l'en remercie grandement !

    John

  2. #2
    Membre à l'essai
    Homme Profil pro
    Étudiant
    Inscrit en
    mai 2014
    Messages
    24
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Industrie

    Informations forums :
    Inscription : mai 2014
    Messages : 24
    Points : 20
    Points
    20

    Par défaut

    Petit UP, une idée ?

Discussions similaires

  1. VC++ Direct3D8, problème avec LPD3DXFONT et LPD3DTEXTURE8
    Par Magus (Dave) dans le forum DirectX
    Réponses: 3
    Dernier message: 03/08/2002, 12h10
  2. Problème avec [b]struct[/b]
    Par Bouziane Abderraouf dans le forum CORBA
    Réponses: 2
    Dernier message: 17/07/2002, 11h25
  3. Problème avec le type 'Corba::Any_out'
    Par Steven dans le forum CORBA
    Réponses: 2
    Dernier message: 14/07/2002, 19h48
  4. Problème avec la mémoire virtuelle
    Par Anonymous dans le forum CORBA
    Réponses: 13
    Dernier message: 16/04/2002, 17h10

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo