1. #1
    Membre à l'essai
    Homme Profil pro
    Étudiant
    Inscrit en
    mars 2015
    Messages
    29
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 23
    Localisation : Cameroun

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : mars 2015
    Messages : 29
    Points : 15
    Points
    15

    Par défaut Problème avec le lancement de Tomcat sous Eclipse

    Bonjour à tous. J'aurais besoin de l'aide du forum. Quand je veux lancer le serveur Tomcat sous Eclipse, je reçois l'erreur suivante (voir image)

    Nom : Capture.JPG
Affichages : 92
Taille : 26,8 Ko


    J'ai essayé d'augmenter le "timeout", mais cela n'a rien changé. Voici ce que j'ai dans la console d'Eclipse quand je lance le serveur Tomcat :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    47
    48
    49
    50
    51
    52
    53
    54
    55
    56
    57
    58
    59
    60
    61
    62
    63
    64
    65
    66
    67
    68
    69
    70
    71
    72
    73
    74
    75
    76
    77
    78
    79
    80
    81
    82
    83
    84
    85
    86
    87
    88
    89
    90
    91
    92
    93
    94
    95
    96
    97
    98
    99
    100
    101
    102
    103
    104
    105
    106
    107
    108
    109
    110
    111
    112
    113
    114
    115
    116
    117
    118
    119
    120
    121
    122
    123
    124
    125
    126
    127
    128
    129
    130
    131
    132
    133
    134
     
    févr. 03, 2018 2:02:37 PM org.apache.tomcat.util.digester.SetPropertiesRule begin
    AVERTISSEMENT: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'source' to 'org.eclipse.jst.jee.server:test' did not find a matching property.
    févr. 03, 2018 2:02:37 PM org.apache.catalina.startup.VersionLoggerListener log
    INFOS: Server version:        Apache Tomcat/9.0.4
    févr. 03, 2018 2:02:37 PM org.apache.catalina.startup.VersionLoggerListener log
    INFOS: Server built:          Jan 18 2018 19:42:17 UTC
    févr. 03, 2018 2:02:37 PM org.apache.catalina.startup.VersionLoggerListener log
    INFOS: Server number:         9.0.4.0
    févr. 03, 2018 2:02:37 PM org.apache.catalina.startup.VersionLoggerListener log
    INFOS: OS Name:               Windows 7
    févr. 03, 2018 2:02:37 PM org.apache.catalina.startup.VersionLoggerListener log
    INFOS: OS Version:            6.1
    févr. 03, 2018 2:02:37 PM org.apache.catalina.startup.VersionLoggerListener log
    INFOS: Architecture:          amd64
    févr. 03, 2018 2:02:37 PM org.apache.catalina.startup.VersionLoggerListener log
    INFOS: Java Home:             C:\Program Files\Java\jre1.8.0_162
    févr. 03, 2018 2:02:37 PM org.apache.catalina.startup.VersionLoggerListener log
    INFOS: JVM Version:           1.8.0_162-b12
    févr. 03, 2018 2:02:37 PM org.apache.catalina.startup.VersionLoggerListener log
    INFOS: JVM Vendor:            Oracle Corporation
    févr. 03, 2018 2:02:37 PM org.apache.catalina.startup.VersionLoggerListener log
    INFOS: CATALINA_BASE:         C:\Users\user\eclipse-workspace\.metadata\.plugins\org.eclipse.wst.server.core\tmp0
    févr. 03, 2018 2:02:37 PM org.apache.catalina.startup.VersionLoggerListener log
    INFOS: CATALINA_HOME:         C:\tomcat9\apache-tomcat-9.0.4
    févr. 03, 2018 2:02:37 PM org.apache.catalina.startup.VersionLoggerListener log
    INFOS: Command line argument: -Dcatalina.base=C:\Users\user\eclipse-workspace\.metadata\.plugins\org.eclipse.wst.server.core\tmp0
    févr. 03, 2018 2:02:37 PM org.apache.catalina.startup.VersionLoggerListener log
    INFOS: Command line argument: -Dcatalina.home=C:\tomcat9\apache-tomcat-9.0.4
    févr. 03, 2018 2:02:37 PM org.apache.catalina.startup.VersionLoggerListener log
    INFOS: Command line argument: -Dwtp.deploy=C:\Users\user\eclipse-workspace\.metadata\.plugins\org.eclipse.wst.server.core\tmp0\wtpwebapps
    févr. 03, 2018 2:02:37 PM org.apache.catalina.startup.VersionLoggerListener log
    INFOS: Command line argument: -Djava.endorsed.dirs=C:\tomcat9\apache-tomcat-9.0.4\endorsed
    févr. 03, 2018 2:02:37 PM org.apache.catalina.startup.VersionLoggerListener log
    INFOS: Command line argument: -Dfile.encoding=Cp1252
    févr. 03, 2018 2:02:37 PM org.apache.catalina.core.AprLifecycleListener lifecycleEvent
    INFOS: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: [C:\Program Files\Java\jre1.8.0_162\bin;C:\Windows\Sun\Java\bin;C:\Windows\system32;C:\Windows;C:/Program Files/Java/jre1.8.0_162/bin/server;C:/Program Files/Java/jre1.8.0_162/bin;C:/Program Files/Java/jre1.8.0_162/lib/amd64;C:\ProgramData\Oracle\Java\javapath;C:\texlive\2015\bin\win32;F:\app\user\product\11.2.0\dbhome_1\bin;C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\Intel\iCLS Client\;C:\Program Files\Intel\iCLS Client\;C:\PROGRAM FILES\DELL\DW WLAN CARD;C:\Windows\SYSTEM32;C:\Windows;C:\Windows\SYSTEM32\WBEM;C:\Windows\SYSTEM32\WINDOWSPOWERSHELL\V1.0\;C:\PROGRAM FILES (X86)\ATI TECHNOLOGIES\ATI.ACE\CORE-STATIC;c:\Program Files\WIDCOMM\Bluetooth Software\;c:\Program Files\WIDCOMM\Bluetooth Software\syswow64;C:\Program Files (x86)\Intel\OpenCL SDK\2.0\bin\x86;C:\Program Files (x86)\Intel\OpenCL SDK\2.0\bin\x64;C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;F:\app\user\product\11.2.0\dbhome_1\BIN;C:\Program Files\MiKTeX 2.9\miktex\bin\x64\;C:\wamp;C:\Program Files\MATLAB\R2010b\runtime\win64;C:\Program Files\MATLAB\R2010b\bin;C:\Program Files (x86)\Skype\Phone\;C:\Program Files\Java\jdk-9.0.4\bin;C:\Users\user\AppData\Roaming\Dashlane\4.6.5.21982\bin\Firefox_Extension\{442718d9-475e-452a-b3e1-fb1ee16b8e9f}\components;C:\eclipse;;.]
    févr. 03, 2018 2:02:37 PM org.apache.coyote.AbstractProtocol init
    INFOS: Initializing ProtocolHandler ["http-nio-8080"]
    févr. 03, 2018 2:02:59 PM org.apache.catalina.util.LifecycleBase handleSubClassException
    GRAVE: Failed to initialize component [Connector[HTTP/1.1-8080]]
    org.apache.catalina.LifecycleException: L''initialisation du gestionnaire de protocole a échoué
    	at org.apache.catalina.connector.Connector.initInternal(Connector.java:935)
    	at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:136)
    	at org.apache.catalina.core.StandardService.initInternal(StandardService.java:530)
    	at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:136)
    	at org.apache.catalina.core.StandardServer.initInternal(StandardServer.java:852)
    	at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:136)
    	at org.apache.catalina.startup.Catalina.load(Catalina.java:622)
    	at org.apache.catalina.startup.Catalina.load(Catalina.java:645)
    	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    	at java.lang.reflect.Method.invoke(Unknown Source)
    	at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:309)
    	at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:492)
    Caused by: java.io.IOException: Unable to establish loopback connection
    	at sun.nio.ch.PipeImpl$Initializer.run(Unknown Source)
    	at sun.nio.ch.PipeImpl$Initializer.run(Unknown Source)
    	at java.security.AccessController.doPrivileged(Native Method)
    	at sun.nio.ch.PipeImpl.<init>(Unknown Source)
    	at sun.nio.ch.SelectorProviderImpl.openPipe(Unknown Source)
    	at java.nio.channels.Pipe.open(Unknown Source)
    	at sun.nio.ch.WindowsSelectorImpl.<init>(Unknown Source)
    	at sun.nio.ch.WindowsSelectorProvider.openSelector(Unknown Source)
    	at java.nio.channels.Selector.open(Unknown Source)
    	at org.apache.tomcat.util.net.NioSelectorPool.getSharedSelector(NioSelectorPool.java:66)
    	at org.apache.tomcat.util.net.NioSelectorPool.open(NioSelectorPool.java:130)
    	at org.apache.tomcat.util.net.NioEndpoint.bind(NioEndpoint.java:218)
    	at org.apache.tomcat.util.net.AbstractEndpoint.init(AbstractEndpoint.java:1043)
    	at org.apache.coyote.AbstractProtocol.init(AbstractProtocol.java:540)
    	at org.apache.coyote.http11.AbstractHttp11Protocol.init(AbstractHttp11Protocol.java:74)
    	at org.apache.catalina.connector.Connector.initInternal(Connector.java:932)
    	... 13 more
    Caused by: java.net.ConnectException: Connection timed out: connect
    	at sun.nio.ch.Net.connect0(Native Method)
    	at sun.nio.ch.Net.connect(Unknown Source)
    	at sun.nio.ch.Net.connect(Unknown Source)
    	at sun.nio.ch.SocketChannelImpl.connect(Unknown Source)
    	at java.nio.channels.SocketChannel.open(Unknown Source)
    	at sun.nio.ch.PipeImpl$Initializer$LoopbackConnector.run(Unknown Source)
    	... 29 more
     
    févr. 03, 2018 2:02:59 PM org.apache.coyote.AbstractProtocol init
    INFOS: Initializing ProtocolHandler ["ajp-nio-8009"]
    févr. 03, 2018 2:03:20 PM org.apache.catalina.util.LifecycleBase handleSubClassException
    GRAVE: Failed to initialize component [Connector[AJP/1.3-8009]]
    org.apache.catalina.LifecycleException: L''initialisation du gestionnaire de protocole a échoué
    	at org.apache.catalina.connector.Connector.initInternal(Connector.java:935)
    	at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:136)
    	at org.apache.catalina.core.StandardService.initInternal(StandardService.java:530)
    	at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:136)
    	at org.apache.catalina.core.StandardServer.initInternal(StandardServer.java:852)
    	at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:136)
    	at org.apache.catalina.startup.Catalina.load(Catalina.java:622)
    	at org.apache.catalina.startup.Catalina.load(Catalina.java:645)
    	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    	at java.lang.reflect.Method.invoke(Unknown Source)
    	at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:309)
    	at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:492)
    Caused by: java.io.IOException: Unable to establish loopback connection
    	at sun.nio.ch.PipeImpl$Initializer.run(Unknown Source)
    	at sun.nio.ch.PipeImpl$Initializer.run(Unknown Source)
    	at java.security.AccessController.doPrivileged(Native Method)
    	at sun.nio.ch.PipeImpl.<init>(Unknown Source)
    	at sun.nio.ch.SelectorProviderImpl.openPipe(Unknown Source)
    	at java.nio.channels.Pipe.open(Unknown Source)
    	at sun.nio.ch.WindowsSelectorImpl.<init>(Unknown Source)
    	at sun.nio.ch.WindowsSelectorProvider.openSelector(Unknown Source)
    	at java.nio.channels.Selector.open(Unknown Source)
    	at org.apache.tomcat.util.net.NioSelectorPool.getSharedSelector(NioSelectorPool.java:66)
    	at org.apache.tomcat.util.net.NioSelectorPool.open(NioSelectorPool.java:130)
    	at org.apache.tomcat.util.net.NioEndpoint.bind(NioEndpoint.java:218)
    	at org.apache.tomcat.util.net.AbstractEndpoint.init(AbstractEndpoint.java:1043)
    	at org.apache.coyote.AbstractProtocol.init(AbstractProtocol.java:540)
    	at org.apache.catalina.connector.Connector.initInternal(Connector.java:932)
    	... 13 more
    Caused by: java.net.ConnectException: Connection timed out: connect
    	at sun.nio.ch.Net.connect0(Native Method)
    	at sun.nio.ch.Net.connect(Unknown Source)
    	at sun.nio.ch.Net.connect(Unknown Source)
    	at sun.nio.ch.SocketChannelImpl.connect(Unknown Source)
    	at java.nio.channels.SocketChannel.open(Unknown Source)
    	at sun.nio.ch.PipeImpl$Initializer$LoopbackConnector.run(Unknown Source)
    	... 28 more
     
    févr. 03, 2018 2:03:20 PM org.apache.catalina.startup.Catalina load
    INFOS: Initialization processed in 43164 ms
    févr. 03, 2018 2:03:20 PM org.apache.catalina.core.StandardService startInternal
    INFOS: Démarrage du service [Catalina]
    févr. 03, 2018 2:03:20 PM org.apache.catalina.core.StandardEngine startInternal
    INFOS: Starting Servlet Engine: Apache Tomcat/9.0.4

    Voici la configuration que j'utilise : Windows 7 64 bits, Eclipse Oxygen 4.7.2 , tomcat 9, JDK 8 update 162.


    Merci d'avance pour votre aide.

  2. #2
    Membre émérite
    Avatar de Mickael_Istria
    Homme Profil pro
    Développeur Expert Eclipse IDE/RCP, pour Red Hat
    Inscrit en
    juillet 2008
    Messages
    1 177
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Isère (Rhône Alpes)

    Informations professionnelles :
    Activité : Développeur Expert Eclipse IDE/RCP, pour Red Hat
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : juillet 2008
    Messages : 1 177
    Points : 2 493
    Points
    2 493

    Par défaut

    Je ne pense pas que ce soit un probleme specifique a Eclipse IDE. Tu as essaye de demarrer ton Tomcat depuis la console en ligne de commande directement voir ce qu'il te dit?
    Tu fais du JEE/Web/Mobile dans Eclipse IDE? Essaye JBoss Tools !
    Follow me on twitter

  3. #3
    Membre à l'essai
    Homme Profil pro
    Étudiant
    Inscrit en
    mars 2015
    Messages
    29
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 23
    Localisation : Cameroun

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : mars 2015
    Messages : 29
    Points : 15
    Points
    15

    Par défaut

    Citation Envoyé par Mickael_Istria Voir le message
    Je ne pense pas que ce soit un probleme specifique a Eclipse IDE. Tu as essaye de demarrer ton Tomcat depuis la console en ligne de commande directement voir ce qu'il te dit?
    J'ai essayé et ça ne fonctionne pas. J'ai changé la version de Tomcat que j'utilise, j'ai pris la version 7.0, j'ai toujours le même message que sur l'image, et j'ai ceci dans la console d'Eclipse:

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    47
    48
    49
    50
    51
    52
    53
    54
    55
    56
     
     
    févr. 05, 2018 3:40:26 PM org.apache.catalina.startup.VersionLoggerListener log
    INFOS: Server version:        Apache Tomcat/7.0.84
    févr. 05, 2018 3:40:26 PM org.apache.catalina.startup.VersionLoggerListener log
    INFOS: Server built:          Jan 19 2018 15:01:35 UTC
    févr. 05, 2018 3:40:26 PM org.apache.catalina.startup.VersionLoggerListener log
    INFOS: Server number:         7.0.84.0
    févr. 05, 2018 3:40:26 PM org.apache.catalina.startup.VersionLoggerListener log
    INFOS: OS Name:               Windows 7
    févr. 05, 2018 3:40:26 PM org.apache.catalina.startup.VersionLoggerListener log
    INFOS: OS Version:            6.1
    févr. 05, 2018 3:40:26 PM org.apache.catalina.startup.VersionLoggerListener log
    INFOS: Architecture:          amd64
    févr. 05, 2018 3:40:26 PM org.apache.catalina.startup.VersionLoggerListener log
    INFOS: Java Home:             C:\Program Files\Java\jre1.8.0_162
    févr. 05, 2018 3:40:26 PM org.apache.catalina.startup.VersionLoggerListener log
    INFOS: JVM Version:           1.8.0_162-b12
    févr. 05, 2018 3:40:26 PM org.apache.catalina.startup.VersionLoggerListener log
    INFOS: JVM Vendor:            Oracle Corporation
    févr. 05, 2018 3:40:26 PM org.apache.catalina.startup.VersionLoggerListener log
    INFOS: CATALINA_BASE:         C:\Users\user\eclipse-workspace\.metadata\.plugins\org.eclipse.wst.server.core\tmp0
    févr. 05, 2018 3:40:26 PM org.apache.catalina.startup.VersionLoggerListener log
    INFOS: CATALINA_HOME:         C:\Program Files\Apache Software Foundation\Tomcat 7.0_Tomcat7.0.84
    févr. 05, 2018 3:40:26 PM org.apache.catalina.startup.VersionLoggerListener log
    INFOS: Command line argument: -Dcatalina.base=C:\Users\user\eclipse-workspace\.metadata\.plugins\org.eclipse.wst.server.core\tmp0
    févr. 05, 2018 3:40:26 PM org.apache.catalina.startup.VersionLoggerListener log
    INFOS: Command line argument: -Dcatalina.home=C:\Program Files\Apache Software Foundation\Tomcat 7.0_Tomcat7.0.84
    févr. 05, 2018 3:40:26 PM org.apache.catalina.startup.VersionLoggerListener log
    INFOS: Command line argument: -Dwtp.deploy=C:\Users\user\eclipse-workspace\.metadata\.plugins\org.eclipse.wst.server.core\tmp0\wtpwebapps
    févr. 05, 2018 3:40:26 PM org.apache.catalina.startup.VersionLoggerListener log
    INFOS: Command line argument: -Djava.endorsed.dirs=C:\Program Files\Apache Software Foundation\Tomcat 7.0_Tomcat7.0.84\endorsed
    févr. 05, 2018 3:40:26 PM org.apache.catalina.startup.VersionLoggerListener log
    INFOS: Command line argument: -Dfile.encoding=Cp1252
    févr. 05, 2018 3:40:26 PM org.apache.catalina.core.AprLifecycleListener lifecycleEvent
    INFOS: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\Program Files\Java\jre1.8.0_162\bin;C:\Windows\Sun\Java\bin;C:\Windows\system32;C:\Windows;C:/Program Files/Java/jre1.8.0_162/bin/server;C:/Program Files/Java/jre1.8.0_162/bin;C:/Program Files/Java/jre1.8.0_162/lib/amd64;C:\ProgramData\Oracle\Java\javapath;C:\texlive\2015\bin\win32;F:\app\user\product\11.2.0\dbhome_1\bin;C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\Intel\iCLS Client\;C:\Program Files\Intel\iCLS Client\;C:\PROGRAM FILES\DELL\DW WLAN CARD;C:\Windows\SYSTEM32;C:\Windows;C:\Windows\SYSTEM32\WBEM;C:\Windows\SYSTEM32\WINDOWSPOWERSHELL\V1.0\;C:\PROGRAM FILES (X86)\ATI TECHNOLOGIES\ATI.ACE\CORE-STATIC;c:\Program Files\WIDCOMM\Bluetooth Software\;c:\Program Files\WIDCOMM\Bluetooth Software\syswow64;C:\Program Files (x86)\Intel\OpenCL SDK\2.0\bin\x86;C:\Program Files (x86)\Intel\OpenCL SDK\2.0\bin\x64;C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;F:\app\user\product\11.2.0\dbhome_1\BIN;C:\Program Files\MiKTeX 2.9\miktex\bin\x64\;C:\wamp;C:\Program Files\MATLAB\R2010b\runtime\win64;C:\Program Files\MATLAB\R2010b\bin;C:\Program Files (x86)\Skype\Phone\;C:\Program Files\Java\jdk-9.0.4\bin;C:\Users\user\AppData\Roaming\Dashlane\4.6.5.21982\bin\Firefox_Extension\{442718d9-475e-452a-b3e1-fb1ee16b8e9f}\components;C:\EclipseJEE\OxygenNoJEE\eclipse;;.
    févr. 05, 2018 3:40:26 PM org.apache.coyote.AbstractProtocol init
    INFOS: Initializing ProtocolHandler ["http-bio-8080"]
    févr. 05, 2018 3:40:26 PM org.apache.coyote.AbstractProtocol init
    INFOS: Initializing ProtocolHandler ["ajp-bio-8009"]
    févr. 05, 2018 3:40:26 PM org.apache.catalina.startup.Catalina load
    INFOS: Initialization processed in 973 ms
    févr. 05, 2018 3:40:26 PM org.apache.catalina.core.StandardService startInternal
    INFOS: Démarrage du service Catalina
    févr. 05, 2018 3:40:26 PM org.apache.catalina.core.StandardEngine startInternal
    INFOS: Starting Servlet Engine: Apache Tomcat/7.0.84
    févr. 05, 2018 3:40:29 PM org.apache.catalina.startup.TldConfig execute
    INFOS: At least one JAR was scanned for TLDs yet contained no TLDs. Enable debug logging for this logger for a complete list of JARs that were scanned but no TLDs were found in them. Skipping unneeded JARs during scanning can improve startup time and JSP compilation time.
    févr. 05, 2018 3:40:31 PM org.apache.catalina.util.SessionIdGeneratorBase createSecureRandom
    AVERTISSEMENT: Creation of SecureRandom instance for session ID generation using [SHA1PRNG] took [2*106] milliseconds.
    févr. 05, 2018 3:40:31 PM org.apache.coyote.AbstractProtocol start
    INFOS: Starting ProtocolHandler ["http-bio-8080"]
    févr. 05, 2018 3:40:31 PM org.apache.coyote.AbstractProtocol start
    INFOS: Starting ProtocolHandler ["ajp-bio-8009"]
    févr. 05, 2018 3:40:31 PM org.apache.catalina.startup.Catalina start
    INFOS: Server startup in 4942 ms

  4. #4
    Membre à l'essai
    Homme Profil pro
    Étudiant
    Inscrit en
    mars 2015
    Messages
    29
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 23
    Localisation : Cameroun

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : mars 2015
    Messages : 29
    Points : 15
    Points
    15

    Par défaut

    Personne pour m'aider s'il vous plait ?

  5. #5
    Rédacteur

    Avatar de millie
    Profil pro
    Inscrit en
    juin 2006
    Messages
    7 011
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2006
    Messages : 7 011
    Points : 9 677
    Points
    9 677

    Par défaut

    Tu as le soucis avec un tomcat à vide ou un tomcat avec déjà un war mis dessus ?
    Je ne répondrai à aucune question technique en privé

  6. #6
    Membre à l'essai
    Homme Profil pro
    Étudiant
    Inscrit en
    mars 2015
    Messages
    29
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 23
    Localisation : Cameroun

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : mars 2015
    Messages : 29
    Points : 15
    Points
    15

    Par défaut

    Citation Envoyé par millie Voir le message
    Tu as le soucis avec un tomcat à vide ou un tomcat avec déjà un war mis dessus ?

    Bonjour, désolé je n'ai pas très bien compris la question. Peux-tu être plus explicite s'il te plaît ?

  7. #7
    Membre régulier
    Homme Profil pro
    Expert Middleware
    Inscrit en
    septembre 2006
    Messages
    69
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Nord (Nord Pas de Calais)

    Informations professionnelles :
    Activité : Expert Middleware

    Informations forums :
    Inscription : septembre 2006
    Messages : 69
    Points : 97
    Points
    97

    Par défaut

    Salut,

    essaye en ajoutant ceci à ta ligne de démarrage ?

    -Djava.net.preferIPv4Stack=true

    Syberi@
    Quand on est mort, on ne sait pas qu’on est mort, c’est pour les autres que c’est difficile… Quand on est con, c’est pareil.

  8. #8
    Rédacteur

    Avatar de millie
    Profil pro
    Inscrit en
    juin 2006
    Messages
    7 011
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2006
    Messages : 7 011
    Points : 9 677
    Points
    9 677

    Par défaut

    Quand tu as installé ton Tomcat, tu n'as rien fait d'autres de particuliers ?
    Est-ce bien un Tomcat "vide" d'application web ?

    J'ai déjà eu ce cas il y a longtemps où le Tomcat hébergait une vieille application pas nettoyée, et le démarrage de toute l'instance ne se faisait pas dans les temps (<60sec) et j'avais eu une popup similaire.
    Je ne répondrai à aucune question technique en privé

Discussions similaires

  1. Problème avec Le serveur Tomcat sous Eclipse
    Par zipcode dans le forum Eclipse
    Réponses: 2
    Dernier message: 19/03/2016, 12h52
  2. Problème de lancement de Tomcat sous Eclipse
    Par <% Bastien %> dans le forum Tomcat
    Réponses: 1
    Dernier message: 14/04/2015, 10h44
  3. probléme avec tomcat sous eclipse (changement de workspace)
    Par rwikus09 dans le forum Servlets/JSP
    Réponses: 2
    Dernier message: 29/10/2010, 12h23
  4. Réponses: 1
    Dernier message: 17/02/2009, 11h05
  5. problem avec tomcat sous eclipse
    Par ricault dans le forum Eclipse Java
    Réponses: 1
    Dernier message: 05/06/2007, 16h25

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo