1. #1
    Candidat au Club
    Homme Profil pro
    Securité Matériel
    Inscrit en
    avril 2017
    Messages
    6
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 28
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : Securité Matériel

    Informations forums :
    Inscription : avril 2017
    Messages : 6
    Points : 3
    Points
    3

    Par défaut Migration projet Web Windows > Mac

    Bonjour,

    Je n'ai pas trouvé mon problème sur ce forum, alors je pose ce post.

    J'aimerai faire la connaissance d'un développeur qui développe en .net Core sur Mac, en effet j'ai un problème assez handicapant :

    Je viens de rebasculer sur Mac, et j'ai donc migrer mon projet Web que j'avais sur windows qui fonctionnait parfaitement. Seulement, impossible de le lancer en mode débug, Et je n'ai même pas de message d'erreur. La génération ce fait. Et puis safari ce lance avec en principe mon site en construction, et là s'affiche en gros comme quoi safari ne veut pas afficher la page "car elle n'a pas l'air sécurisé". Et ce avec tous les navigateurs.

    Du coup, je suis près à être dépanner (même si cela me coûte une prestation) avec une prise de main à distance et m'aider à résoudre, ou au moins à comprendre d'ou vient le problème.

    N'hésitez pas à me contacter ou me poser des questions.

  2. #2
    Candidat au Club
    Homme Profil pro
    Securité Matériel
    Inscrit en
    avril 2017
    Messages
    6
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 28
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : Securité Matériel

    Informations forums :
    Inscription : avril 2017
    Messages : 6
    Points : 3
    Points
    3

    Par défaut Première Piste : HTTPS

    Je viens d'enlever toutes la partie HTTPS et rewriting d'url et le problème est résolu.

    Reste à savoir pourquoi avec le HTTPS sa plante.

  3. #3
    Membre expérimenté

    Homme Profil pro
    Développeur multimédia
    Inscrit en
    juillet 2004
    Messages
    978
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur multimédia
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : juillet 2004
    Messages : 978
    Points : 1 708
    Points
    1 708
    Billets dans le blog
    1

    Par défaut

    Peut être que ton certificat SSL n'est plus valide (le domain, date de validité pour les gratuit a renouveler ex:let's encrypt ) ... peux être que tu dois régénérer les certificats. Consulte tes logs pour en savoir plus.

  4. #4
    Candidat au Club
    Homme Profil pro
    Securité Matériel
    Inscrit en
    avril 2017
    Messages
    6
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 28
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : Securité Matériel

    Informations forums :
    Inscription : avril 2017
    Messages : 6
    Points : 3
    Points
    3

    Par défaut

    Tu es également sur Mac ?

    J'ai l'impression que mes modifications ne sont pas forcément prise en compte.

  5. #5
    Membre expérimenté

    Homme Profil pro
    Développeur multimédia
    Inscrit en
    juillet 2004
    Messages
    978
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur multimédia
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : juillet 2004
    Messages : 978
    Points : 1 708
    Points
    1 708
    Billets dans le blog
    1

    Par défaut

    Non désolé @Eristoff47 je suis pas sous Mac mais linux Debian, peux être voir le Forum Mac pour la spécificité de ton environnement Serveur web, certificat SSL ...

  6. #6
    Candidat au Club
    Homme Profil pro
    Securité Matériel
    Inscrit en
    avril 2017
    Messages
    6
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 28
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : Securité Matériel

    Informations forums :
    Inscription : avril 2017
    Messages : 6
    Points : 3
    Points
    3

    Par défaut

    Je ne pense pas que cela change beaucoup. Les Macs sont quand même très proches des Noyaux Linux.

    Il faudrait que je trouve une personne qui utilise de la même façon que moi.

    Après si sa te tente de vouloir tester de dépanner, pourquoi pas.

  7. #7
    Candidat au Club
    Homme Profil pro
    Securité Matériel
    Inscrit en
    avril 2017
    Messages
    6
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 28
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : Securité Matériel

    Informations forums :
    Inscription : avril 2017
    Messages : 6
    Points : 3
    Points
    3

    Par défaut

    Voilà, j'ai résolu mon problème c'était bien un problème lié à HTTPS.

    Cela m'a au moins permis d'apprendre à créer un certificat sur Mac et j'imagine que c'est la même chose que pour Linux.

    Merci à headmax pour avoir tenter de me trouver une solution.

  8. #8
    Membre expérimenté

    Homme Profil pro
    Développeur multimédia
    Inscrit en
    juillet 2004
    Messages
    978
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur multimédia
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : juillet 2004
    Messages : 978
    Points : 1 708
    Points
    1 708
    Billets dans le blog
    1

    Par défaut

    Pas de problème, bonne continuation.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Développement web Windows ou Mac
    Par Khleo dans le forum Général Conception Web
    Réponses: 5
    Dernier message: 07/11/2009, 11h02
  2. Projet réalisé sous Mac puis transféré sous Windows XP
    Par loic20h28 dans le forum Eclipse Java
    Réponses: 6
    Dernier message: 23/03/2009, 19h03
  3. migration de web services vers windows forms
    Par diamentelle dans le forum Windows Forms
    Réponses: 0
    Dernier message: 18/03/2009, 01h28
  4. migration projet rails sur linux from windows
    Par horkets dans le forum Ruby on Rails
    Réponses: 15
    Dernier message: 14/02/2008, 14h44
  5. Authentification windows pour un projet web
    Par Korn_Muse dans le forum Développement Web en Java
    Réponses: 1
    Dernier message: 18/01/2007, 15h25

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo