Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Outils MySQL Discussion :

mysqldump : option inconnue


Sujet :

Outils MySQL

  1. #1
    Membre du Club
    Profil pro
    Inscrit en
    septembre 2007
    Messages
    77
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : septembre 2007
    Messages : 77
    Points : 53
    Points
    53
    Par défaut mysqldump : option inconnue
    Bonjour,
    J'ai changé de serveur pour GLPI.
    Sur l'ancien serveur, j'avais une sauvegarde quotidienne automatique avec sqldump.
    Sur le nouveau, cela ne fonctionne pas.

    Même en ligne de commande quand je tape :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    mysqldump -u root -motdepasse glpi test.bk
    J'ai :
    mysqldump: [ERROR] mysqldump: unknown option '-g'

    Seulement voilà il n'y a pas d'option g dans ma ligne de commande. J'ai essayé différentes syntaxes, mais toujours la même erreur !

    Auriez-vous une idée du problème !

    D'avance merci pour votre aide.

    Romain

  2. #2
    Membre confirmé Avatar de Sebwar
    Homme Profil pro
    Administrateur de base de données
    Inscrit en
    avril 2012
    Messages
    172
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 34
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Administrateur de base de données
    Secteur : High Tech - Produits et services télécom et Internet

    Informations forums :
    Inscription : avril 2012
    Messages : 172
    Points : 508
    Points
    508
    Par défaut
    hello,

    il manque un "p" devant le mot de passe :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    mysqldump -u root -pmotdepasse glpi test.bk

  3. #3
    Expert éminent sénior Avatar de Artemus24
    Homme Profil pro
    Agent secret au service du président Ulysses S. Grant !
    Inscrit en
    février 2011
    Messages
    4 310
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 80
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Agent secret au service du président Ulysses S. Grant !
    Secteur : Finance

    Informations forums :
    Inscription : février 2011
    Messages : 4 310
    Points : 12 626
    Points
    12 626
    Par défaut
    Salut à tous.

    Comme je suis un bavard invétéré, je préfère plutôt cette forme d'écriture :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    mysqldump --user=root  --password=motdepasse  --databases glpi  --result-file=test.bk  --verbose  --force
    On trouve tous les paramètres dans ce lien !

    @+
    Si vous êtes de mon aide, vous pouvez cliquer sur .
    Mon site : http://www.jcz.fr

  4. #4
    Membre du Club
    Profil pro
    Inscrit en
    septembre 2007
    Messages
    77
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : septembre 2007
    Messages : 77
    Points : 53
    Points
    53
    Par défaut
    Bonjour,
    Je vous remercie. Cela a débloqué un peu la situation avec le p devant. Maintenant j'ai cette erreur "MYSQL: Out of resources when opening file... (Errcode: 24)".
    J'ai trouvé des solutions sur le net, cela vient de la variable open_files_limit.
    Comme indiqué, j'ai essayé de lui mettre 5000 comme valeur en éditant le fichier /etc/my.cnf (qui n'existe pas chez moi c'est /etc/mysql/my.cnf)
    J'ai ajouté les lignes
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    [mysqld]
    open_files_limit = 5000
    Sans résultat
    En cherchant encore, j'ai trouvé le fichier :/etc/mysql/mysql.conf.d/mysqld.cnf qui contenait exactement les variables MySQL. J'ai ajouté la ligne "open_files_limit = 5000" sans résultats non plus. Après chaque modif j'ai bien redémarré MySQL et même le serveur dans le doute.

    Comment puis-je modifier cette variable ?

  5. #5
    Membre du Club
    Profil pro
    Inscrit en
    septembre 2007
    Messages
    77
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : septembre 2007
    Messages : 77
    Points : 53
    Points
    53
    Par défaut
    En fait le fichier à modifier était : /lib/systemd/system/mysqld.service

    J'y ai ajouté
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    LimitNOFILE=infinity
    LimitMEMLOCK=infinity
    Et là c'est bon mysqldump fonctionne !

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. OUTREC - Option inconnue
    Par Antichoc dans le forum Cobol
    Réponses: 4
    Dernier message: 30/09/2011, 00h10
  2. Option --delete-master-logs de mysqldump bloquante
    Par dychentrus dans le forum Administration
    Réponses: 1
    Dernier message: 07/08/2009, 10h24
  3. mysqldump : Option pour avoir un INSERT par enregistrement
    Par jaymzwise dans le forum Administration
    Réponses: 1
    Dernier message: 30/08/2007, 21h41
  4. Questions mysqldump et option --all-databases
    Par RR instinct dans le forum Outils
    Réponses: 9
    Dernier message: 03/08/2007, 17h20
  5. mysqldump unknown option
    Par lamachine_fr dans le forum Administration
    Réponses: 9
    Dernier message: 26/03/2007, 18h12

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo