1. #1
    Nouveau Candidat au Club
    Femme Profil pro
    Étudiant
    Inscrit en
    décembre 2017
    Messages
    1
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : décembre 2017
    Messages : 1
    Points : 1
    Points
    1

    Par défaut problème avec le résultat de proc REG et la fonction RANNOR?

    Bonjour tout le monde,
    J'ai un TD comme ci dessous. Après fonctionner le programme, j'ai le résultat suivant:
    Nom : Screenshot (5).png
Affichages : 35
Taille : 50,3 Ko

    Le problème ici est mon professeur m'a demandé de faire une autre étape. Il m'a donné un exemple de code avec les faux données.
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
     
    DATA MaTable ;
    DO _i = 1 TO 100 ;
    x = RANNOR(123) ;
    w = 2*x + 3 + RANNOR(123) ;
    homme = 1 ; femme = 0 ; x_homme = x * homme ; x_femme = x * femme ;
    OUTPUT ;
    w = 1.5*x + 2 + RANNOR(123) ;
    femme = 1 ; homme = 0 ; x_femme = x * femme ; x_homme = x * homme ;
    OUTPUT ;
    END ;
    RUN ;
    PROC reg DATA=MaTable ;
    where homme ;
    MODEL w = x ;
    RUN ;
    PROC reg DATA=MaTable ;
    where femme ;
    MODEL w = x ;
    RUN ;
    PROC reg DATA=MaTable ;
    MODEL w = x ;
    RUN ;
    PROC reg DATA=MaTable ;
    MODEL w = x_homme x_femme homme femme / NOINT ;
    RUN ;
    Mon travail est de trouver les bonnes données pour remplacer à la fonction. Mais je comprends pas du tout à quoi présenter l'équation w=2*x+3+RANNOR(123). Je dois remplacer quoi à la place de "2" et "3"? Et c'est quoi ces variables? Parameter estimates?

    Merci d'avance.
    Images attachées Images attachées

Discussions similaires

  1. [2008] Problème avec le résultat de mon cube
    Par DotNetMatt dans le forum SSAS
    Réponses: 11
    Dernier message: 31/03/2011, 14h18
  2. problème avec les résultats de la recherche
    Par senouss dans le forum PHP & MySQL
    Réponses: 2
    Dernier message: 21/12/2010, 18h17
  3. Réponses: 5
    Dernier message: 07/08/2008, 15h33
  4. problème avec les résultats d'une requête select top1
    Par kariiim dans le forum Requêtes et SQL.
    Réponses: 5
    Dernier message: 19/03/2007, 15h05
  5. [avifile] Problème avec des résultats étrange
    Par Jim_Nastiq dans le forum Dev-C++
    Réponses: 1
    Dernier message: 30/01/2007, 11h11

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo