1. #1
    Candidat au Club
    Homme Profil pro
    Technicien maintenance
    Inscrit en
    décembre 2017
    Messages
    6
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Burkina Faso

    Informations professionnelles :
    Activité : Technicien maintenance
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : décembre 2017
    Messages : 6
    Points : 2
    Points
    2

    Par défaut Raspberrypi3 - Renommer Addrese Hotspot wifi

    Salut. Je tourne en rond depuis un moment pour donner une adresse en lettres à mon site. je vous explique:
    J’héberge un site local sur ma Raspberry pi3 sous Jessy. J'ai alors créer un hot-spot wifi (sans internet) sur lequel en se connectant et en entrant le IP 192.168.10.1 on tombe sur mon site.
    Mon problème est alors de remplace le IP (192.168.10.1) en quelque chose comme "monsite" ou "monsite.local" ou tout autre chose qui ne soit pas une suite de chiffres.

    J'ai déjà essaye en vain la méthode "sudo nano etc/hosts" (en allignant le IP et le Nom que j'aimerais lui donner).

    Je tiens à précisé que:
    1) Le système (Site, diffusion wifi, absolument tout) marche très bien maintenant avec l'adresse 192.168.10.1
    2) Il n'y a pas de box dans mon système il n'y a que la (Raspberry) .
    3) Le principe est que tout appareil équipé d'un capteur wifi puisse se connecté au réseau diffuse par la Raspberry et qu'en tapant l'adresse du site dans leur navigateur atterrisse sur le site ébergé

    PS: Éléments installés:
    -hotspot
    -hostapd isc-dhcp-server iptables wpa_supplicant
    -serveur apache2 php5 mysql

    J'èspère trouver de l'aide auprès de vous.

  2. #2
    Modérateur

    Avatar de Bktero
    Homme Profil pro
    Ingénieur systèmes embarqués
    Inscrit en
    juin 2009
    Messages
    3 801
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 30
    Localisation : France, Loire Atlantique (Pays de la Loire)

    Informations professionnelles :
    Activité : Ingénieur systèmes embarqués

    Informations forums :
    Inscription : juin 2009
    Messages : 3 801
    Points : 10 217
    Points
    10 217
    Billets dans le blog
    1

    Par défaut

    Bonjour

    On peut voir ton fichier etc/hosts ?

    Naturellement, tu as rebooté ton Pi après la modification ?

  3. #3
    Candidat au Club
    Homme Profil pro
    Technicien maintenance
    Inscrit en
    décembre 2017
    Messages
    6
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Burkina Faso

    Informations professionnelles :
    Activité : Technicien maintenance
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : décembre 2017
    Messages : 6
    Points : 2
    Points
    2

    Par défaut

    Oui j'ai fait un redémarrage mais ça rien changer. Le contenu de /etc/hosts


    127.0.0.1 localhost
    ::1 localhost ip6-localhost ip6-loopback
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters

    127.0.1.1 raspberrypi

    Je précise que j'ai déjà essaye en vain la méthode "sudo nano etc/hosts" (en allignant le IP et le Nom que j'aimerais lui donner) comme ceci

    127.0.0.1 localhost
    ::1 localhost ip6-localhost ip6-loopback
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters

    127.0.1.1 raspberrypi
    192.168.10.1 case.local

    Même après redémarage

  4. #4
    Modérateur

    Avatar de Bktero
    Homme Profil pro
    Ingénieur systèmes embarqués
    Inscrit en
    juin 2009
    Messages
    3 801
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 30
    Localisation : France, Loire Atlantique (Pays de la Loire)

    Informations professionnelles :
    Activité : Ingénieur systèmes embarqués

    Informations forums :
    Inscription : juin 2009
    Messages : 3 801
    Points : 10 217
    Points
    10 217
    Billets dans le blog
    1

    Par défaut

    J'étais en train de brancher mon Pi pour faire des essais quand j'ai réalisé que le fichier /etc/hosts est un DNS local (https://www.makeuseof.com/tag/modify...ts-file-linux/). Il est sert au Raspberry Pi quand lui essaye de résoudre un nom d'hôte en adresse IP. Je ne suis pas sûr que ce soit ce qu'il faille utiliser dans ton cas.

    Sur ton client, le PC qui se connecte au Raspberry Pi, quel serveur DNS est renseigné ?

    EDIT : la première réponse de cette discussion confirme ce que je viens de dire https://superuser.com/questions/5919...dns-on-hotspot
    Changes on /etc/hosts file only affect the local machine.
    EDIT2 : la réponse à ton problème est sans doute dans le point 2 de cet article https://www.pcworld.com/article/3200...h-dnsmasq.html Il faut passer par dnsmasq. Cet article de la fondation Raspberry explique comment créer un hostpot https://www.raspberrypi.org/document...ccess-point.md et je pense que cet article devrait te dire comment rajouter ton serveur local https://www.linux.com/learn/dnsmasq-...-name-services

  5. #5
    Candidat au Club
    Homme Profil pro
    Technicien maintenance
    Inscrit en
    décembre 2017
    Messages
    6
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Burkina Faso

    Informations professionnelles :
    Activité : Technicien maintenance
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : décembre 2017
    Messages : 6
    Points : 2
    Points
    2

    Par défaut

    merci beaucoup! je vais suivre tes liens et voir où ça me mène. merci encore!

  6. #6
    Candidat au Club
    Homme Profil pro
    Technicien maintenance
    Inscrit en
    décembre 2017
    Messages
    6
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Burkina Faso

    Informations professionnelles :
    Activité : Technicien maintenance
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : décembre 2017
    Messages : 6
    Points : 2
    Points
    2

    Par défaut

    Salut a tous. ça fait un bout de temps. Désole pour ce silence radio, j’étais en pleine recherches. Vue que c'est mon premier poste de l'année, je vous souhaite pour l’occasion une très belle année.

    Alors... j'ai beaucoup avancé sur mon projet sur ma raspi3 (hot-spot=OK et résolution DNS=OK (grâce a Dnsmasq) site local=OK). Merci pour vos différentes aides. Mais voilà je bute sur un dernier problème. Lorsque je tape C.C dans mon navigateur (IE, Firefox etc....) tout marche correct: je tombe sur le site. par contre sur mobile (Android) ça ne marche pas du tout.Quelqu'un aurais une idée de ce qui cloche SVP?
    PS: le lien du tuto que j'ai utilisé pour la config DNShttp://doc.frapp.fr/doku.php?id=tuto...ur:rpi:unbound

  7. #7
    Modérateur

    Avatar de Bktero
    Homme Profil pro
    Ingénieur systèmes embarqués
    Inscrit en
    juin 2009
    Messages
    3 801
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 30
    Localisation : France, Loire Atlantique (Pays de la Loire)

    Informations professionnelles :
    Activité : Ingénieur systèmes embarqués

    Informations forums :
    Inscription : juin 2009
    Messages : 3 801
    Points : 10 217
    Points
    10 217
    Billets dans le blog
    1

    Par défaut

    Salut,

    Que te dit ton smartphone ?

  8. #8
    Candidat au Club
    Homme Profil pro
    Technicien maintenance
    Inscrit en
    décembre 2017
    Messages
    6
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Burkina Faso

    Informations professionnelles :
    Activité : Technicien maintenance
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : décembre 2017
    Messages : 6
    Points : 2
    Points
    2

    Par défaut

    Bahh rien justement. Ça m'indique que je suis hors connexion. Je précise tout de même que si j'entre l'adresse IP, ça marche correct.

  9. #9
    Modérateur

    Avatar de Bktero
    Homme Profil pro
    Ingénieur systèmes embarqués
    Inscrit en
    juin 2009
    Messages
    3 801
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 30
    Localisation : France, Loire Atlantique (Pays de la Loire)

    Informations professionnelles :
    Activité : Ingénieur systèmes embarqués

    Informations forums :
    Inscription : juin 2009
    Messages : 3 801
    Points : 10 217
    Points
    10 217
    Billets dans le blog
    1

    Par défaut

    Ton téléphone ne doit pas utiliser le bon serveur DNS.

  10. #10
    Candidat au Club
    Homme Profil pro
    Technicien maintenance
    Inscrit en
    décembre 2017
    Messages
    6
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Burkina Faso

    Informations professionnelles :
    Activité : Technicien maintenance
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : décembre 2017
    Messages : 6
    Points : 2
    Points
    2

    Par défaut

    c'est bon j'ai réussi a régler le problème. ça coinçait au niveau des caractères de mon nom de domaine. Merci pour l'aide

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Impossibilité de me connecter aux Hotspots Wifi.
    Par pb8808 dans le forum Réseau
    Réponses: 0
    Dernier message: 15/11/2011, 07h52
  2. Réponses: 15
    Dernier message: 01/11/2009, 15h09
  3. Réponses: 15
    Dernier message: 01/11/2009, 15h09
  4. création d'un serveur + hotspot wifi
    Par sermadiras nicolas dans le forum Réseau
    Réponses: 8
    Dernier message: 27/07/2009, 20h50
  5. Se méfier des Hotspots Wifi gratuits ?
    Par byloute dans le forum Sécurité
    Réponses: 7
    Dernier message: 05/08/2008, 10h27

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo