1. #1
    Futur Membre du Club
    Femme Profil pro
    developpeur fichiers
    Inscrit en
    janvier 2017
    Messages
    13
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : Canada

    Informations professionnelles :
    Activité : developpeur fichiers
    Secteur : Finance

    Informations forums :
    Inscription : janvier 2017
    Messages : 13
    Points : 9
    Points
    9

    Par défaut Comment mettre une condition N'est pas #N/A dans SOMMEPROD

    Bonjour,

    J'essaie d'écrire un sommeprod conditionnel dont l'une des conditions est "Pas #N/A". J'ai essayé

    =SOMMEPROD((Donnees!$BT$19:$BT$20=CF5)*(Donnees!$BS$19:$BS$20>=MOIS(Presentation!$AB$22))*(NON(ESTNA(Donnees!CF7:CF43)))*(Donnees!CF19:CF20*Donnees!CJ19:CJ20))

    ça n'a pas fonctionné

    J'ai aussi essayé

    Donnees!CF7:CF43 <> "#N/A" et ça n'a pas fonctionné non plus.

    Merci d'avance pour votre aide.

  2. #2
    Responsable
    Office & Excel

    Avatar de Pierre Fauconnier
    Homme Profil pro
    Formateur et développeur informatique indépendant
    Inscrit en
    novembre 2003
    Messages
    10 909
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 50
    Localisation : Belgique

    Informations professionnelles :
    Activité : Formateur et développeur informatique indépendant
    Secteur : Enseignement

    Informations forums :
    Inscription : novembre 2003
    Messages : 10 909
    Points : 27 238
    Points
    27 238
    Billets dans le blog
    14

    Par défaut

    Salut.

    ESTNA fonctionne très bien...

    Nom : 2017-12-06_204444.png
Affichages : 23
Taille : 9,1 Ko

    Es-tu certain que c'est un vrai #N/A dans les cellules? Teste-le sur une des cellules avec la fonction pour vérifier...

    Nom : 2017-12-06_203943.png
Affichages : 23
Taille : 7,6 Ko

    A la relecture de TA formule... (Dommage que tu n'as pas dit ce que tu obtenais comme erreur).

    Ta plage sur laquelle tu testes le #N/A n'a pas la même dimension que les autres... Tes plages doivent avoir le même nombre de lignes ou une seule ligne pour que SOMMEPROD puisse fonctionner.
    "Plus les hommes seront éclairés, plus ils seront libres" (Voltaire)
    ---------------
    Vous souhaitez rédiger pour DVP? Contactez-moi
    VBA pour Excel? Pensez D'ABORD en EXCEL avant de penser en VBA...
    Vous avez apprécié l'intervention => Merci pour le
    ---------------

  3. #3
    Futur Membre du Club
    Femme Profil pro
    developpeur fichiers
    Inscrit en
    janvier 2017
    Messages
    13
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : Canada

    Informations professionnelles :
    Activité : developpeur fichiers
    Secteur : Finance

    Informations forums :
    Inscription : janvier 2017
    Messages : 13
    Points : 9
    Points
    9

    Par défaut

    Merci pour la réponse!

    Oui, j'ai corrigé ma formule. Je l'ai tout d'abord essayée dans une zone où il n'y avait pas de #N/A et elle fonctionne. Quand j'élargis pour inclure la zone où il y a un #N/A, la réponse est... #N/A


    Mais j'ai compris pourquoi la réponse est #N/A. C'est parce que dans une des colonnes multipliantes, il y a des N/A. Quand j'ai utilisé le somme.si, ça fonctionnait même si il y avait des #N/A dans la colonne. Je ne comprends pas pourquoi ça ne fonctionne pas dans le sommeprod.

  4. #4
    Futur Membre du Club
    Femme Profil pro
    developpeur fichiers
    Inscrit en
    janvier 2017
    Messages
    13
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : Canada

    Informations professionnelles :
    Activité : developpeur fichiers
    Secteur : Finance

    Informations forums :
    Inscription : janvier 2017
    Messages : 13
    Points : 9
    Points
    9

    Par défaut

    Rebonjour,

    J'ai résolu le problème!

    Voici comment : il faut utiliser sierreur et le mode matriciel

    =SOMMEPROD(($CC$18:$CC$20=CF5)*($CB$18:$CB$20>=MOIS(Presentation!$AB$22))*(SIERREUR(CF18:CF20;0)*CJ18:CJ20))

    ne pas oublier de faire CTL-Shft-Enter

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. [XL-2013] Afficher un userform tant qu'une condition n'est pas realisée
    Par Nono Sto dans le forum Macros et VBA Excel
    Réponses: 3
    Dernier message: 06/09/2014, 00h57
  2. Réponses: 4
    Dernier message: 06/03/2010, 12h29
  3. [Tableaux] Comment mettre une condition sur une variable?
    Par faucon54 dans le forum Fonctions
    Réponses: 8
    Dernier message: 16/05/2007, 22h16
  4. Réponses: 3
    Dernier message: 03/05/2007, 12h06
  5. Réponses: 1
    Dernier message: 08/09/2006, 11h31

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo