IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

WebDev Discussion :

accès site externe webdev avec envoi de parametre


Sujet :

WebDev

  1. #1
    Nouveau Candidat au Club
    Homme Profil pro
    Administrateur systèmes et réseaux
    Inscrit en
    novembre 2017
    Messages
    3
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Corse (Corse)

    Informations professionnelles :
    Activité : Administrateur systèmes et réseaux
    Secteur : Administration - Collectivité locale

    Informations forums :
    Inscription : novembre 2017
    Messages : 3
    Points : 1
    Points
    1
    Par défaut accès site externe webdev avec envoi de parametre
    bonjour

    j'ai deux site webdev, je m'identifie sur le premier et je veux accéder au deuxième sans ressaisir les login et passe

    le premier site (via un bouon) appelle le second : NavigateurOuvre(lien_du_site+variable_identifiant_utilisateur, "SITE")

    le lien du site est un lien du type : http://adresse.fr/nom_du_projet/inde...ssible&PARAM2=
    le PARAM2 recoit bien la valeur et j'arrive a me connecté .... sauf que dans la barre d'adresse rien n'est cacher et on peut modifier les variable PARAM1 et PARAM2

    j'ai essayer de créer une page index_bis.html sur le serveur avec comme code :

    Code html : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    <HTML>
    <HEAD>
    <TITLE>NOm du site</TITLE>
    </HEAD>
    <FRAMESET>
    <FRAME src="http://adresse.fr/nom_du_projet/index.html?PARAM1=accessible&PARAM2="  name="SITE" >
    </FRAMESET>
    </HTML>

    mais je n'arrive pas a lui envoyer des paramètres !

    au final j’aurais voulu une adresse du genre http://adresse.fr/index_bis.html mais avec la réception des paramètres invisible pour l’utilisateur final

    par avance merci

  2. #2
    Membre confirmé

    Profil pro
    Inscrit en
    mars 2002
    Messages
    1 184
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2002
    Messages : 1 184
    Points : 608
    Points
    608
    Par défaut
    Bonjour,

    Je connais WinDev pas WebDev
    Dans le cas de votre besoin une ligne avec window.location (donc HTML + Javascript) permet d'obtenir ce résultat.
    Par contre il faut encoder (et donc décoder) les paramètres. Ils ne sont pas visibles par l'utilisateur mais le deviennent si on ouvre le code de la page

  3. #3
    Membre habitué
    Profil pro
    Inscrit en
    février 2007
    Messages
    120
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : février 2007
    Messages : 120
    Points : 149
    Points
    149
    Par défaut
    Bonjour,

    T'as essayé de passer les mêmes paramètres en POST?

  4. #4
    Nouveau Candidat au Club
    Homme Profil pro
    Administrateur systèmes et réseaux
    Inscrit en
    novembre 2017
    Messages
    3
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Corse (Corse)

    Informations professionnelles :
    Activité : Administrateur systèmes et réseaux
    Secteur : Administration - Collectivité locale

    Informations forums :
    Inscription : novembre 2017
    Messages : 3
    Points : 1
    Points
    1
    Par défaut
    bonjour

    merci pour vos réponses

    j'ai essayer de crypter le num utilisateur sur le premier site et de le récupérer sur le second en le décryptant (sans succès)

    j'ai essayer avec POST (mais je maitrise pas) .... je vais creuser un peu plus et je reviens vers vous

    merci

  5. #5
    Nouveau Candidat au Club
    Homme Profil pro
    Administrateur systèmes et réseaux
    Inscrit en
    novembre 2017
    Messages
    3
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Corse (Corse)

    Informations professionnelles :
    Activité : Administrateur systèmes et réseaux
    Secteur : Administration - Collectivité locale

    Informations forums :
    Inscription : novembre 2017
    Messages : 3
    Points : 1
    Points
    1
    Par défaut
    j'ai modifier un exemples Webdev :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    Url est une chaîne 
    Res_HTTP est une chaîne
    Erreurhttp est une chaîne
     
    Url="http://nom_du_site.fr/WD200AWP/WD200Awp.exe/CONNECT/nom_projet?PART01=acces"
     
    // je lance http requête avec comme paramètre le numéro d'utilisateur
    SI HTTPRequête(Url,"","","ID="+ID_UTILISATEUR) ALORS
    	Res_HTTP = HTTPDonneRésultat()
    	SI Taille(Res_HTTP) = 0 ALORS
    		Erreurhttp = HTTPDonneRésultat(httpEntête)
    		Erreur(Erreurhttp)
    	FIN
    FIN
    mais cela ne marche pas

Discussions similaires

  1. Réponses: 3
    Dernier message: 27/12/2011, 11h18
  2. Réponses: 10
    Dernier message: 06/06/2011, 12h45
  3. [STRUTS]Envoi de parametre avec un lien hmtl:link
    Par hinanui dans le forum Struts 1
    Réponses: 33
    Dernier message: 26/07/2005, 16h59

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo