1. #1
    Membre actif

    Homme Profil pro
    Consultant informatique
    Inscrit en
    septembre 2011
    Messages
    323
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Consultant informatique
    Secteur : Industrie

    Informations forums :
    Inscription : septembre 2011
    Messages : 323
    Points : 241
    Points
    241

    Par défaut Erreur 302 : ProxyPass / ProxyPassReverse avec tomcat

    Bonjour,
    Je cherche à passer au travers d'un firewall un peu pénible. je n'ai le droit qu'au port 80 et 443, déjà utilisé.

    je veux accéder à mon application via: http://mon-site.fr/app1. Cette application est une application tomcat écoutant sur le port 9011.
    Pour le port 80, je fait ceci sur apache.
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    <IfModule mod_proxy.c>
     ProxyRequests Off
     ProxyVia Off
     ProxyPreserveHost Off
    </IfModule>
    ProxyPass /app1 http://localhost:9011
    ProxyPassReverse /app1 http://localhost:9011
    et ceci sur tomcat:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    <Connector port="9011" protocol="HTTP/1.1"
    connectionTimeout="20000"
    proxyName="http://mon-site.fr"
    proxyPort="80"
    redirectPort="9012" />
    J'ai une erreur 302. Je ne sait pas d'ou ca vient. Une idée?
    Cordialement,
    Vandman

  2. #2
    Membre éprouvé
    Homme Profil pro
    Développeur multimédia
    Inscrit en
    juillet 2004
    Messages
    678
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur multimédia
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : juillet 2004
    Messages : 678
    Points : 1 128
    Points
    1 128

    Par défaut

    Généralement l'erreur évoque une erreur de script ou de configuration d'un serveur voir d'une mauvaise configuration du firewall qui bloque les requêtes.
    La conduite a tenir, checker les logs des différents serveurs mise en jeux, tomcat, apache... afin d'en savoir un peu plus sans ça c'est le brouillard total.
    De plus est-ce normale cette syntax pour ton proxyName?
    ...
    proxyName="http://http://mon-site.fr"
    ...

  3. #3
    Membre actif

    Homme Profil pro
    Consultant informatique
    Inscrit en
    septembre 2011
    Messages
    323
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Consultant informatique
    Secteur : Industrie

    Informations forums :
    Inscription : septembre 2011
    Messages : 323
    Points : 241
    Points
    241

    Par défaut

    Bonjour,
    Je viens de corriger: proxyName="http://http://mon-site.fr".
    Par contre, les logs ne me donne pas plus d’informations.

    Cordialement,
    Vandman

  4. #4
    Membre éprouvé
    Homme Profil pro
    Développeur multimédia
    Inscrit en
    juillet 2004
    Messages
    678
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur multimédia
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : juillet 2004
    Messages : 678
    Points : 1 128
    Points
    1 128

    Par défaut

    Je suis pas sur que tu es besoin du http aussi dans ton fichier configuration du connector tu peux nous dire sous quel environnement tu es?

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
     
    <Connector port="9011" protocol="HTTP/1.1"
    connectionTimeout="20000"
    proxyName="mon-site.fr" //ou www.mon-site.fr
    proxyPort="80"
    redirectPort="9012" />

  5. #5
    Membre actif

    Homme Profil pro
    Consultant informatique
    Inscrit en
    septembre 2011
    Messages
    323
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Consultant informatique
    Secteur : Industrie

    Informations forums :
    Inscription : septembre 2011
    Messages : 323
    Points : 241
    Points
    241

    Par défaut

    Bonjour,
    J'ai retiré le http:// dans le connecteur.

    Je suis sous linux ubuntu 16.04 avec un tomcat (apache-tomcat-7.0.78) installé depuis le tar du site tomcat.

    j'ai remarqué que le comportement n'est pas le même si je tape:
    mon-site.fr/app1 (1)
    mon-site.fr/app1/ (2)

    (1) => erreur 302
    (2) => erreur 404 avec mon-site.fr/login.html au lieu de mon-site.fr/app1/login.html

    Cordialement,
    Pierre NIKOLOV

  6. #6
    Membre éprouvé
    Homme Profil pro
    Développeur multimédia
    Inscrit en
    juillet 2004
    Messages
    678
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur multimédia
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : juillet 2004
    Messages : 678
    Points : 1 128
    Points
    1 128

    Par défaut

    je suis sous linux ubuntu 16.04 avec un tomcat (apache-tomcat-7.0.78) installé depuis le tar du site tomcat.
    Désolé pour le temps de réponse pour ne pas refaire la musique je te conseil de regarder ce type de tuto bien documenté http://www.supinfo.com/articles/sing...serveur-tomcat

  7. #7
    Membre actif

    Homme Profil pro
    Consultant informatique
    Inscrit en
    septembre 2011
    Messages
    323
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Consultant informatique
    Secteur : Industrie

    Informations forums :
    Inscription : septembre 2011
    Messages : 323
    Points : 241
    Points
    241

    Par défaut

    Bon,
    A priori, ce que je demande n'est pas possible cf. ce lien
    Merci tout de même.

    je vais demander a mes services de me créer des sous-domaines
    app1.mon-site.fr
    app2.mon-site.fr
    app3.mon-site.fr
    Au moins là, je sais faire.

    C'est domage qu'on ne puisse pas faire l'inverse???
    mon-site.fr/app1/
    mon-site.fr/app2/
    mon-site.fr/app3/

    Cordialement,
    Vandman

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Téléchargement d'un fichier avec IdHTTP (erreur 302)
    Par Webco dans le forum C++Builder
    Réponses: 3
    Dernier message: 07/04/2009, 12h14
  2. Traitement des erreurs avec Tomcat
    Par ingdev dans le forum Tomcat
    Réponses: 11
    Dernier message: 14/01/2009, 17h55
  3. Erreur avec Tomcat: Etat HTTP 500
    Par bene86 dans le forum Tomcat
    Réponses: 1
    Dernier message: 16/06/2008, 18h16
  4. Réponses: 14
    Dernier message: 08/08/2007, 19h36

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo