1. #1
    Membre à l'essai
    Inscrit en
    décembre 2010
    Messages
    8
    Détails du profil
    Informations forums :
    Inscription : décembre 2010
    Messages : 8
    Points : 15
    Points
    15

    Par défaut Protection de répertoire avec AuthType mais sans .htaccess

    Hello à toutes et à tous;
    Je tourne sous debian 7 avec Apache 2.
    Je souhaite protéger le repertoire PostfixAdmin, PhpMyAdmin et d'autres sauf que mes manipulations ne fonctionnent pas
    avec le .htpasswd au bonne emplacement et un user/password crypté dedans mais rien n'y fait même en essayant de restreindre d'autres répertoires...

    Une idée ?

    Je relance bien le serveur après mes manips et je ne veux pas utiliser de fichier .htaccess

    Dans /etc/apache2/sites-available/mondomaine.com j'ai mis:

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    47
    48
    49
    50
    51
    52
    53
    54
    55
    56
    57
    58
    59
    60
    61
    62
    63
    64
    65
    66
    67
    68
    69
    70
    71
    72
    73
    74
    75
    76
    77
    78
    79
    <VirtualHost *:80>
    	ServerAdmin webmaster@localhost
    	ServerName mondomaine.com/postfixadmin
    	DocumentRoot /var/www/mondomaine.com/
     
    	<Directory /usr/share/postfixadmin/>
        	AuthType Basic
        	AuthName "Page PostfixAdmin"
        	AuthUserFile /etc/postfixadmin/.htpasswd
        	Require valid-user
    	</Directory>
    </VirtualHost>
     
    <VirtualHost *:80>
            ServerAdmin webmaster@localhost
            ServerName newsletter.mondomaine.com
            DocumentRoot /var/www/mondomaine.com/newsletter/
     
    	<Directory /var/www/mondomaine.com/newsletter/>
            AuthType Basic
            AuthName "Page PostfixAdmin"
            AuthUserFile /etc/postfixadmin/.htpasswd
            Require valid-user
            </Directory>
    </VirtualHost>
     
    <VirtualHost *:80>
    	ServerAdmin webmaster@localhost
            ServerName mondomaine.com
            DocumentRoot /var/www/mondomaine.com/
     
    	<Directory />
    		Options FollowSymLinks
    		AllowOverride None
    	</Directory>
     
    	ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    	<Directory "/usr/lib/cgi-bin">
    		AllowOverride None
    		Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    		Order allow,deny
    		Allow from all
    	</Directory>
     
    	ErrorLog ${APACHE_LOG_DIR}/error.log
     
    	# Possible values include: debug, info, notice, warn, error, crit,
    	# alert, emerg.
    	LogLevel warn
     
    	CustomLog ${APACHE_LOG_DIR}/access.log combined
     
    	## Redirection phpmyadmin ajouté
    	Alias /phpmyadmin /usr/share/phpmyadmin
    	<Directory /user/share/phpmyadmin/>
            AuthType Basic
            AuthName "Page PostfixAdmin"
            AuthUserFile /etc/postfixadmin/.htpasswd
            Require valid-user
            </Directory>
     
    	<Directory /usr/share/phpmyadmin>
            Options FollowSymLinks
            DirectoryIndex index.php
     
            <IfModule mod_php5.c>
                    AddType application/x-httpd-php .php
     
                    php_flag magic_quotes_gpc Off
                    php_flag track_vars On
                    php_flag register_globals Off
                    php_admin_flag allow_url_fopen Off
                    php_value include_path .
                    php_admin_value upload_tmp_dir /var/lib/phpmyadmin/tmp
                    php_admin_value open_basedir /usr/share/phpmyadmin/:/etc/phpmyadmin/:/var/lib/phpmyadmin/
            </IfModule>
     
    </Directory>
    </VirtualHost>
    Merci d'avance pour vos retours.

    PS: J'ajoute le fichier default au cas ou
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    47
    <VirtualHost *:80>
    	ServerAdmin webmaster@localhost
    	ServerName default
     
    	DocumentRoot /var/www/
    	<Directory />
    		Options -indexes
    		AllowOverride None
    	</Directory>
    	<Directory /var/www/>
    		Options MultiViews
    		AllowOverride None
    		Order allow,deny
    		deny from all
    	</Directory>
    	<Directory /usr/share/phpmyadmin>
            Options FollowSymLinks
            DirectoryIndex index.php
            Order Deny,Allow
            Allow from 192.168.1.0/24
            Deny from All
    	</Directory>
     
    	ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    	<Directory "/usr/lib/cgi-bin">
    		AllowOverride None
    		Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    		Order allow,deny
    		Allow from all
    	</Directory>
     
    	<Location /adm>
    		AuthUserFile /etc/munin/munin-htpasswd
    		AuthGroupFile /dev/null
    		AuthName "Accès protégé"
    		AuthType Basic
    		Require valid-user
    	</Location>
     
    	ErrorLog ${APACHE_LOG_DIR}/error.log
     
    	# Possible values include: debug, info, notice, warn, error, crit,
    	# alert, emerg.
    	LogLevel warn
     
    	CustomLog ${APACHE_LOG_DIR}/access.log combined
    </VirtualHost>

  2. #2
    Expert éminent sénior
    Avatar de mathieu
    Profil pro
    Inscrit en
    juin 2003
    Messages
    6 473
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2003
    Messages : 6 473
    Points : 10 375
    Points
    10 375

    Par défaut

    Qu'est ce qui ne fonctionne pas ?
    Le mot de passe n'est pas demandé ou alors vous avez le message "accès refusé" même quand vous saisissez le bon mot de passe ?

  3. #3
    Membre à l'essai
    Inscrit en
    décembre 2010
    Messages
    8
    Détails du profil
    Informations forums :
    Inscription : décembre 2010
    Messages : 8
    Points : 15
    Points
    15

    Par défaut

    Hello Mathieu,
    Merci d'avoir pris le temps de me répondre.
    Effectivement rien ne se passe, j'accède au répertoire normalement et aucun message m'invitant à mettre mon mdp...

Discussions similaires

  1. Réponses: 4
    Dernier message: 06/04/2010, 11h36
  2. Réponses: 4
    Dernier message: 11/05/2009, 16h59
  3. Requete avec count mais sans grouper.
    Par fabrice91 dans le forum Requêtes
    Réponses: 19
    Dernier message: 29/04/2009, 17h25
  4. Protection de répertoire avec autentification LDAP
    Par Dr_maïs dans le forum Apache
    Réponses: 5
    Dernier message: 25/02/2008, 13h14

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo