IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

WebDev Discussion :

Déploiement site Erreur 401 [WB22]


Sujet :

WebDev

  1. #1
    Membre du Club
    Profil pro
    Inscrit en
    août 2009
    Messages
    70
    Détails du profil
    Informations personnelles :
    Localisation : France, Loire (Rhône Alpes)

    Informations forums :
    Inscription : août 2009
    Messages : 70
    Points : 53
    Points
    53
    Par défaut Déploiement site Erreur 401
    Bonjour,

    J'essaye, depuis plusieurs jours, de déployer mon site Webdev à distance sur un serveur local Windows Server 2016 avec IIS.

    J'ai suivi le tuto détaillé à la lettre mais j'ai une erreur lorsque je tente le déploiement.

    Erreur de serveur
    401 - Non autorisé: accès refusé en raison d'informations d'identification non valides.
    Vous n'avez pas l'autorisation d'afficher ce répertoire ou cette page à l'aide des informations d'identification que vous avez fournies.

    Ci-dessous mon répertoire avec le dossier ftp_webdev qui s'est crée tout seul avec des fichiers .tmp à l'intérieur

    Nom : Repertoire.PNG
Affichages : 661
Taille : 53,3 Ko

    Les paramètres du compte dans l'administrateur Webdev :

    Nom : Compte.PNG
Affichages : 643
Taille : 89,1 Ko

    Avez-vous une idée ?

    Merci

  2. #2
    Membre actif
    Homme Profil pro
    Développeur WEB - Admin Réseaux
    Inscrit en
    décembre 2004
    Messages
    153
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Cantal (Auvergne)

    Informations professionnelles :
    Activité : Développeur WEB - Admin Réseaux
    Secteur : Distribution

    Informations forums :
    Inscription : décembre 2004
    Messages : 153
    Points : 286
    Points
    286
    Par défaut
    Bonjour,

    Est que tes répertoires ont l'utilisateur IIS_IUSRS d'autorisé.
    C'est l'utilisateur de IIS.

    Bon dev.

  3. #3
    Membre du Club
    Profil pro
    Inscrit en
    août 2009
    Messages
    70
    Détails du profil
    Informations personnelles :
    Localisation : France, Loire (Rhône Alpes)

    Informations forums :
    Inscription : août 2009
    Messages : 70
    Points : 53
    Points
    53
    Par défaut
    Non.

    Je viens de le rajouter sur mon répertoire et dans le registre mais l'erreur est la même.

  4. #4
    Membre du Club
    Profil pro
    Inscrit en
    août 2009
    Messages
    70
    Détails du profil
    Informations personnelles :
    Localisation : France, Loire (Rhône Alpes)

    Informations forums :
    Inscription : août 2009
    Messages : 70
    Points : 53
    Points
    53
    Par défaut
    J'ai résolu la moitié du problème.

    J'arrive bien à déployer mon site mais lorsque j'y accède, ca me dit que le fichier du projet .wdl est introuvable.

    Erreur 30 Accès refusé (5).

    A l'intérieur du répertoire cité, mon fichier est bien présent mais on dirait un problème de droits.

    EDIT : Problème résolu en mettant les droits d'accès sur mon répertoire FTP pour le groupe IIS_IUSRS

  5. #5
    Membre habitué
    Profil pro
    Inscrit en
    février 2007
    Messages
    120
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : février 2007
    Messages : 120
    Points : 149
    Points
    149
    Par défaut
    J'ai gérer ce cas là différemment.

    Dans le code du projet, j'ai déclarer le code en exception et rediriger l'exception/l'erreur vers une page erreur créer.

    Pensez a faire pareil pour l'Hyperfile.

  6. #6
    Invité
    Invité(e)
    Par défaut
    Bonjour,
    J'ai pu déployer mon 1er site webdev chez un client qui a également un windows server 2016 sur IIS, ce qu'on a fait dans IIS :
    - l'authentification au niveau du répertoire virtuel se fait sur l'identité du pool d'applications
    - l'authentification au niveau du site se fait sur l'identité du pool d'applications
    - dans le paramétrage du pool d'applications, nous avons fait appel à un utilisateur windows qui a les droits pour accéder au répertoire virtuel dont lequel le mot de passe de sa session windows n'expire jamais et ne change jamais.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Déploiement site web erreur
    Par BOUHH37 dans le forum Symfony
    Réponses: 17
    Dernier message: 28/06/2016, 00h00
  2. [IIS 7] Erreur 401 sur mon site
    Par hirochirak dans le forum IIS
    Réponses: 2
    Dernier message: 20/08/2014, 10h20
  3. (NB6.7.1,JPA) erreur 401 (accès refusé) au déploiement
    Par olivier57b dans le forum NetBeans
    Réponses: 6
    Dernier message: 15/08/2009, 15h01
  4. [Mail] ERREUR 401 petit souci
    Par depelek dans le forum Langage
    Réponses: 7
    Dernier message: 07/12/2006, 17h11
  5. Erreur 401 + IIS
    Par DiabloZizi dans le forum Autres Logiciels
    Réponses: 10
    Dernier message: 25/03/2006, 12h26

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo