Discussion: somme totale si une valeur le permet [LibreOffice][Tableur]

  1. #1
    Futur Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    mars 2016
    Messages
    8
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 21
    Localisation : France, Hérault (Languedoc Roussillon)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : mars 2016
    Messages : 8
    Points : 5
    Points
    5

    Par défaut somme totale si une valeur le permet

    Bonjour à toutes et à tous!
    Il me manque un petit algorithme que je n'arrive pas à bien saisir.
    Voici ce que je voudrais faire :
    Nom : Screenshot_1.png
Affichages : 32
Taille : 15,7 Ko

    j'avais fait cette fonction mais elle ne fonctionne pas : SOMME(SI((B2:B3="HJ");C2:C3;0))
    merci d'avance de votre aide précieuse 😉

  2. #2
    Membre actif
    Homme Profil pro
    utilisateur
    Inscrit en
    janvier 2017
    Messages
    126
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 56
    Localisation : France

    Informations professionnelles :
    Activité : utilisateur
    Secteur : Service public

    Informations forums :
    Inscription : janvier 2017
    Messages : 126
    Points : 214
    Points
    214

    Par défaut

    Bonjour aielloine,

    votre formule "SOMME(SI((B2:B3="HJ");C2:C3;0))" est correcte hormis qu'elle ne se réfère pas aux bonnes colonnes

    D'après l'image jointe la formule devrait être :

    En N4
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    =SOMME(SI((I2:I5="HJ");J2:J5;0))
    En N5
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    =SOMME(SI((I2:I5="HC");J2:J5;0))
    En N6
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    =SOMME(SI((I2:I5="PED");J2:J5;0))

  3. #3
    Futur Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    mars 2016
    Messages
    8
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 21
    Localisation : France, Hérault (Languedoc Roussillon)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : mars 2016
    Messages : 8
    Points : 5
    Points
    5

    Par défaut

    Ah oui mince j'ai déplacé les collones après avoir fait le screen
    Merci de votre réponse mais le total m'affiche toujours 0 :/

  4. #4
    Futur Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    mars 2016
    Messages
    8
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 21
    Localisation : France, Hérault (Languedoc Roussillon)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : mars 2016
    Messages : 8
    Points : 5
    Points
    5

    Par défaut

    Voici ce que j'ai après toute rectification..
    Nom : Screenshot_2.png
Affichages : 19
Taille : 13,3 Ko

  5. #5
    Membre actif
    Homme Profil pro
    utilisateur
    Inscrit en
    janvier 2017
    Messages
    126
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 56
    Localisation : France

    Informations professionnelles :
    Activité : utilisateur
    Secteur : Service public

    Informations forums :
    Inscription : janvier 2017
    Messages : 126
    Points : 214
    Points
    214

    Par défaut

    Bonjour aielloine,

    Vous conviendrez que votre exemple initial manquait cruellement de lignes pour deviner qu'il vous en faudrait un millier, et un millier ne se gère pas comme une paire voilà donc la formule à utiliser

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    =SOMME.SI.ENS(C2:C1000;B2:B1000;"HJ")

  6. #6
    Futur Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    mars 2016
    Messages
    8
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 21
    Localisation : France, Hérault (Languedoc Roussillon)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : mars 2016
    Messages : 8
    Points : 5
    Points
    5

    Par défaut

    Bonjour njhub,
    je ne l'avais pas dit pour pas trop compliquer les choses, je pensais pas que ça pouvait influencer sur les calculs..
    merci beaucoup pour votre aide tout marche maintenant a merveille!

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. [XL-2013] Somme annuelle d'une valeur qui double tous les mois
    Par alberick dans le forum Excel
    Réponses: 2
    Dernier message: 17/06/2017, 14h12
  2. Combinaison de nombres dont la somme est inférieure à une valeur
    Par senacle dans le forum Général Algorithmique
    Réponses: 23
    Dernier message: 31/05/2016, 13h20
  3. [Access] somme de 2 colonnes même qd une valeur nulle ?
    Par kikidrome dans le forum Langage SQL
    Réponses: 4
    Dernier message: 26/01/2008, 20h18
  4. Réponses: 8
    Dernier message: 27/06/2006, 08h40
  5. access : calcul d'une somme de 0 sans valeur par défaut
    Par ericbelgium dans le forum Access
    Réponses: 6
    Dernier message: 06/10/2005, 10h05

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo