1. #1
    Membre averti
    Homme Profil pro
    Inscrit en
    novembre 2008
    Messages
    596
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Loire Atlantique (Pays de la Loire)

    Informations forums :
    Inscription : novembre 2008
    Messages : 596
    Points : 322
    Points
    322

    Par défaut Problème avec Setfocus sur un formulaire tabulaire modifiable

    Bonjour,

    J'effectue des contrôles lors de la saisie sur un formulaire tabulaire modifiable. Si la saisie n'est pas correcte, je dois me repositionner sur le champ en question.

    Pour cela, j'ai codé:

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    Forms!mon_formulaire!mon_champ.setfocus
    Cela ne fonctionne pas !


    Merci d'avance.
    Julien.

  2. #2
    Rédacteur/Modérateur
    Avatar de loufab
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    avril 2005
    Messages
    10 575
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : avril 2005
    Messages : 10 575
    Points : 21 449
    Points
    21 449

    Par défaut

    Bonjour,

    Le code est correct. Inutile d'utiliser les !, utilises des . à la place.

    Où as-tu placé le code ?

    Si tu mets un point d'arrêt sur la ligne est qu'elle s'active ?

    Cordialement,
    Détecter les modifications formulaire Cloud storage et ACCESS
    Classe MELA(CRUD) Opérateur IN et zone de liste Opérateur LIKE
    Visitez mon Blog
    Les questions techniques par MP ne sont pas lues et je ne pratique pas la bactériomancie

  3. #3
    Membre averti
    Homme Profil pro
    Inscrit en
    novembre 2008
    Messages
    596
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Loire Atlantique (Pays de la Loire)

    Informations forums :
    Inscription : novembre 2008
    Messages : 596
    Points : 322
    Points
    322

    Par défaut

    J'ai mis et cela fonctionne.

    Merci quand même.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. [AC-2016] Problème d'exclusive lock sur un formulaire tabulaire
    Par juju05 dans le forum Access
    Réponses: 0
    Dernier message: 17/05/2017, 16h42
  2. Prob avec PHP sur le formulaire de contact
    Par inferno66667 dans le forum Formulaires
    Réponses: 7
    Dernier message: 16/11/2005, 17h06
  3. Problèmes avec INTERSECT sur MYSQL
    Par zarbydigital dans le forum Requêtes
    Réponses: 1
    Dernier message: 27/09/2005, 13h18
  4. Problème avec OnDrawColumnCell sur un DBGrid
    Par n1portki dans le forum Composants VCL
    Réponses: 3
    Dernier message: 23/09/2005, 04h18
  5. Problème avec RDTSC sur K6-III
    Par le mage tophinus dans le forum x86 32-bits / 64-bits
    Réponses: 17
    Dernier message: 30/09/2003, 09h43

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo