IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Composants VCL Delphi Discussion :

[Delphi][04/10/2017] JCL /JVCL Tokyo starter


Sujet :

Composants VCL Delphi

  1. #21
    Membre chevronné

    Profil pro
    Inscrit en
    août 2005
    Messages
    909
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : août 2005
    Messages : 909
    Points : 1 781
    Points
    1 781
    Par défaut
    Bonjour
    J'avais réussi sans problème l'installation pour Berlin avec Getit par contre à la mise à jour vers Tokyo 10.2.1 j'ai retenté l'installation via Getit dès la sortie et si JCL s'était installée sans problème la JVCL n'avait rien voulu savoir (toujours de petites erreurs de compilation). Comme je n'ai pas besoin de la JVCL je n'ai pas retenté depuis, par contre d'autres composants (dont j'avais besoin) via getit qui ne s'installaient pas (ie. Treeview) se dont installés sans problème une semaine plus tard !
    Merci pour la réponse.

    Pour info, par curiosité, j'ai testé Getit avec justement lockbox (lockbox2 et lockbox3) : ça s'installe, ça se désinstalle, avec un message de succès, mais quand on regarde de plus près la désinstallation semble incomplète : notamment les .dcp et .bpl qui ne sont pas supprimés. Bon ça gène pas (pas de message d'erreur au lancement de Delphi) mais avoir plein de fichiers résiduels qui servent a rien j'aime pas trop.

    Par ailleurs des qu'on a cliqué sur 'Installer" c'est parti ... il n'y a pas de message de confirmation (genre voulez vous continuer, choix de l'emplacement d'installation etc.). Les messages défilent a toute vitesse ...
    On fini certes par retrouver ou ça a été installé.

    La description des packages est indigente et se limite à une courte phrase qui ne permet pas d'installer en connaissance de cause.. (dans le cas de lockbox 2 et 3 qui suivant lockbox 3 sont des choses très différentes on ne sait pas exactement quelle version installer )
    On ne sait d'ailleurs pas comme l'a dit Sergio Master quelle version précise va être installée.

    De tout cela, pour du développement loisir occasionnel, j'oublie donc pour le moment Getit.

  2. #22
    Rédacteur/Modérateur

    Avatar de SergioMaster
    Homme Profil pro
    Développeur informatique
    Inscrit en
    janvier 2007
    Messages
    13 215
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 65
    Localisation : France, Loire Atlantique (Pays de la Loire)

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : Industrie

    Informations forums :
    Inscription : janvier 2007
    Messages : 13 215
    Points : 35 909
    Points
    35 909
    Billets dans le blog
    54
    Par défaut
    Bonjour
    Citation Envoyé par gaby277 Voir le message
    Pour info, par curiosité, j'ai testé Getit avec justement lockbox (lockbox2 et lockbox3) : ça s'installe, ça se désinstalle, avec un message de succès, mais quand on regarde de plus près la désinstallation semble incomplète : notamment les .dcp et .bpl qui ne sont pas supprimés. Bon ça gène pas (pas de message d'erreur au lancement de Delphi) mais avoir plein de fichiers résiduels qui servent a rien j'aime pas trop.
    merci de ce retour

    La description des packages est indigente et se limite à une courte phrase qui ne permet pas d'installer en connaissance de cause..
    en général, il vaut mieux faire un tour sur le lien de l'éditeur avant histoire de savoir de quoi il s'agit exactement

    Par ailleurs des qu'on a cliqué sur 'Installer" c'est parti ... il n'y a pas de message de confirmation (genre voulez vous continuer, choix de l'emplacement d'installation etc.). Les messages défilent a toute vitesse ...
    On fini certes par retrouver ou ça a été installé.
    il me semble que c'est toujours dans user/public/embarcadero/<version>/bpl pour info dans le répertoire user/public/embarcadero/<version> il y a un fichier GetitInstall.log très intéressant à lire.
    C'est vrai que cette partie installation pêche sur le choix de l'emplacement désiré, en téléchargeant directement le composant via la page de l'éditeur (donc sans passer par getit) c'est possible par contre. C'est donc un choix à faire ("Getit or not Getit that is the question" écrirait Shakespeare )
    Delphi installés : D3,D7,D2010,XE4,XE7,D10 (Tokyo, Rio, Sidney) ,D11 (Alexandria)
    SGBD : Firebird 2.5, 3, SQLite
    générateurs Etats : FastReport, Rave, QuickReport
    OS : Window Vista, Windows 10, Ubuntu, Androïd

+ Répondre à la discussion
Cette discussion est résolue.
Page 2 sur 2 PremièrePremière 12

Discussions similaires

  1. Problème à l'installation des composants Jcl/Jvcl
    Par Kikim dans le forum Composants VCL
    Réponses: 15
    Dernier message: 23/02/2021, 13h41
  2. Réponses: 6
    Dernier message: 31/08/2017, 10h47
  3. XE starter installation de la jcl jvcl
    Par gaby277 dans le forum EDI
    Réponses: 4
    Dernier message: 01/11/2016, 15h00
  4. [Delphi XE2] Installation de la JVCL 3.47
    Par Charly910 dans le forum Composants VCL
    Réponses: 1
    Dernier message: 29/09/2012, 19h50
  5. Installation JCL-JVCL 3.36 et INDY10 sous D2009
    Par trident_job dans le forum Composants VCL
    Réponses: 1
    Dernier message: 31/03/2009, 22h26

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo